summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 12 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index f1eb62b57..2a18f4f47 100755
--- a/debian/rules
+++ b/debian/rules
@@ -131,7 +131,7 @@ clean:
rm -rf build
# Add here commands to clean up after the build process.
- dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
+ dh_clean debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
binary-indep: apt-doc libapt-pkg-doc
# Build architecture-independent files here.
@@ -186,6 +186,7 @@ apt-doc: build-doc
# Build architecture-dependent files here.
binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
+apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
apt: build build-doc debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
@@ -213,8 +214,10 @@ apt: build build-doc debian/shlibs.local
cp debian/bugscript debian/$@/usr/share/bug/apt/script
cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
- cp share/debian-archive.gpg debian/$@/usr/share/$@
+ cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
+ sed 's/^_//' share/apt-auth-failure.note > debian/$@/usr/share/$@/apt-auth-failure.note
cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
+ cp debian/apt.conf.ubuntu debian/$@/etc/apt/apt.conf.d/01ubuntu
# head -n 500 ChangeLog > debian/ChangeLog
# copy lintian override
@@ -225,8 +228,12 @@ apt: build build-doc debian/shlibs.local
rm -f build/po/*.pot
rm -f po/*.pot
+ # move the mirror failure script in place
+ mv debian/$@/usr/bin/apt-report-mirror-failure \
+ debian/$@/usr/lib/apt/apt-report-mirror-failure \
+
dh_installexamples -p$@ $(BLD)/docs/examples/*
- dh_installman -p$@
+ dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
dh_installcron -p$@
dh_installdocs -p$@
dh_installchangelogs -p$@
@@ -269,6 +276,7 @@ libapt-pkg-dev: build debian/shlibs.local
dh_md5sums -p$@
dh_builddeb -p$@
+apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
apt-utils: build debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
@@ -284,7 +292,7 @@ apt-utils: build debian/shlibs.local
dh_installexamples -p$@
# Install the man pages..
- dh_installman -p$@
+ dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
dh_installchangelogs -p$@
dh_strip -p$@