summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/.cvsignore13
-rw-r--r--debian/apt.cron.daily346
-rw-r--r--debian/apt.dirs1
-rw-r--r--debian/changelog223
-rw-r--r--debian/control4
5 files changed, 336 insertions, 251 deletions
diff --git a/debian/.cvsignore b/debian/.cvsignore
deleted file mode 100644
index d9f983686..000000000
--- a/debian/.cvsignore
+++ /dev/null
@@ -1,13 +0,0 @@
-copyright
-apt
-apt-doc
-apt-utils
-apt-utils.substvars
-apt.substvars
-files
-libapt-pkg-dev
-libapt-pkg-doc
-shlibs.local
-shlibs.local.apt
-shlibs.local.apt-utils
-*.debhelper
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index cdec7eea0..4f47ccfab 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -69,26 +69,50 @@ check_stamp()
interval="$2"
if [ $interval -eq 0 ]; then
- debug_echo "check_stamp: interval=0."
+ debug_echo "check_stamp: interval=0"
# treat as no time has passed
return 1
fi
if [ ! -f $stamp ]; then
- update_stamp $stamp
debug_echo "check_stamp: missing time stamp file: $stamp."
# treat as enough time has passed
return 0
fi
# compare midnight today to midnight the day the stamp was updated
- stamp=$(date -r $stamp '+%s')
+ stamp_file="$stamp"
+ stamp=$(date --date=$(date -r $stamp_file --iso-8601) +%s 2>/dev/null)
+ if [ "$?" != "0" ]; then
+ # Due to some timezones returning 'invalid date' for midnight on
+ # certain dates (eg America/Sao_Paulo), if date returns with error
+ # remove the stamp file and return 0. See coreutils bug:
+ # http://lists.gnu.org/archive/html/bug-coreutils/2007-09/msg00176.html
+ rm -f "$stamp_file"
+ return 0
+ fi
+
+ now=$(date --date=$(date --iso-8601) +%s 2>/dev/null)
+ if [ "$?" != "0" ]; then
+ # As above, due to some timezones returning 'invalid date' for midnight
+ # on certain dates (eg America/Sao_Paulo), if date returns with error
+ # return 0.
+ return 0
+ fi
+
delta=$(($now-$stamp))
# intervall is in days, convert to sec.
interval=$(($interval*60*60*24))
debug_echo "check_stamp: interval=$interval, now=$now, stamp=$stamp, delta=$delta (sec)"
+ # remove timestamps a day (or more) in the future and force re-check
+ if [ $stamp -gt $(($now+86400)) ]; then
+ echo "WARNING: file $stamp_file has a timestamp in the future: $stamp"
+ rm -f "$stamp_file"
+ return 0
+ fi
+
if [ $delta -ge $interval ]; then
return 0
fi
@@ -105,18 +129,25 @@ update_stamp()
# we check here if autoclean was enough sizewise
check_size_constraints()
{
- # min-age in days
MaxAge=0
- MinAge=2
- MaxSize=0
- CacheDir="var/cache/apt"
- CacheArchive="archives/"
eval $(apt-config shell MaxAge APT::Archives::MaxAge)
+ eval $(apt-config shell MaxAge APT::Periodic::MaxAge)
+
+ MinAge=2
eval $(apt-config shell MinAge APT::Archives::MinAge)
+ eval $(apt-config shell MinAge APT::Periodic::MinAge)
+
+ MaxSize=0
eval $(apt-config shell MaxSize APT::Archives::MaxSize)
- eval $(apt-config shell Dir Dir)
+ eval $(apt-config shell MaxSize APT::Periodic::MaxSize)
+
+ CacheDir="var/cache/apt/"
eval $(apt-config shell CacheDir Dir::Cache)
+ CacheDir=${CacheDir%/}
+
+ CacheArchive="archives/"
eval $(apt-config shell CacheArchive Dir::Cache::archives)
+ CacheArchive=${CacheArchive%/}
# sanity check
if [ -z "$CacheDir" -o -z "$CacheArchive" ]; then
@@ -128,9 +159,13 @@ check_size_constraints()
# check age
if [ ! $MaxAge -eq 0 ] && [ ! $MinAge -eq 0 ]; then
+ debug_echo "aged: ctime <$MaxAge and mtime <$MaxAge and ctime>$MinAge and mtime>$MinAge"
find $Cache -name "*.deb" \( -mtime +$MaxAge -and -ctime +$MaxAge \) -and -not \( -mtime -$MinAge -or -ctime -$MinAge \) -print0 | xargs -r -0 rm -f
elif [ ! $MaxAge -eq 0 ]; then
+ debug_echo "aged: ctime <$MaxAge and mtime <$MaxAge only"
find $Cache -name "*.deb" -ctime +$MaxAge -and -mtime +$MaxAge -print0 | xargs -r -0 rm -f
+ else
+ debug_echo "skip aging since MaxAge is 0"
fi
# check size
@@ -148,11 +183,12 @@ check_size_constraints()
size=${du%%/*}
# check if the cache is small enough
if [ $size -lt $MaxSize ]; then
+ debug_echo "end remove by archive size: size=$size < $MaxSize"
break
fi
# check for MinAge of the file
- if [ ! $MinAge -eq 0 ]; then
+ if [ $MinAge -ne 0 ]; then
# check both ctime and mtime
mtime=$(stat -c %Y $file)
ctime=$(stat -c %Z $file)
@@ -161,19 +197,94 @@ check_size_constraints()
else
delta=$(($now-$ctime))
fi
- #echo "$file ($delta), $MinAge"
if [ $delta -le $MinAge ]; then
- #echo "Skiping $file (delta=$delta)"
+ debug_echo "skip remove by archive size: $file, delta=$delta < $MinAgeSec"
break
+ else
+ # delete oldest file
+ debug_echo "remove by archive size: $file, delta=$delta >= $MinAgeSec (sec), size=$size >= $MaxSize"
+ rm -f $file
fi
fi
-
- # delete oldest file
- rm -f $file
done
fi
}
+# deal with the Apt::Periodic::BackupArchiveInterval
+do_cache_backup()
+{
+ BackupArchiveInterval="$1"
+ if [ $BackupArchiveInterval -eq 0 ]; then
+ return
+ fi
+
+ # Set default values and normalize
+ Dir="/"
+ eval $(apt-config shell Dir Dir)
+ Dir=${Dir%/}
+
+ CacheDir="var/cache/apt/"
+ eval $(apt-config shell CacheDir Dir::Cache)
+ CacheDir=${CacheDir%/}
+ if [ -z "$CacheDir" ]; then
+ debug_echo "practically empty Dir::Cache, exiting"
+ return 0
+ fi
+
+ CacheArchive="archives/"
+ eval $(apt-config shell CacheArchive Dir::Cache::Archives)
+ CacheArchive=${CacheArchive%/}
+ if [ -z "$CacheArchive" ]; then
+ debug_echo "practically empty Dir::Cache::archives, exiting"
+ return 0
+ fi
+
+ BackupLevel=3
+ eval $(apt-config shell BackupLevel APT::Periodic::BackupLevel)
+ if [ $BackupLevel -le 1 ]; then
+ BackupLevel=2 ;
+ fi
+
+ CacheBackup="backup/"
+ eval $(apt-config shell CacheBackup Dir::Cache::Backup)
+ CacheBackup=${CacheBackup%/}
+ if [ -z "$CacheBackup" ]; then
+ echo "practically empty Dir::Cache::Backup, exiting" 1>&2
+ return
+ fi
+
+ Cache="${Dir}/${CacheDir}/${CacheArchive}/"
+ Back="${Dir}/${CacheDir}/${CacheBackup}/"
+ BackX="${Back}${CacheArchive}/"
+ for x in $(seq 0 1 $((${BackupLevel}-1))); do
+ eval "Back${x}=${Back}${x}/"
+ done
+
+ # backup after n-days if archive contents changed.
+ # (This uses hardlink to save disk space)
+ BACKUP_ARCHIVE_STAMP=/var/lib/apt/periodic/backup-archive-stamp
+ if check_stamp $BACKUP_ARCHIVE_STAMP $BackupArchiveInterval; then
+ if [ $({(cd $Cache 2>/dev/null; find . -name "*.deb"); (cd $Back0 2>/dev/null;find . -name "*.deb") ;}| sort|uniq -u|wc -l) -ne 0 ]; then
+ mkdir -p $Back
+ rm -rf $Back$((${BackupLevel}-1))
+ for y in $(seq $((${BackupLevel}-1)) -1 1); do
+ eval BackY=${Back}$y
+ eval BackZ=${Back}$(($y-1))
+ if [ -e $BackZ ]; then
+ mv -f $BackZ $BackY ;
+ fi
+ done
+ cp -la $Cache $Back ; mv -f $BackX $Back0
+ update_stamp $BACKUP_ARCHIVE_STAMP
+ debug_echo "backup with hardlinks. (success)"
+ else
+ debug_echo "skip backup since same content."
+ fi
+ else
+ debug_echo "skip backup since too new."
+ fi
+}
+
# sleep for a random interval of time (default 30min)
# (some code taken from cron-apt, thanks)
random_sleep()
@@ -188,6 +299,7 @@ random_sleep()
RANDOM=$(dd if=/dev/urandom count=1 2> /dev/null | cksum | cut -c"1-5")
fi
TIME=$(($RANDOM % $RandomSleep))
+ debug_echo "sleeping for $TIME seconds"
sleep $TIME
}
@@ -200,7 +312,7 @@ debug_echo()
fi
}
-# main
+# ------------------------ main ----------------------------
# check apt-config exstance
if ! which apt-config >/dev/null ; then
@@ -209,6 +321,7 @@ fi
# Set VERBOSE mode from apt-config (or inherit from environment)
eval $(apt-config shell VERBOSE APT::Periodic::Verbose)
+debug_echo "verbose level $VERBOSE"
if [ -z "$VERBOSE" ]; then
VERBOSE="0"
fi
@@ -238,74 +351,25 @@ if which on_ac_power >/dev/null; then
on_ac_power
POWER=$?
if [ $POWER -eq 1 ]; then
- debug_echo "exit: system on main power."
+ debug_echo "exit: system NOT on main power"
exit 0
elif [ $POWER -ne 0 ]; then
- debug_echo "exit: power status ($POWER) undetermined."
- exit 0
+ debug_echo "power status ($POWER) undetermined, continuing"
fi
debug_echo "system is on main power."
fi
# check if we can lock the cache and if the cache is clean
-if which apt-get >/dev/null && ! eval apt-get check $XAPTOPT $XSTDERR ; then
+if which apt-get >/dev/null && ! eval apt-get check -f $XAPTOPT $XSTDERR ; then
debug_echo "error encountered in cron job with \"apt-get check\"."
exit 0
fi
-# No need to check for apt-get below
# Global current time in seconds since 1970-01-01 00:00:00 UTC
now=$(date +%s)
-# Set default values and normalize
-Dir="/"
-eval $(apt-config shell Dir Dir)
-Dir=${Dir%/}
-
-CacheDir="var/cache/apt/"
-eval $(apt-config shell CacheDir Dir::Cache)
-CacheDir=${CacheDir%/}
-if [ -z "$CacheDir" ]; then
- debug_echo "practically empty Dir::Cache, exiting"
- exit 0
-fi
-
-CacheArchive="archives/"
-eval $(apt-config shell CacheArchive Dir::Cache::Archives)
-CacheArchive=${CacheArchive%/}
-if [ -z "$CacheArchive" ]; then
- debug_echo "practically empty Dir::Cache::archives, exiting"
- exit 0
-fi
-
-BackupArchiveInterval=0
-eval $(apt-config shell BackupArchiveInterval APT::Periodic::BackupArchiveInterval)
-
-BackupLevel=3
-eval $(apt-config shell BackupLevel APT::Periodic::BackupLevel)
-if [ $BackupLevel -le 1 ]; then BackupLevel=2 ; fi
-
-CacheBackup="backup/"
-eval $(apt-config shell CacheBackup Dir::Cache::Backup)
-CacheBackup=${CacheBackup%/}
-if [ -z "$CacheBackup" ]; then
- echo "practically empty Dir::Cache::Backup, exiting" 1>&2
- exit 0
-fi
-
# Support old Archive for compatibility.
# Document only Periodic for all controling parameters of this script.
-MaxAge=0
-eval $(apt-config shell MaxAge APT::Archives::MaxAge)
-eval $(apt-config shell MaxAge APT::Periodic::MaxAge)
-
-MinAge=2
-eval $(apt-config shell MinAge APT::Archives::MinAge)
-eval $(apt-config shell MinAge APT::Periodic::MinAge)
-
-MaxSize=0
-eval $(apt-config shell MaxSize APT::Archives::MaxSize)
-eval $(apt-config shell MaxSize APT::Periodic::MaxSize)
UpdateInterval=0
eval $(apt-config shell UpdateInterval APT::Periodic::Update-Package-Lists)
@@ -319,12 +383,8 @@ eval $(apt-config shell UnattendedUpgradeInterval APT::Periodic::Unattended-Upgr
AutocleanInterval=0
eval $(apt-config shell AutocleanInterval APT::Periodic::AutocleanInterval)
-Cache="${Dir}/${CacheDir}/${CacheArchive}/"
-Back="${Dir}/${CacheDir}/${CacheBackup}/"
-BackX="${Back}${CacheArchive}/"
-for x in $(seq 0 1 $((${BackupLevel}-1))); do
- eval "Back${x}=${Back}${x}/"
-done
+BackupArchiveInterval=0
+eval $(apt-config shell BackupArchiveInterval APT::Periodic::BackupArchiveInterval)
# check if we actually have to do anything
if [ $UpdateInterval -eq 0 ] &&
@@ -335,79 +395,15 @@ if [ $UpdateInterval -eq 0 ] &&
exit 0
fi
+# deal with BackupArchiveInterval
+do_cache_backup $BackupArchiveInterval
-# backup after n-days if archive contents changed.
-# (This uses hardlink to save disk space)
-BACKUP_ARCHIVE_STAMP=/var/lib/apt/periodic/backup-archive-stamp
-if check_stamp $BACKUP_ARCHIVE_STAMP $BackupArchiveInterval; then
- if [ $({(cd $Cache 2>/dev/null; find . -name "*.deb"); (cd $Back0 2>/dev/null;find . -name "*.deb") ;}| sort|uniq -u|wc -l) -ne 0 ]; then
- mkdir -p $Back
- rm -rf $Back$((${BackupLevel}-1))
- for y in $(seq $((${BackupLevel}-1)) -1 1); do
- eval BackY=${Back}$y
- eval BackZ=${Back}$(($y-1))
- if [ -e $BackZ ]; then mv -f $BackZ $BackY ; fi
- done
- cp -la $Cache $Back ; mv -f $BackX $Back0
- update_stamp $BACKUP_ARCHIVE_STAMP
- debug_echo "backup with hardlinks. (success)"
- else
-
- debug_echo "skip backup since same content."
- fi
-else
- debug_echo "skip backup since too new."
-fi
-
-# package archive contnts removal by package age
-if [ $MaxAge -ne 0 ] && [ $MinAge -ne 0 ]; then
- find $Cache -name "*.deb" \( -mtime +$MaxAge -and -ctime +$MaxAge \) -and -not \( -mtime -$MinAge -or -ctime -$MinAge \) -print0 | xargs -r -0 rm -f
- debug_echo "aged: ctime <$MaxAge and mtime <$MaxAge and ctime>$MinAge and mtime>$MinAge"
-elif [ $MaxAge -ne 0 ]; then
- find $Cache -name "*.deb" -ctime +$MaxAge -and -mtime +$MaxAge -print0 | xargs -r -0 rm -f
- debug_echo "aged: ctime <$MaxAge and mtime <$MaxAge only"
-else
- debug_echo "skip aging since MaxAge is 0"
-fi
-
-# package archive contnts removal down to $MaxSize
-if [ $MaxSize -ne 0 ]; then
-
- MinAgeSec=$(($MinAge*24*60*60))
-
- # reverse-sort by mtime
- for file in $(ls -rt $Cache/*.deb 2>/dev/null); do
- du=$(du -m -s $Cache)
- size=${du%%/*}
- # check if the cache is small enough
- if [ $size -lt $MaxSize ]; then
- debug_echo "end remove by archive size: size=$size < $MaxSize"
- break
- fi
-
- # check for MinAge in second of the file
- if [ $MinAgeSec -ne 0 ]; then
- # check both ctime and mtime
- mtime=$(stat -c %Y $file)
- ctime=$(stat -c %Z $file)
- if [ $mtime -gt $ctime ]; then
- delta=$(($now-$mtime))
- else
- delta=$(($now-$ctime))
- fi
- if [ $delta -le $MinAgeSec ]; then
- debug_echo "skip remove by archive size: $file, delta=$delta < $MinAgeSec"
- else
- # delete oldest file
- debug_echo "remove by archive size: $file, delta=$delta >= $MinAgeSec (sec), size=$size >= $MaxSize"
- rm -f $file
- fi
- fi
-
- done
-fi
+# sleep random amount of time to avoid hitting the
+# mirrors at the same time
+random_sleep
# update package lists
+UPDATED=0
UPDATE_STAMP=/var/lib/apt/periodic/update-stamp
if check_stamp $UPDATE_STAMP $UpdateInterval; then
if eval apt-get $XAPTOPT -y update $XSTDERR; then
@@ -422,50 +418,56 @@ if check_stamp $UPDATE_STAMP $UpdateInterval; then
debug_echo "dbus signal not send (command not available)"
fi
update_stamp $UPDATE_STAMP
- # download all upgradeable packages if it is requested
- DOWNLOAD_UPGRADEABLE_STAMP=/var/lib/apt/periodic/download-upgradeable-stamp
- if check_stamp $DOWNLOAD_UPGRADEABLE_STAMP $DownloadUpgradeableInterval; then
- if eval apt-get $XAPTOPT -y -d dist-upgrade $XSTDERR; then
- update_stamp $DOWNLOAD_UPGRADEABLE_STAMP
- debug_echo "download upgradable (success)."
- # auto upgrade all upgradeable packages
- UPGRADE_STAMP=/var/lib/apt/periodic/upgrade-stamp
- if which unattended-upgrade >/dev/null && check_stamp $UPGRADE_STAMP $UnattendedUpgradeInterval; then
- if unattended-upgrade $XUUPOPT; then
- update_stamp $UPGRADE_STAMP
- debug_echo "unattended-upgrade (success)."
- else
- debug_echo "unattended-upgrade (error)."
- fi
- else
- debug_echo "unattended-upgrade (not run)."
- fi
- else
- debug_echo "download upgradable (error)."
- fi
- else
- debug_echo "download upgradable (not run)."
- fi
+ UPDATED=1
else
- debug_echo "download updated metadata (error)."
+ debug_echo "download updated metadata (error)"
fi
else
debug_echo "download updated metadata (not run)."
fi
+
+# download all upgradeable packages (if it is requested)
+DOWNLOAD_UPGRADEABLE_STAMP=/var/lib/apt/periodic/download-upgradeable-stamp
+if [ $UPDATED -eq 1 ] && check_stamp $DOWNLOAD_UPGRADEABLE_STAMP $DownloadUpgradeableInterval; then
+ if eval apt-get $XAPTOPT -y -d dist-upgrade $XSTDERR; then
+ update_stamp $DOWNLOAD_UPGRADEABLE_STAMP
+ debug_echo "download upgradable (success)"
+ else
+ debug_echo "download upgradable (error)"
+ fi
+else
+ debug_echo "download upgradable (not run)"
+fi
+
+# auto upgrade all upgradeable packages
+UPGRADE_STAMP=/var/lib/apt/periodic/upgrade-stamp
+if [ $UPDATED -eq 1 ] && which unattended-upgrade >/dev/null && check_stamp $UPGRADE_STAMP $UnattendedUpgradeInterval; then
+ if unattended-upgrade $XUUPOPT; then
+ update_stamp $UPGRADE_STAMP
+ debug_echo "unattended-upgrade (success)"
+ else
+ debug_echo "unattended-upgrade (error)"
+ fi
+else
+ debug_echo "unattended-upgrade (not run)"
+fi
# autoclean package archive
AUTOCLEAN_STAMP=/var/lib/apt/periodic/autoclean-stamp
if check_stamp $AUTOCLEAN_STAMP $AutocleanInterval; then
- if apt-get $XAPTOPT -y autoclean $XSTDERR; then
+ if eval apt-get $XAPTOPT -y autoclean $XSTDERR; then
debug_echo "autoclean (success)."
update_stamp $AUTOCLEAN_STAMP
else
- debug_echo "autoclean (error)."
+ debug_echo "autoclean (error)"
fi
else
- debug_echo "autoclean (not run)."
+ debug_echo "autoclean (not run)"
fi
+# check cache size
+check_size_constraints
+
#
# vim: set sts=4 ai :
#
diff --git a/debian/apt.dirs b/debian/apt.dirs
index 47f60e7e3..fb6716c35 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -3,6 +3,7 @@ usr/lib/apt/methods
usr/lib/dpkg/methods/apt
etc/apt
etc/apt/apt.conf.d
+etc/apt/preferences.d
etc/apt/sources.list.d
etc/logrotate.d
var/cache/apt/archives/partial
diff --git a/debian/changelog b/debian/changelog
index cce7fc0f7..30edf0757 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,22 +1,54 @@
-apt (0.7.22) unstable; urgency=low
+apt (0.7.22) UNRELEASED; urgency=low
- * add Acquire::Cdrom::mount "apt-udev-auto" magic to allow
- dynamically finding the cdrom device
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Wed, 22 Jul 2009 18:00:53 +0200
-
-apt (0.7.21) UNRELEASED; urgency=low
-
- [ Osamu Aoki ]
- * Updated cron script to support backups by hardlinks and
- verbose levels. All features turned off by default.
- * Added more error handlings. Closes: #438803, #462734, #454989,
- * Refactored condition structure to make download and upgrade performed
- if only previous steps succeeded. Closes: #341970
- * Documented all cron script related configuration items in
- configure-index.
+ The 'not dead yet' release
+
+ [ Christian Perrier ]
+ * Documentation translations:
+ - Fix a typo in apt-get(8) French translation. Closes: #525043
+ Thanks to Guillaume Delacour for spotting it.
+ - Updated apt.conf(5) manpgae French translation.
+ Thanks to Aurélien Couderc.
+ * Translations:
+ - fr.po
+ - sk.po. Closes: #525857
+ - ru.po. Closes: #526816
+ - eu.po. Closes: #528985
+ - zh_CN.po. Closes: #531390
+ - fr.po
+ - it.po. Closes: #531758
+ - ca.po. Closes: #531921
+ - de.po. Closes: #536430
+ * Added translations
+ - ast.po (Asturian by Marcos Alvareez Costales).
+ Closes: #529007, #529730, #535328
+
+ [ David Kalnischkies ]
+ * [ABI break] support '#' in apt.conf and /etc/apt/preferences
+ (closes: #189866)
+ * [ABI break] Allow pinning by codename (closes: #97564)
+ * support running "--simulate" as user
+ * add depth information to the debug output and show what depends
+ type triggers a autoinst (closes: #458389)
+ * add Debug::pkgDepCache::Marker with more detailed debug output
+ (closes: #87520)
+ * add Debug::pkgProblemResolver::ShowScores and make the scores
+ adjustable
+ * do not write state file in simulate mode (closes: #433007)
+ * add hook for MarkInstall and MarkDelete (closes: #470035)
+ * fix typo in apt-pkg/acquire.cc which prevents Dl-Limit to work
+ correctly when downloading from multiple sites (Closes: #534752)
+ * add the various foldmarkers in apt-pkg & cmdline (no code change)
+ * versions with a pin of -1 shouldn't be a candidate (Closes: #355237)
+ * prefer mmap as memory allocator in MMap instead of a static char
+ array which can (at least in theory) grow dynamic
+ * eliminate (hopefully all) segfaults in pkgcachegen.cc and mmap.cc
+ which can arise if cache doesn't fit into the mmap (Closes: #535218)
+ * display warnings instead of errors if the parts dirs doesn't exist
[ Michael Vogt ]
+ * honor the dpkg hold state in new Marker hooks (closes: #64141)
+ * debian/apt.cron.daily:
+ - if the timestamp is too far in the future, delete it
* apt-pkg/acquire.cc:
- make the max pipeline depth of the acquire queue configurable
via Acquire::Max-Pipeline-Depth
@@ -24,6 +56,8 @@ apt (0.7.21) UNRELEASED; urgency=low
- add Dpkg::UseIoNice boolean option to run dpkg with ionice -c3
(off by default)
- send "dpkg-exec" message on the status fd when dpkg is run
+ - provide DPkg::Chroot-Directory config option (useful for testing)
+ - fix potential hang when in a backgroud process group
* apt-pkg/algorithms.cc:
- consider recommends when making the scores for the problem
resolver
@@ -34,67 +68,127 @@ apt (0.7.21) UNRELEASED; urgency=low
* methods/http.cc:
- ignore SIGPIPE, we deal with EPIPE from write in
HttpMethod::ServerDie() (LP: #385144)
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 28 May 2009 17:51:42 +0200
-
- [ Michael Vogt ]
+ * Only run Download-Upgradable and Unattended-Upgrades if the initial
+ update was successful Closes: #341970
* apt-pkg/indexcopy.cc:
- support having CDs with no Packages file (just a Packages.gz)
by not forcing a verification on non-existing files
(LP: #255545)
- remove the gettext from a string that consists entirely
of variables (LP: #56792)
- * doc/makefile:
- - add examples/apt-https-method-example.conf
* apt-pkg/cacheiterators.h:
- add missing checks for Owner == 0 in end()
- * apt-pkg/deb/dpkgpm.cc:
- - fix potential hang when in a backgroud process group
* apt-pkg/indexrecords.cc:
- fix some i18n issues
* apt-pkg/contrib/strutl.h:
- add new strprintf() function to make i18n strings easier
- * methods/gpgv.cc:
- fix compiler warning
- * cmdline/apt-get.cc:
- - fix "apt-get source pkg=ver" if binary name != source name
- and show a message (LP: #202219)
- - fix "apt-get source pkg" if there is a binary package and
- a source package of the same name but from different
- packages (LP: #330103)
* apt-pkg/deb/debsystem.cc:
- make strings i18n able
- * apt-pkg/contrib/strutl.cc:
- - fix TimeToStr i18n (LP: #289807)
- * [ABI break] merge support for http redirects, thanks to
- Jeff Licquia and Anthony Towns
- * [ABI break] use int for the package IDs (thanks to Steve Cotton)
- * apt-pkg/pkgcache.cc:
- - do not run "dpkg --configure pkg" if pkg is in trigger-awaited
- state (LP: #322955)
- * methods/https.cc:
- - add Acquire::https::AllowRedirect support
- * methods/gpgv.cc:
- - properly check for expired and revoked keys (closes: #433091)
* fix problematic use of tolower() when calculating the version
hash by using locale independant tolower_ascii() function.
Thanks to M. Vefa Bicakci (LP: #80248)
* build fixes for g++-4.4
* cmdline/apt-mark:
- add "showauto" option to show automatically installed packages
+ * document --install-recommends and --no-install-recommends
+ (thanks to Dereck Wonnacott, LP: #126180)
+ * doc/apt.conf.5.xml:
+ - merged patch from Aurélien Couderc to improve the text
+ (thanks!)
+ * [ABI] merged the libudev-dlopen branch, this allows to pass
+ "apt-udev-auto" to Acquire::Cdrom::mount and the cdrom method will
+ dynamically find/mount the cdrom device (if libhal is available)
+
+ [ Julian Andres Klode ]
+ * apt-pkg/contrib/configuration.cc: Fix a small memory leak in
+ ReadConfigFile.
+ * Introduce support for the Enhances field. (Closes: #137583)
+ * Support /etc/apt/preferences.d, by adding ReadPinDir() (Closes: #535512)
+ * configure-index: document Dir::Etc::SourceParts and some other options
+ (Closes: #459605)
+ * Remove Eugene V. Lyubimkin from uploaders as requested.
+ * apt-pkg/contrib/hashes.cc, apt-pkg/contrib/md5.cc:
+ - Support reading until EOF if Size=0 to match behaviour of
+ SHA1Summation and SHA256Summation
+
+ [ Osamu Aoki ]
+ * Updated cron script to support backups by hardlinks and
+ verbose levels. All features turned off by default.
+ * Added more error handlings. Closes: #438803, #462734, #454989,
+ * Documented all cron script related configuration items in
+ configure-index.
[ Dereck Wonnacott ]
* apt-ftparchive might write corrupt Release files (LP: #46439)
* Apply --important option to apt-cache depends (LP: #16947)
- * Clarify the --help for 'purge' (LP: #243948)
+ -- Julian Andres Klode <jak@debian.org> Fri, 03 Jul 2009 08:27:35 +0200
+
+apt (0.7.21) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * Translations:
+ - bg.po. Closes: #513211
+ - zh_TW.po. Closes: #513311
+ - nb.po. Closes: #513843
+ - fr.po. Closes: #520430
+ - sv.po. Closes: #518070
+ - sk.po. Closes: #520403
+ - it.po. Closes: #522222
+ - sk.po. Closes: #520403
+
+ [ Jamie Strandboge ]
+ * apt.cron.daily: catch invalid dates due to DST time changes
+ in the stamp files
+
+ [ Michael Vogt ]
+ * methods/gpgv.cc:
+ - properly check for expired and revoked keys (closes: #433091)
+ * apt-pkg/contrib/strutl.cc:
+ - fix TimeToStr i18n (LP: #289807)
+ * [ABI break] merge support for http redirects, thanks to
+ Jeff Licquia and Anthony Towns
+ * [ABI break] use int for the package IDs (thanks to Steve Cotton)
+ * apt-pkg/pkgcache.cc:
+ - do not run "dpkg --configure pkg" if pkg is in trigger-awaited
+ state (LP: #322955)
+ * methods/https.cc:
+ - add Acquire::https::AllowRedirect support
+ * Clarify the --help for 'purge' (LP: #243948)
+ * cmdline/apt-get.cc
+ - fix "apt-get source pkg" if there is a binary package and
+ a source package of the same name but from different
+ packages (LP: #330103)
[ Colin Watson ]
* cmdline/acqprogress.cc:
- Call pkgAcquireStatus::Pulse even if quiet, so that we still get
dlstatus messages on the status-fd (LP: #290234).
- -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 12 Sep 2008 11:34:24 +0200
+ -- Michael Vogt <mvo@debian.org> Tue, 14 Apr 2009 14:12:51 +0200
+
+apt (0.7.20.2) unstable; urgency=medium
+
+ [ Eugene V. Lyubimkin ]
+ * Urgency set to medium due to RC bug fix.
+ * doc/apt.ent, apt-get.8.xml:
+ - Fix invalid XML entities. (Closes: #514402)
+
+ -- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Sat, 07 Feb 2009 16:48:21 +0200
+
+apt (0.7.20.1) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * apt-pkg/pkgcachegen.cc:
+ - fix apt-cache search for localized description
+ (closes: #512110)
+
+ [ Christian Perrier ]
+ * Translations:
+ - fr.po: fix spelling error to "défectueux". Thanks to Thomas Péteul.
+
+ -- Michael Vogt <mvo@debian.org> Tue, 20 Jan 2009 09:35:05 +0100
apt (0.7.20) unstable; urgency=low
@@ -110,35 +204,37 @@ apt (0.7.20) unstable; urgency=low
(Closes: #457265)
- Mentioned 'APT::Periodic' and 'APT::Archives' groups of options.
(Closes: #438559)
-
- [ Michael Vogt ]
- * apt-pkg/depcache.cc:
- - when checking for new important deps, skip critical ones
- (LP: #236360)
- * document --install-recommends and --no-install-recommends
- (thanks to Dereck Wonnacott, LP: #126180)
- * make "apt-get build-dep" installed packages marked automatic
- by default. This can be changed by setting the value of
- APT::Get::Build-Dep-Automatic to false (thanks to Aaron
- Haviland, closes: #44874, LP: #248268)
-
- -- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Sat, 06 Dec 2008 20:57:00 +0200
-
-apt (0.7.20~exp2) unstable; urgency=low
-
- [ Eugene V. Lyubimkin ]
+ - Mentioned '/* ... */' comments. (Closes: #507601)
* doc/examples/sources.list:
- Removed obsolete commented non-us deb-src entry, replaced it with
'deb-src security.debian.org' one. (Closes: #411298)
* apt-pkg/contrib/mmap.cc:
- Added instruction how to work around MMap error in MMap error message.
(Closes: #385674, 436028)
+ * COPYING:
+ - Actualized. Removed obsolete Qt section, added GPLv2 clause.
+ (Closes: #440049, #509337)
+
+ [ Michael Vogt ]
+ * add option to "apt-get build-dep" to mark the needed
+ build-dep packages as automatic installed.
+ This is controlled via the value of
+ APT::Get::Build-Dep-Automatic and is set "false" by default.
+ Thanks to Aaron Haviland, closes: #448743
+ * apt-inst/contrib/arfile.cc:
+ - support members ending with '/' as well (thanks to Michal Cihr,
+ closes: #500988)
[ Christian Perrier ]
* Translations:
+ - Finnish updated. Closes: #508449
+ - Galician updated. Closes: #509151
+ - Catalan updated. Closes: #509375
+ - Vietnamese updated. Closes: #509422
+ - Traditional Chinese added. Closes: #510664
- French corrected (remove awful use of first person)
- -- Michael Vogt <mvo@debian.org> Tue, 02 Dec 2008 20:30:14 +0100
+ -- Michael Vogt <mvo@debian.org> Mon, 05 Jan 2009 08:59:20 +0100
apt (0.7.19) unstable; urgency=low
@@ -156,7 +252,6 @@ apt (0.7.19) unstable; urgency=low
is a request to install only one package and it is not installable.
(Closes: #419521)
-
[ Michael Vogt ]
- fix SIGHUP handling (closes: #463030)
diff --git a/debian/control b/debian/control
index ba9e32e4b..84c411509 100644
--- a/debian/control
+++ b/debian/control
@@ -4,8 +4,8 @@ Priority: important
Maintainer: APT Development Team <deity@lists.debian.org>
Uploaders: Michael Vogt <mvo@debian.org>, Otavio Salvador <otavio@debian.org>,
Christian Perrier <bubulle@debian.org>, Daniel Burrows <dburrows@debian.org>,
- Luca Bruno <lethalman88@gmail.com>, Eugene V. Lyubimkin <jackyf.devel@gmail.com>
-Standards-Version: 3.8.0
+ Luca Bruno <lethalman88@gmail.com>
+Standards-Version: 3.8.1.0
Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5), debiandoc-sgml, docbook-utils (>= 0.6.12), xsltproc, docbook-xsl, xmlto
Vcs-Bzr: http://bzr.debian.org/apt/debian-sid/