summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily4
-rw-r--r--debian/changelog49
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules2
4 files changed, 51 insertions, 6 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 4f7eff47b..d1016dfc5 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -147,6 +147,9 @@ check_size_constraints()
fi
}
+if ! which apt-config >/dev/null; then
+ exit 0
+fi
UpdateInterval=0
DownloadUpgradeableInterval=0
@@ -172,6 +175,7 @@ fi
# check if we can lock the cache and if the cache is clean
if ! apt-get check -q -q 2>/dev/null; then
+ echo "$0: could not lock the APT cache"
exit 1
fi
diff --git a/debian/changelog b/debian/changelog
index 9177aa826..40882faa6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,47 @@
+apt (0.7.9ubuntu2) hardy; urgency=low
+
+ [ Otavio Salvador ]
+ * Applied patch from Aurelien Jarno <aurel32@debian.org> to fix building
+ with newest dpkg-shlibdeps changing the packaging building order and a
+ patch from Robert Millan <rmh@aybabtu.com> to fix parallel building,
+ closes: #452862.
+ * Applied patch from Alexander Winston <alexander.winston@comcast.net>
+ to use 'min' as symbol for minute, closes: #219034.
+ * Applied patch from Amos Waterland <apw@us.ibm.com> to allow apt to
+ work properly in initramfs, closes: #448316.
+ * Applied patch from Robert Millan <rmh@aybabtu.com> to make apt-key and
+ apt-get to ignore time conflicts, closes: #451328.
+ * Applied patch from Peter Eisentraut <peter_e@gmx.net> to fix a
+ grammatical error ("manual installed" -> "manually installed"),
+ closes: #438136.
+ * Fix cron.daily job to not call fail if apt isn't installed, closes:
+ #443286.
+
+ [ Daniel Burrows ]
+ * apt-pkg/contrib/configuration.cc:
+ - if RootDir is set, then FindFile and FindDir will return paths
+ relative to the directory stored in RootDir, closes: #456457.
+
+ [ Christian Perrier ]
+ * Fix wording for "After unpacking...". Thans to Michael Gilbert
+ for the patch. Closes: #260825
+
+ [ Program translations ]
+ - Vietnamese updated. Closes: #453774
+ - Japanese updated. Closes: #456909
+ - French updated.
+
+ [ Michael Vogt ]
+ * apt-pkg/packagemanager.{cc,h}:
+ - propergate the Immediate flag to make hitting the
+ "E: Internal Error, Could not perform immediate configuration (2)"
+ harder. (LP: #179247)
+ * debian/apt.conf.daily:
+ - print warning if the cache can not be locked (closes: #454561),
+ thanks to Bastian Kleineidam
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 03 Jan 2008 11:31:45 +0100
+
apt (0.7.9ubuntu1) hardy; urgency=low
* merged from http://bzr.debian.org/apt/apt/debian-sid/, remaining
@@ -24,13 +68,10 @@ apt (0.7.9ubuntu1) hardy; urgency=low
* Applied patch from Aurelien Jarno <aurel32@debian.org> to avoid CPU
getting crazy when /dev/null is redirected to stdin (which breaks
buildds), closes: #452858.
- * Applied patch from Aurelien Jarno <aurel32@debian.org> to fix building
- with newest dpkg-shlibdeps changing the packaging building order,
- closes: #452862.
[ Program translations ]
- Basque updated. Closes: #453088
-
+
[ Michael Vogt ]
* debian/rules
- fix https install location
diff --git a/debian/control b/debian/control
index 6c1453857..a93f76510 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
XSBC-Original-Maintainer: APT Development Team <deity@lists.debian.org>
Uploaders: Jason Gunthorpe <jgg@debian.org>, Adam Heath <doogie@debian.org>, Matt Zimmerman <mdz@debian.org>, Michael Vogt <mvo@debian.org>, Otavio Salvador <otavio@debian.org>
Standards-Version: 3.7.2.2
-Build-Depends: debhelper (>= 5.0), libdb4.4-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5)
+Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5)
Build-Depends-Indep: debiandoc-sgml, docbook-utils (>= 0.6.12-1)
XS-Vcs-Bzr: http://code.launchpad.net/~ubuntu-core-dev/apt/ubuntu
diff --git a/debian/rules b/debian/rules
index b64efa925..7bf99f9ef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -299,7 +299,7 @@ apt-utils: build debian/shlibs.local
dh_md5sums -p$@
dh_builddeb -p$@
-apt-transport-https: build debian/shlibs.local
+apt-transport-https: build debian/shlibs.local libapt-pkg-dev
dh_testdir -p$@
dh_testroot -p$@
dh_clean -p$@ -k