summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily14
-rw-r--r--debian/apt.dirs1
-rw-r--r--debian/changelog184
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules3
5 files changed, 200 insertions, 7 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 2d93a5ba4..26dfa2530 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -95,9 +95,9 @@ check_size_constraints()
# check age
if [ ! $MaxAge -eq 0 ] && [ ! $MinAge -eq 0 ]; then
- find $Cache -name "*.deb" -mtime +$MaxAge -and -not -mtime -$MinAge -print0 | xargs -r -0 rm -f
+ find $Cache -name "*.deb" \( -mtime +$MaxAge -and -ctime +$MaxAge \) -and -not \( -mtime -$MinAge -or -ctime -$MinAge \) -print0 | xargs -r -0 rm -f
elif [ ! $MaxAge -eq 0 ]; then
- find $Cache -name "*.deb" -mtime +$MaxAge -print0 | xargs -r -0 rm -f
+ find $Cache -name "*.deb" -ctime +$MaxAge -and -mtime +$MaxAge -print0 | xargs -r -0 rm -f
fi
# check size
@@ -120,8 +120,14 @@ check_size_constraints()
# check for MinAge of the file
if [ ! $MinAge -eq 0 ]; then
- mtime=$(date --date=$(date -r $file --iso-8601) +%s)
- delta=$(($now-$mtime))
+ # check both ctime and mtime
+ mtime=$(stat -c %Y $file)
+ ctime=$(stat -c %Z $file)
+ if [ $mtime -gt $ctime ]; then
+ delta=$(($now-$mtime))
+ else
+ delta=$(($now-$ctime))
+ fi
#echo "$file ($delta), $MinAge"
if [ $delta -le $MinAge ]; then
#echo "Skiping $file (delta=$delta)"
diff --git a/debian/apt.dirs b/debian/apt.dirs
index d39bfd1f7..e1cb738fa 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -2,6 +2,7 @@ usr/bin
usr/lib/apt/methods
usr/lib/dpkg/methods/apt
etc/apt
+etc/apt/sources.list.d
var/cache/apt/archives/partial
var/lib/apt/lists/partial
var/lib/apt/periodic
diff --git a/debian/changelog b/debian/changelog
index cc3da8f84..89322ae31 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,187 @@
+apt (0.6.43.4) unstable; urgency=low
+
+ * apt-pkg/acquire.cc: don't show ETA if it is 0 or absurdely large
+ * apt-pkg/contrib/sha256.{cc,h},hashes.{cc,h}: support for sha256
+ (thanks to Anthony Towns)
+ * ftparchive/cachedb.{cc,h},writer.{cc,h}: optimizations
+ (thanks to Anthony Towns)
+ * apt pdiff support from experimental merged
+
+ -- Michael Vogt <mvo@debian.org> Sun, 2 Apr 2006 13:05:24 +0200
+
+apt (0.6.43.3) unstable; urgency=low
+
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-186:
+ * ca.po: Completed to 512t. Closes: #351592
+ * eu.po: Completed to 512t. Closes: #350483
+ * ja.po: Completed to 512t. Closes: #349806
+ * pl.po: Completed to 512t. Closes: #349514
+ * sk.po: Completed to 512t. Closes: #349474
+ * gl.po: Completed to 512 strings Closes: #349407
+ * sv.po: Completed to 512 strings Closes: #349210
+ * ru.po: Completed to 512 strings Closes: #349154
+ * da.po: Completed to 512 strings Closes: #349084
+ * fr.po: Completed to 512 strings
+ * vi.po: Completed to 511 strings Closes: #348968
+ * zh_CN.po: Completed to 512t. Closes: #353936
+ * it.po: Completed to 512t. Closes: #352803
+ * pt_BR.po: Completed to 512t. Closes: #352419
+ * LINGUAS: Add Welsh
+ * *.po: Updated from sources (512 strings)
+ * apt-pkg/deb/deblistparser.cc:
+ - don't explode on a DepCompareOp in a Provides line, but warn about
+ it and ignore it otherwise (thanks to James Troup for reporting it)
+ * cmdline/apt-get.cc:
+ - don't lock the lists directory in DoInstall, breaks --print-uri
+ (thanks to James Troup for reporting it)
+ * debian/apt.dirs: create /etc/apt/sources.list.d
+ * make apt-cache madison work without deb-src entries (#352583)
+ * cmdline/apt-get.cc: only run the list-cleaner if a update was
+ successfull
+
+ -- Michael Vogt <mvo@debian.org> Wed, 22 Feb 2006 10:13:04 +0100
+
+apt (0.6.43.2) unstable; urgency=low
+
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-166:
+ - en_GB.po, de.po: fix spaces errors in "Ign " translations Closes: #347258
+ - makefile: make update-po a pre-requisite of clean target so
+ that POT and PO files are always up-to-date
+ - sv.po: Completed to 511t. Closes: #346450
+ - sk.po: Completed to 511t. Closes: #346369
+ - fr.po: Completed to 511t
+ - *.po: Updated from sources (511 strings)
+ - el.po: Completed to 511 strings Closes: #344642
+ - da.po: Completed to 511 strings Closes: #348574
+ - es.po: Updated to 510t1f Closes: #348158
+ - gl.po: Completed to 511 strings Closes: #347729
+ - it.po: Yet another update Closes: #347435
+ * added debian-archive-keyring to the Recommends (closes: #347970)
+ * fixed message in apt-key to install debian-archive-keyring
+ * typos fixed in apt-cache.8 (closes: #348348, #347349)
+ * add patch to fix http download corruption problem (thanks to
+ Petr Vandrovec, closes: #280844, #290694)
+
+ -- Michael Vogt <mvo@debian.org> Thu, 19 Jan 2006 00:06:33 +0100
+
+apt (0.6.43.1) unstable; urgency=low
+
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-148:
+ * fr.po: Completed to 510 strings
+ * it.po: Completed to 510t
+ * en_GB.po: Completed to 510t
+ * cs.po: Completed to 510t
+ * zh_CN.po: Completed to 510t
+ * el.po: Updated to 510t
+ * vi.po: Updated to 383t93f34u
+ * tl.po: Completed to 510 strings (Closes: #344306)
+ * sv.po: Completed to 510 strings (Closes: #344056)
+ * LINGUAS: disabled Hebrew translation. (Closes: #313283)
+ * eu.po: Completed to 510 strings (Closes: #342091)
+ * apt-get source won't download already downloaded files again
+ (closes: #79277)
+ * share/debian-archive.gpg: new 2006 ftp-archive signing key added
+ (#345891)
+ * redownload the Release file if IMS-Hit and gpg failure
+ * deal with multiple signatures on a Release file
+
+ -- Michael Vogt <mvo@debian.org> Fri, 6 Jan 2006 01:17:08 +0100
+
+apt (0.6.43) unstable; urgency=medium
+
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-132:
+ * zh_CN.po: Completed to 510 strings(Closes: #338267)
+ * gl.po: Completed to 510 strings (Closes: #338356)
+ * added support for "/etc/apt/sources.list.d" directory
+ (closes: #66325)
+ * make pkgDirStream (a bit) more complete
+ * fix bug in pkgCache::VerIterator::end() (thanks to Daniel Burrows)
+ (closes: #339533)
+ * pkgAcqFile is more flexible now (closes: #57091)
+ * support a download rate limit for http (closes: #146877)
+ * included lots of the speedup changes from #319377
+ * add stdint.h to contrib/md5.h (closes: #340448)
+ * ABI change, library name changed (closes: #339147)
+ * Fix GNU/kFreeBSD crash on non-existing server file (closes: #317718)
+ * switch to libdb4.3 in build-depends
+
+ -- Michael Vogt <mvo@debian.org> Tue, 29 Nov 2005 00:17:07 +0100
+
+apt (0.6.42.3) unstable; urgency=low
+
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-129:
+ - patch-118: Russian translation update by Yuri Kozlov (closes: #335164)
+ - patch-119: add update-po as a pre-req for binary (closes: #329910)
+ - patch-121: Complete French translation
+ - patch-125: Fixed localization of y/n questions in German translation
+ (closes: #337078)
+ - patch-126: Swedish translation update (closes: #337163)
+ - patch-127: Complete Tagalog translation (closes: #337306)
+ - patch-128: Danish translation update (closes: #337949)
+ - patch-129: Basque translation update (closes: #338101)
+ * cmdline/apt-get.cc:
+ - bufix in FindSrc (closes: #335213, #337910)
+ * added armeb to archtable (closes: #333599)
+ * with --allow-unauthenticated use the old fallback behaviour for
+ sources (closes: #335112)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 9 Nov 2005 07:22:31 +0100
+
+apt (0.6.42.2) unstable; urgency=high
+
+ * NMU (approved by maintainer)
+ * Add AMD64 archive signing key to debian-archive.gpg (closes: #336500).
+ * Add big-endian arm (armeb) support (closes: #333599).
+ * Priority high to get the AMD key into testing ASAP.
+
+ -- Frans Pop <fjp@debian.org> Sun, 30 Oct 2005 21:29:11 +0100
+
+apt (0.6.42.1) unstable; urgency=low
+
+ * fix a incorrect example in the apt_prefrences man page
+ (thanks to Filipus Klutiero, closes: #282918)
+ * apt-pkg/pkgrecords.cc:
+ - revert patch from last version, it causes trouble on alpha
+ and ia64 (closes: #335102, #335103)
+ * cmdline/apt-get.cc:
+ - be extra carefull in FindSrc (closes: #335213)
+
+ -- Michael Vogt <mvo@debian.org> Sat, 22 Oct 2005 23:44:35 +0200
+
+apt (0.6.42) unstable; urgency=low
+
+ * apt-pkg/cdrom.cc:
+ - unmount the cdrom when apt failed to locate any package files
+ * allow cdrom failures and fallback to other sources in that case
+ (closes: #44135)
+ * better error text when dpkg-source fails
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-115:
+ - patch-99: Added Galician translation
+ - patch-100: Completed Danish translation (Closes: #325686)
+ - patch-104: French translation completed
+ - patch-109: Italian translation completed
+ - patch-112: Swedish translation update
+ - patch-115: Basque translation completed (Closes: #333299)
+ * applied french man-page update (thanks to Philippe Batailler)
+ (closes: #316638, #327456)
+ * fix leak in the mmap code, thanks to Daniel Burrows for the
+ patch (closes: #250583)
+ * support for apt-get [build-dep|source] -t (closes: #152129)
+ * added "APT::Authentication::TrustCDROM" option to make the life
+ for the installer people easier (closes: #334656)
+ * fix crash in apt-ftparchive (thanks to Bastian Blank for the patch)
+ (closes: #334671)
+ * apt-pkg/contrib/md5.cc:
+ - fix a alignment problem on sparc64 that gives random bus errors
+ (thanks to Fabbione for providing a test-case)
+ * init the default ScreenWidth to 79 columns by default
+ (Closes: #324921)
+ * cmdline/apt-cdrom.cc:
+ - fix some missing gettext() calls (closes: #334539)
+ * doc/apt-cache.8.xml: fix typo (closes: #334714)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 19 Oct 2005 22:02:09 +0200
+
apt (0.6.41) unstable; urgency=low
* improved the support for "error" and "conffile" reporting from
diff --git a/debian/control b/debian/control
index 6d9418a46..3b8883f88 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: important
Maintainer: APT Development Team <deity@lists.debian.org>
Uploaders: Jason Gunthorpe <jgg@debian.org>, Adam Heath <doogie@debian.org>, Matt Zimmerman <mdz@debian.org>, Michael Vogt <mvo@debian.org>
Standards-Version: 3.6.1
-Build-Depends: debhelper (>= 4.1.62), libdb4.2-dev, gettext (>= 0.12)
+Build-Depends: debhelper (>= 4.1.62), libdb4.3-dev, gettext (>= 0.12)
Build-Depends-Indep: debiandoc-sgml, docbook-utils (>= 0.6.12-1)
Package: apt
@@ -13,8 +13,9 @@ Depends: ${shlibs:Depends}
Priority: important
Replaces: libapt-pkg-doc (<< 0.3.7), libapt-pkg-dev (<< 0.3.7)
Provides: ${libapt-pkg:provides}
+Recommends: debian-archive-keyring
Suggests: aptitude | synaptic | gnome-apt | wajig, dpkg-dev, apt-doc, bzip2, gnupg
-Section: base
+Section: admin
Description: Advanced front-end for dpkg
This is Debian's next generation front-end for the dpkg package manager.
It provides the apt-get utility and APT dselect method that provides a
diff --git a/debian/rules b/debian/rules
index cd026b4a4..5647ebd23 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,6 +36,7 @@ endif
# Default rule
build:
+PKG=apt
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
@@ -335,6 +336,6 @@ cvs-mkul:
arch-build:
rm -rf debian/arch-build
mkdir -p debian/arch-build/apt-$(APT_DEBVER)
- baz inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
+ tar -c --exclude=arch-build -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
$(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
(cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))