summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily2
-rw-r--r--debian/apt.postinst2
-rw-r--r--debian/changelog51
3 files changed, 51 insertions, 4 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 2665b6579..3f9df9d7e 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -375,7 +375,7 @@ fi
check_power || exit 0
# check if we can lock the cache and if the cache is clean
-if which apt-get >/dev/null && ! eval apt-get check -f $XAPTOPT $XSTDERR ; then
+if which apt-get >/dev/null && ! eval apt-get check $XAPTOPT $XSTDERR ; then
debug_echo "error encountered in cron job with \"apt-get check\"."
exit 0
fi
diff --git a/debian/apt.postinst b/debian/apt.postinst
index 70de237d0..fd3e273bb 100644
--- a/debian/apt.postinst
+++ b/debian/apt.postinst
@@ -33,7 +33,7 @@ case "$1" in
fi
# create kernel autoremoval blacklist on update
- if dpkg --compare-versions "$2" lt-nl 0.9.9.3; then
+ if dpkg --compare-versions "$2" lt 0.9.9.3; then
/etc/kernel/postinst.d/apt-auto-removal
fi
;;
diff --git a/debian/changelog b/debian/changelog
index 3ae0d3182..638d8ef3b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,44 @@
-apt (0.9.11.2) UNRELEASED; urgency=low
+apt (0.9.11.5) UNRELEASED; urgency=low
+
+ [ Christian Perrier ]
+ * Fix typo in apt-private/private-show.cc. Thanks to Benjamin
+ Keresa. Closes: #724073
+
+ [ Mark Hymers ]
+ * fix libapt-inst for >2G debs (closes: #725483)
+
+ -- Christian Perrier <bubulle@debian.org> Mon, 23 Sep 2013 07:05:34 +0200
+
+apt (0.9.11.4) unstable; urgency=low
+
+ [ Oskari Saarenmaa ]
+ * don't truncate 100 char long paths in tar extraction.
+ Thanks to Mika Eloranta for the testcase! (Closes: #689582)
+
+ [ David Kalnischkies ]
+ * do not trust FileFd::Eof() in pkgTagFile::Fill()
+ Thanks to Cyril Brulebois (Closes: 723705)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 20 Sep 2013 16:12:07 +0200
+
+apt (0.9.11.3) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * Add DPkgPM::Progress option to enable terminal install
+ progress
+ * fix typo (mkostemp->mkstemp)
+ * Remove invalid "-f" option for apt-get check, thanks to
+ Philipp Weis (closes: #721477)
+ * Fix regression of "apt-cache unmet -i", thanks to Daniel Schepler
+ (closes: #722324)
+
+ [ David Kalnischkies ]
+ * use FileFd in HashSum test to unbreak non-linux ports.
+ Thanks to Aaron M. Ucko (Closes: 721723)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 10 Sep 2013 17:32:02 +0200
+
+apt (0.9.11.2) unstable; urgency=low
[ Milo Casagrande ]
* Update Italian translation. Closes: #721030
@@ -11,8 +51,15 @@ apt (0.9.11.2) UNRELEASED; urgency=low
- remove "-f" option for apt-get clean/auto-clean (closes: #720532)
* apt-private/private-cmndline.cc:
- fix typo in CmdMatches() selection for dselect-upgrade (closes: #720532)
+ * use SPtr<pkgProblemResolver> in DoInstall() to simplify the code
+ * allow pkg manipulation in the upgrade/dist-upgrade commandline, like
+ apt-get dist-upgrade 2vcard- 4g8+ (thanks to Thorsten Glaser for the
+ suggestion)
+
+ [ Angel Guzman Maeso ]
+ * replace usage of potential dangerous mktemp with mkstemp
- -- Christian Perrier <bubulle@debian.org> Sun, 25 Aug 2013 15:39:40 +0200
+ -- Michael Vogt <mvo@debian.org> Sat, 31 Aug 2013 16:45:31 +0200
apt (0.9.11.1) unstable; urgency=low