summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.manpages4
-rw-r--r--debian/apt.postinst42
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules24
5 files changed, 63 insertions, 15 deletions
diff --git a/debian/apt.manpages b/debian/apt.manpages
index 9a93da667..7a15245d4 100644
--- a/debian/apt.manpages
+++ b/debian/apt.manpages
@@ -2,6 +2,7 @@ doc/apt-cache.8
doc/apt-cdrom.8
doc/apt-config.8
doc/apt-get.8
+doc/apt-key.8
doc/apt.8
doc/apt.conf.5
doc/apt_preferences.5
@@ -12,7 +13,6 @@ doc/fr/apt-get.fr.8
doc/fr/apt.conf.fr.5
doc/fr/apt_preferences.fr.5
doc/fr/sources.list.fr.5
-doc/fr/vendors.list.fr.5
doc/es/apt-cache.es.8
doc/es/apt-cdrom.es.8
doc/es/apt-config.es.8
@@ -20,7 +20,6 @@ doc/es/apt-get.es.8
doc/es/apt.conf.es.5
doc/es/apt_preferences.es.5
doc/es/sources.list.es.5
-doc/es/vendors.list.es.5
doc/es/apt.es.8
doc/pt_BR/apt_preferences.pt_BR.5
doc/ja/apt-cache.ja.8
@@ -28,5 +27,4 @@ doc/ja/apt-cdrom.ja.8
doc/ja/apt-get.ja.8
doc/ja/apt.conf.ja.5
doc/sources.list.5
-doc/vendors.list.5
doc/de/apt.de.8
diff --git a/debian/apt.postinst b/debian/apt.postinst
new file mode 100644
index 000000000..df0433057
--- /dev/null
+++ b/debian/apt.postinst
@@ -0,0 +1,42 @@
+#! /bin/sh
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+case "$1" in
+ configure)
+
+ if ! test -f /etc/apt/trusted.gpg; then
+ cp /usr/share/apt/ubuntu-archive.gpg /etc/apt/trusted.gpg
+ fi
+
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/changelog b/debian/changelog
index f61efa7f7..9d26496f2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+apt (0.6.27) hoary; urgency=low
+
+ * Merge apt--authentication--0 branch (gpg authentication)
+
+ -- Matt Zimmerman <mdz@canonical.com> Mon, 13 Dec 2004 01:03:11 -0800
+
apt (0.5.32) hoary; urgency=low
* Call setlocale in the methods, so that the messages are properly
diff --git a/debian/control b/debian/control
index a1e376b9d..ea709acc9 100644
--- a/debian/control
+++ b/debian/control
@@ -13,7 +13,7 @@ Depends: ${shlibs:Depends}
Priority: important
Replaces: libapt-pkg-doc (<< 0.3.7), libapt-pkg-dev (<< 0.3.7)
Provides: ${libapt-pkg:provides}
-Suggests: aptitude | synaptic | gnome-apt | wajig, dpkg-dev, apt-doc, bzip2
+Suggests: aptitude | synaptic | gnome-apt | wajig, dpkg-dev, apt-doc, bzip2, gnupg
Section: base
Description: Advanced front-end for dpkg
This is Debian's next generation front-end for the dpkg package manager.
diff --git a/debian/rules b/debian/rules
index fba0e1a20..caf7bacfd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -108,7 +108,7 @@ build/configure-stamp: configure
dh_testdir
-mkdir build
cp COPYING debian/copyright
- cd build && ../configure $(confflags)
+ cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
touch $@
build/build-stamp: build/configure-stamp
@@ -189,25 +189,27 @@ apt: build debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
dh_clean -p$@ -k
- dh_installdirs -p$@
+ dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
#
# apt install
#
- cp $(BLD)/bin/apt-* debian/apt/usr/bin/
+ cp $(BLD)/bin/apt-* debian/$@/usr/bin/
# Remove the bits that are in apt-utils
- rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
+ rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
# install the shared libs
- find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
- find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
+ find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+ find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+
+ cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
- cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
+ cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
+ cp -r $(BLD)/locale debian/$@/usr/share/
- cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
- cp -r $(BLD)/locale debian/apt/usr/share/
+ cp debian/bugscript debian/$@/usr/share/bug/apt/script
- cp debian/bugscript debian/apt/usr/share/bug/apt/script
+ cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
# head -n 500 ChangeLog > debian/ChangeLog
@@ -221,7 +223,7 @@ apt: build debian/shlibs.local
dh_fixperms -p$@
dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
+ dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@