summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog28
-rw-r--r--debian/tests/run-tests17
2 files changed, 42 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 4d7d2e963..151be3bec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,31 @@
+apt (0.9.14.2) UNRELEASED; urgency=low
+
+ [ Joe Hansen ]
+ * Danish translation update. Closes: #732166
+
+ [ Peter Green ]
+ * add apt-vendor for raspbian. Closes: #732749
+
+ [ Michael Vogt ]
+ * vendor/getinfo:
+ - fix ubuntu-codename
+ * vendor/steamos/*:
+ - add steamos support
+
+ -- Christian Perrier <bubulle@debian.org> Sun, 15 Dec 2013 08:43:06 +0100
+
+apt (0.9.14.1) unstable; urgency=medium
+
+ * fix apt-get source -t dist regression (closes: #731853)
+ and add testcase
+ * clarify error message when apt-get source=ver fails
+ (thans to David Kalnischkies)
+ * Fix conffile prompt regression (LP: #1260297)
+ and add testcase
+ * improve error message for apt-get source pkg:arch{=ver,/release}
+
+ -- Michael Vogt <mvo@debian.org> Thu, 12 Dec 2013 18:34:29 +0100
+
apt (0.9.14) unstable; urgency=low
[ David Kalnischkies ]
diff --git a/debian/tests/run-tests b/debian/tests/run-tests
index 6ea503568..233c5a386 100644
--- a/debian/tests/run-tests
+++ b/debian/tests/run-tests
@@ -2,6 +2,17 @@
set -e
-make
-make test
-test/integration/run-tests
+# auto-package-test is very unhappy if stuff it writen to stderr
+exec 2> apt-stderr.log
+
+# we need the buildin webserver for the tests
+if [ ! -e environment.mak ]; then
+ ./configure
+fi
+make -C test/interactive-helper/
+
+# run against the installed apt
+APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
+APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
+APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
+./test/integration/run-tests