summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily4
-rw-r--r--debian/changelog21
-rw-r--r--debian/control1
-rw-r--r--debian/tests/control2
-rw-r--r--debian/tests/run-tests7
5 files changed, 33 insertions, 2 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 3f9df9d7e..2616af1dd 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -197,11 +197,11 @@ check_size_constraints()
delta=$(($now-$ctime))
fi
if [ $delta -le $MinAge ]; then
- debug_echo "skip remove by archive size: $file, delta=$delta < $MinAgeSec"
+ debug_echo "skip remove by archive size: $file, delta=$delta < $MinAge"
break
else
# delete oldest file
- debug_echo "remove by archive size: $file, delta=$delta >= $MinAgeSec (sec), size=$size >= $MaxSize"
+ debug_echo "remove by archive size: $file, delta=$delta >= $MinAge (sec), size=$size >= $MaxSize"
rm -f $file
fi
fi
diff --git a/debian/changelog b/debian/changelog
index e6bdcb1fa..8359438d1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,24 @@
+apt (0.9.13.1) unstable; urgency=low
+
+ [ Colin Watson ]
+ * fix "apt-get --purge build-dep" (closes: #720597)
+ * fix regression that APT::Keep-Fds is not honored (closes: #730490)
+
+ [ Michael Vogt ]
+ * add "-f" option to "build-dep" as sbuild is using it to fix
+ regression with cross-building (LP: #1255806)
+ * merge mvo/feature/short-list
+
+ -- Michael Vogt <mvo@debian.org> Thu, 28 Nov 2013 20:02:39 +0100
+
+apt (0.9.13) unstable; urgency=low
+
+ [ TJ Guthrie ]
+ * Changed MinAgeSec to MinAge in /etc/cron.daily/apt:200,204
+ LP: #1206047
+
+ -- Michael Vogt <mvo@debian.org> Sun, 24 Nov 2013 10:56:22 +0100
+
apt (0.9.13~exp1) experimental; urgency=low
* Improve the API for APT::Upgrade::Upgrade()
diff --git a/debian/control b/debian/control
index 673fba477..84d6155a6 100644
--- a/debian/control
+++ b/debian/control
@@ -13,6 +13,7 @@ Build-Depends-Indep: doxygen, debiandoc-sgml
Build-Conflicts: autoconf2.13, automake1.4
Vcs-Git: git://anonscm.debian.org/apt/apt.git
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=apt/apt.git
+XS-Testsuite: autopkgtest
Package: apt
Architecture: any
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 000000000..e38921c7e
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,2 @@
+Tests: run-tests
+Depends: @, dpkg-dev, debhelper, libdb-dev, gettext, libcurl4-gnutls-dev, zlib1g-dev, libbz2-dev, xsltproc, docbook-xsl, docbook-xml, po4a, autotools-dev, autoconf, automake, doxygen, debiandoc-sgml, stunnel4 \ No newline at end of file
diff --git a/debian/tests/run-tests b/debian/tests/run-tests
new file mode 100644
index 000000000..6ea503568
--- /dev/null
+++ b/debian/tests/run-tests
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+set -e
+
+make
+make test
+test/integration/run-tests