summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily4
-rw-r--r--debian/changelog38
-rwxr-xr-xdebian/rules2
3 files changed, 39 insertions, 5 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 5524c16ee..7af689e1f 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -147,6 +147,9 @@ check_size_constraints()
fi
}
+if ! which apt-config >/dev/null; then
+ exit 0
+fi
UpdateInterval=0
DownloadUpgradeableInterval=0
@@ -172,6 +175,7 @@ fi
# check if we can lock the cache and if the cache is clean
if ! apt-get check -q -q 2>/dev/null; then
+ echo "$0: could not lock the APT cache"
exit 1
fi
diff --git a/debian/changelog b/debian/changelog
index fd2162b2c..ef9784178 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-apt (0.7.10) unstable; urgency=low
+apt (0.7.10) UNRELEASED; urgency=low
[ Otavio Salvador ]
* Applied patch from Mike O'Connor <stew@vireo.org> to add a manpage to
@@ -9,27 +9,57 @@ apt (0.7.10) unstable; urgency=low
getting crazy when /dev/null is redirected to stdin (which breaks
buildds), closes: #452858.
* Applied patch from Aurelien Jarno <aurel32@debian.org> to fix building
- with newest dpkg-shlibdeps changing the packaging building order,
+ with newest dpkg-shlibdeps changing the packaging building order and a
+ patch from Robert Millan <rmh@aybabtu.com> to fix parallel building,
closes: #452862.
+ * Applied patch from Alexander Winston <alexander.winston@comcast.net>
+ to use 'min' as symbol for minute, closes: #219034.
+ * Applied patch from Amos Waterland <apw@us.ibm.com> to allow apt to
+ work properly in initramfs, closes: #448316.
+ * Applied patch from Robert Millan <rmh@aybabtu.com> to make apt-key and
+ apt-get to ignore time conflicts, closes: #451328.
+ * Applied patch from Peter Eisentraut <peter_e@gmx.net> to fix a
+ grammatical error ("manual installed" -> "manually installed"),
+ closes: #438136.
+ * Fix cron.daily job to not call fail if apt isn't installed, closes:
+ #443286.
[ Program translations ]
- Basque updated. Closes: #453088
-
+ - Vietnamese updated. Closes: #453774
+ - Japanese updated. Closes: #456909
+ - French updated.
+
[ Michael Vogt ]
* debian/rules
- fix https install location
+ * debian/apt.conf.daily:
+ - print warning if the cache can not be locked (closes: #454561),
+ thanks to Bastian Kleineidam
* methods/gpgv.cc:
- remove cruft code that caused timestamp/I-M-S issues
* ftparchive/contents.cc:
- fix error output
+ * apt-pkg/acquire-item.{cc,h}:
+ - make the authentication download code more robust against
+ servers/proxies with broken If-Range implementations
[ Chris Cheney ]
* ftparchive/contents.cc:
- support lzma data members
* ftparchive/multicompress.cc:
- support lzma output
+
+ [ Daniel Burrows ]
+ * apt-pkg/contrib/configuration.cc:
+ - if RootDir is set, then FindFile and FindDir will return paths
+ relative to the directory stored in RootDir, closes: #456457.
+
+ [ Christian Perrier ]
+ * Fix wording for "After unpacking...". Thans to Michael Gilbert
+ for the patch. Closes: #260825
- -- Michael Vogt <mvo@debian.org> Wed, 28 Nov 2007 17:10:49 +0100
+ -- Christian Perrier <bubulle@debian.org> Mon, 17 Dec 2007 10:10:17 +0530
apt (0.7.9) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index 5989934b4..006d2de8a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -294,7 +294,7 @@ apt-utils: build debian/shlibs.local
dh_md5sums -p$@
dh_builddeb -p$@
-apt-transport-https: build debian/shlibs.local
+apt-transport-https: build debian/shlibs.local libapt-pkg-dev
dh_testdir -p$@
dh_testroot -p$@
dh_clean -p$@ -k