summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.postinst2
-rwxr-xr-xdebian/bugscript2
-rw-r--r--debian/changelog32
-rwxr-xr-xdebian/rules2
4 files changed, 32 insertions, 6 deletions
diff --git a/debian/apt.postinst b/debian/apt.postinst
index df0433057..ae1801198 100644
--- a/debian/apt.postinst
+++ b/debian/apt.postinst
@@ -17,7 +17,7 @@ case "$1" in
configure)
if ! test -f /etc/apt/trusted.gpg; then
- cp /usr/share/apt/ubuntu-archive.gpg /etc/apt/trusted.gpg
+ cp /usr/share/apt/debian-archive.gpg /etc/apt/trusted.gpg
fi
;;
diff --git a/debian/bugscript b/debian/bugscript
index 8423e07c2..f5ec9e05d 100755
--- a/debian/bugscript
+++ b/debian/bugscript
@@ -1,4 +1,4 @@
-#!/bin/sh -e
+#!/bin/bash -e
# reportbug #169495
if [ -z "$YESNO" ]; then
diff --git a/debian/changelog b/debian/changelog
index 681684daa..28dfe0e58 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,35 @@
-apt (0.6.37) breezy; urgency=low
-
+apt (0.6.38) unstable; urgency=low
+
+ * Merge michael.vogt@ubuntu.com--2005/apt--fixes--0--patch-6, a workaround
+ for the French man pages' failure to build
+ * Branch Debian and Ubuntu
+ - apt.postinst, apt-key: use the appropriate keyring
+ - debian/rules: install all keyrings
+ * Add the current Debian archive signing key (4F368D5D) to
+ debian-archive.gpg
* make pinning on the "component" work again (using the section of the
archive, we don't use per-section Release files anymore with apt-0.6)
(closes ubuntu #9935)
+
+ -- Matt Zimmerman <mdz@debian.org> Sat, 25 Jun 2005 09:51:00 -0700
+
+apt (0.6.37) breezy; urgency=low
- -- Michael Vogt <michael.vogt@ubuntu.com> Mon, 23 May 2005 23:02:50 +0200
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-81
+ - patch-66: Italian update
+ - patch-71: French update
+ - patch-73: Basque update
+ - patch-74: Hebrew update
+ - patch-76: Correct Hebrew translation (Closes: #306658)
+ - patch-77: French man page update
+ - patch-79: Correct syntax errors in Hebrew translation
+ - patch-81: Portuguese update
+ * Fix build of French man pages (now using XML, not SGML)
+ * Add Welsh translation from Dafydd Harries
+ (daf@muse.19inch.net--2005/apt--main--0--patch-1)
+ * Change debian/bugscript to use #!/bin/bash (Closes: #313402)
+
+ -- Matt Zimmerman <mdz@ubuntu.com> Tue, 24 May 2005 14:38:25 -0700
apt (0.6.36ubuntu1) breezy; urgency=low
@@ -59,6 +84,7 @@ apt (0.6.34) hoary; urgency=low
-- Matt Zimmerman <mdz@ubuntu.com> Fri, 4 Mar 2005 16:13:15 -0800
+>>>>>>> MERGE-SOURCE
apt (0.6.33) hoary; urgency=low
* Merge michael.vogt@ubuntu.com--2005/apt--mvo--0 (through patch-6)
diff --git a/debian/rules b/debian/rules
index e3254c2d2..d6ae540ee 100755
--- a/debian/rules
+++ b/debian/rules
@@ -209,7 +209,7 @@ apt: build debian/shlibs.local
cp debian/bugscript debian/$@/usr/share/bug/apt/script
- cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
+ cp share/*.gpg debian/$@/usr/share/$@
# head -n 500 ChangeLog > debian/ChangeLog