summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog22
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules5
3 files changed, 27 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index a41380cdf..7af0dd75f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,25 @@
+apt (0.9.5) UNRELEASED; urgency=low
+
+ [ David Kalnischkies ]
+ * buildlib/podomain.mak:
+ - ensure that all sources end up in the srclist so that we don't
+ forget to extract half of the translation strings
+ * buildlib/inttypes.h.in:
+ - remove inttypes.h compatibility as providing such a c99 types
+ compatibility conflicts with the usage of c99 type long long
+ * apt-pkg/contrib/mmap.cc:
+ - have a dummy SyncToFd around in case of ReadOnly access to a
+ compressed file as we otherwise on Close() do not delete[] the
+ char buffer but munmap() it… (Closes: #673815)
+ * debian/control:
+ - moving debiandoc-sgml to Build-Depends-Indep was one step too much
+ for the buildds as we still build two sgml files in arch:any
+ * debian/rules:
+ - move internal-solver as 'apt' to his friend dump-solver in
+ /usr/lib/apt/solvers to avoid writing a manpage for it
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Mon, 21 May 2012 15:10:49 +0200
+
apt (0.9.4) unstable; urgency=low
[ David Kalnischkies ]
diff --git a/debian/control b/debian/control
index 56de07a03..bb1bb9aae 100644
--- a/debian/control
+++ b/debian/control
@@ -9,8 +9,8 @@ Standards-Version: 3.9.3
Build-Depends: dpkg-dev (>= 1.15.8), debhelper (>= 8.1.3~), libdb-dev,
gettext (>= 0.12), libcurl4-gnutls-dev (>= 7.19.0),
zlib1g-dev, libbz2-dev, xsltproc, docbook-xsl, docbook-xml,
- po4a (>= 0.34-2), autotools-dev, autoconf, automake
-Build-Depends-Indep: debiandoc-sgml, doxygen
+ po4a (>= 0.34-2), autotools-dev, autoconf, automake, debiandoc-sgml
+Build-Depends-Indep: doxygen
Build-Conflicts: autoconf2.13, automake1.4
Vcs-Bzr: http://bzr.debian.org/apt/debian-sid/
Vcs-Browser: http://bzr.debian.org/loggerhead/apt/debian-sid/
diff --git a/debian/rules b/debian/rules
index 7b221fc2a..ee001fe12 100755
--- a/debian/rules
+++ b/debian/rules
@@ -51,7 +51,7 @@ override BLD := ./build
endif
# APT Programs in apt-utils
-APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver
+APT_UTILS=ftparchive sortpkgs extracttemplates
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -191,7 +191,7 @@ apt: build build-manpages
dh_install -p$@ --sourcedir=$(BLD)
# Remove the bits that are in apt-utils
- rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver)
+ rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
# https has its own package
rm debian/$@/usr/lib/apt/methods/https
@@ -245,6 +245,7 @@ apt-utils: build build-manpages
cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
+ cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
dh_install -p$@ --sourcedir=$(BLD)
dh_link -p$@