summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog19
-rwxr-xr-xdebian/prerm15
2 files changed, 19 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index 48768ad88..b5cedbe2e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,6 +18,25 @@ apt (0.7.24) UNRELEASED; urgency=low
- activate DOT_MULTI_TARGETS, it is default on since doxygen 1.5.9
* buildlib/po4a_manpage.mak, doc/makefile, configure:
- simplify the makefiles needed for po4a manpages
+ * apt-pkg/contrib/configuration.cc:
+ - add a helper to easily get a vector of strings from the config
+ * apt-pkg/contrib/strutl.cc:
+ - replace unknown multibytes with ? in UTF8ToCharset (Closes: #545208)
+ * doc/apt-get.8.xml:
+ - fix two little typos in the --simulate description.
+ * apt-pkg/aptconfiguration.cc, doc/apt.conf.5.xml:
+ - add an order subgroup to the compression types to simplify reordering
+ a bit and improve the documentation for this option group.
+ * doc/apt.ent, all man pages:
+ - move the description of files to globally usable entities
+ * doc/apt_preferences.5.xml:
+ - document the new preferences.d folder (Closes: #544017)
+ * methods/rred.cc:
+ - add at the top without failing (by Bernhard R. Link, Closes: #545694)
+ * buildlib/sizetable:
+ - add amd64 for cross building (by Mikhail Gusarov, Closes: #513058)
+ * debian/prerm:
+ - remove file as nobody will upgrade from 0.4.10 anymore
[ Christian Perrier ]
* doc/fr/*, doc/po/fr.po:
diff --git a/debian/prerm b/debian/prerm
deleted file mode 100755
index 4a8d47782..000000000
--- a/debian/prerm
+++ /dev/null
@@ -1,15 +0,0 @@
-#! /bin/sh
-
-set -e
-
-#DEBHELPER#
-
-if [ "$1" = "upgrade" -o "$1" = "failed-upgrade" ] &&
- dpkg --compare-versions "$2" "<<" 0.4.10
-then
- if [ ! -d /var/state/apt/ ]; then
- ln -s /var/lib/apt /var/state/apt
- touch /var/lib/apt/lists/partial/.delete-me-later
- fi
-fi
-