summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt-doc.docs3
-rw-r--r--debian/apt.conf.autoremove23
-rw-r--r--debian/apt.dirs1
-rw-r--r--debian/changelog406
-rw-r--r--debian/control9
-rw-r--r--debian/libapt-pkg-doc.doc-base.cache18
-rwxr-xr-xdebian/rules116
-rw-r--r--debian/source/format1
8 files changed, 447 insertions, 130 deletions
diff --git a/debian/apt-doc.docs b/debian/apt-doc.docs
index a7507f4e7..86aa69ceb 100644
--- a/debian/apt-doc.docs
+++ b/debian/apt-doc.docs
@@ -1 +1,2 @@
-README.progress-reporting \ No newline at end of file
+README.progress-reporting
+README.MultiArch
diff --git a/debian/apt.conf.autoremove b/debian/apt.conf.autoremove
index b41be8397..b3f4a3edd 100644
--- a/debian/apt.conf.autoremove
+++ b/debian/apt.conf.autoremove
@@ -1,9 +1,24 @@
APT
{
- NeverAutoRemove
- {
- "^linux-image.*";
+ NeverAutoRemove
+ {
+ "^firmware-linux.*";
+ "^linux-firmware$";
+ "^linux-image.*";
+ "^kfreebsd-image.*";
"^linux-restricted-modules.*";
- "^kfreebsd-image.*";
+ "^linux-ubuntu-modules-.*";
+ };
+
+ Never-MarkAuto-Sections
+ {
+ "metapackages";
+ "restricted/metapackages";
+ "universe/metapackages";
+ "multiverse/metapackages";
+ "oldlibs";
+ "restricted/oldlibs";
+ "universe/oldlibs";
+ "multiverse/oldlibs";
};
};
diff --git a/debian/apt.dirs b/debian/apt.dirs
index 66556e453..f25e4600b 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -9,6 +9,7 @@ etc/apt/trusted.gpg.d
etc/logrotate.d
var/cache/apt/archives/partial
var/lib/apt/lists/partial
+var/lib/apt/mirrors/partial
var/lib/apt/periodic
var/log/apt
usr/share/bug/apt
diff --git a/debian/changelog b/debian/changelog
index 6f3d2eb71..bc35468c3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,9 @@
-apt (0.7.26~exp5) UNRELEASED; urgency=low
+apt (0.7.26~exp10) UNRELEASED; urgency=low
- [ Christian Perrier ]
- * Slovak translation update. Closes: #581159
- * Italian translation update. Closes: #581742
+ [ David Kalnischkies ]
+ * apt-pkg/contrib/error.{cc,h}:
+ - remove constness of va_list parameter to fix build on amd64 and co
+ Thanks Eric Valette! (Closes: #588610)
[ Martin Pitt ]
* debian/rules:
@@ -10,7 +11,7 @@ apt (0.7.26~exp5) UNRELEASED; urgency=low
CXXFLAGS.
* apt-pkg/contrib/fileutl.{h,cc}:
- Add support for reading of gzipped files with the new "ReadOnlyGzip"
- OpenMode.
+ OpenMode. (Closes: #188407)
- Link against zlib (in apt-pkg/makefile) and add zlib build dependency.
- [ABI BREAK] This adds a new private member to FileFd, but its
initialization is in the public header file.
@@ -34,22 +35,313 @@ apt (0.7.26~exp5) UNRELEASED; urgency=low
* Add test/test-indexes.sh:
- Test behaviour of index retrieval and usage, in particular with
uncompressed and gzip compressed indexes.
- * apt-pkg/acquire-item.cc:
- - Fix return value of pkgAcqFile::Custom600Headers() in the non-index
- case, to avoid returning NULL and causing crashers in callers. This also
- fixes a compiler warning.
* methods/gzip.cc: With FileFd now being able to read gzipped files, there
is no need for the gzip method any more to spawn an external gzip process.
Rewrite it to use FileFd directly, which makes the code a lot simpler, and
also using less memory and overhead.
- -- Christian Perrier <bubulle@debian.org> Tue, 11 May 2010 19:52:00 +0200
+ -- David Kalnischkies <kalnischkies@gmail.com> Sat, 10 Jul 2010 13:44:32 +0200
+
+apt (0.7.26~exp9) experimental; urgency=low
+
+ [ David Kalnischkies ]
+ * doc/apt.conf.5.xml:
+ - add and document APT::Cache-{Start,Grow,Limit} options for mmap control
+ * apt-pkg/contrib/fileutl.cc:
+ - do not fail von double close()
+
+ -- Michael Vogt <mvo@debian.org> Fri, 09 Jul 2010 21:51:55 +0200
+
+apt (0.7.26~exp8) experimental; urgency=low
+
+ [ David Kalnischkies ]
+ * cmdline/cacheset.cc:
+ - doesn't include it in the library for now as it is too volatile
+ - get the candidate either from an already built depcache
+ or use the policy which is a bit faster than depcache generation
+ - get packages by task^ with FromTask()
+ - only print errors if all tries to get a package by string failed
+ - factor out code to get a single package FromName()
+ - check in Grouped* first without modifier interpretation
+ * cmdline/apt-get.cc:
+ - use the cachsets in the install commands
+ - make the specify order of packages irrelevant (Closes: #196021)
+ * apt-pkg/orderlist.cc:
+ - untouched packages are never missing
+ * apt-pkg/packagemanager.cc:
+ - packages that are not touched doesn't need to be unpacked
+ * debian/control:
+ - remove intltool's dependency as it is an ubuntu artefact
+ * apt-pkg/depcache.cc:
+ - SetCandidateVer for all pseudo packages
+ - SetReInstall for the "all" package of a pseudo package
+ - use the new MatchAgainstConfig for the DefaultRootSetFunc
+ - always mark the all package if a pseudo package is marked for install
+ * apt-pkg/contrib/error.{cc,h}:
+ - complete rewrite but use the same API
+ - add NOTICE and DEBUG as new types of a message
+ - add a simple stack handling to be able to delay error handling
+ * apt-pkg/aptconfiguration.cc:
+ - show a deprecation notice for APT::Acquire::Translation
+ * apt-pkg/contrib/configuration.{cc,h}:
+ - add a wrapper to match strings against configurable regex patterns
+ * apt-pkg/contrib/fileutl.cc:
+ - show notice about ignored file instead of being always silent
+ - add a Dir::Ignore-Files-Silently list option to control the notice
+ * apt-pkg/policy.h:
+ - add another round of const& madness as the previous round accidentally
+ NOT overrides the virtual GetCandidateVer() method (Closes: #587725)
+ * apt-pkg/pkgcachegen.{cc,h}:
+ - make the used MMap moveable (and therefore dynamic resizeable) by
+ applying (some) mad pointer magic (Closes: #195018)
+
+ [ Michael Vogt ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - make the apt/term.log output unbuffered (thanks to Matt Zimmerman)
+
+ [ Julian Andres Klode ]
+ * methods/ftp.h:
+ - Handle different logins on the same server (Closes: #586904).
+ * apt-pkg/deb/deblistparser.cc:
+ - Handle architecture wildcards (Closes: #547724).
+ * apt-pkg/versionmatch.cc:
+ - Support matching pins by regular expressions or glob() like patterns,
+ regular expressions have to be put between to slashes; for example,
+ /.*/.
+ * apt-pkg/contrib/fileutl.cc:
+ - Make FileFd replace files atomically in WriteTemp mode (for cache, etc).
+ * debian/control:
+ - Set Standards-Version to 3.9.0
+
+ -- Michael Vogt <mvo@debian.org> Fri, 09 Jul 2010 19:16:20 +0200
+
+apt (0.7.26~exp7) experimental; urgency=low
+
+ * apt-pkg/cachefile.h:
+ - make pkgPolicy public again, libapt-pkg-perl (and probably
+ others) get unhappy without that
+
+ -- Michael Vogt <mvo@debian.org> Thu, 10 Jun 2010 15:33:24 +0200
-apt (0.7.26~exp4) unstable; urgency=low
+apt (0.7.26~exp6) experimental; urgency=low
+ [ Michael Vogt ]
+ * merge the remaining Ubuntu change:
+ - on gpg verification failure warn and restore the last known
+ good state
+ - on failure display the IP of the server (useful for servers
+ that use round robin DNS)
+ - support Original-Maintainer in RewritePackageOrder
+ - enable cdrom autodetection via libudev by default
+ - show message about Vcs in use when apt-get source is run for
+ packages maintained in a Vcs
+ - better support transitional packages with mark auto-installed.
+ when the transitional package is in "oldlibs" the new package
+ is not marked auto installed (same is true for section
+ metapackages)
+ - provide new "deb mirror://archive.foo/mirrors.list sid main"
+ method expects a list of mirrors (generated on the server e.g.
+ via geoip) and will use that, including cycle on failure
+ - write apport crash file on package failure (disabled by default
+ on debian until apport is available)
+ - support mirror failure reporting (disabled by default on debian)
+
+ [ David Kalnischkies ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - write Disappeared also to the history.log
+ - forward manual-installed bit on package disappearance
+ * apt-pkg/deb/debsystem.cc:
+ - add better config item for extended_states file
+ * apt-pkg/pkgcache.h:
+ - switch {,Install-}Size to unsigned long long
+ * apt-pkg/depcache.cc:
+ - do the autoremove mark process also for required packages to handle
+ these illegally depending on lower priority packages (Closes: #583517)
+ - try harder to find the other pseudo versions for autoremove multiarch
+ - correct "Dangerous iterator usage" pointed out by cppcheck
+ - deal with long long, not with int to remove 2GB Limit (LP: #250909)
+ - deprecate AddSize with Multiplier as it is unused and switch to
+ boolean instead to handle the sizes more gracefully.
+ - switch i{Download,Usr}Size from double to (un)signed long long
+ * apt-pkg/aptconfiguration.cc:
+ - remove duplicate architectures in getArchitectures()
+ * apt-pkg/indexrecords.{cc,h}:
+ - backport forgotten Valid-Until patch from the obsolete experimental
+ branch to prevent replay attacks better, thanks to Thomas Viehmann
+ for the initial patch! (Closes: #499897)
+ - add a constant Exists check for MetaKeys
+ * apt-pkg/acquire-item.cc:
+ - do not try PDiff if it is not listed in the Meta file
+ - sent Last-Modified header also for Translation files
+ * apt-pkg/cacheiterator.h:
+ - let pkgCache::Iterator inherent std::iterator
+ * ftparchive/writer.h:
+ - add a virtual destructor to FTWScanner class (for cppcheck)
+ * apt-pkg/cacheset.{cc,h}:
+ - add simple wrapper around std::set for cache structures
+ - move regex magic from apt-get to new FromRegEx method
+ - move cmdline parsing from apt-cache to new FromCommandLine method
+ - support special release-modifier 'installed' and 'candidate'
+ * apt-pkg/contrib/cmdline.cc:
+ - fix segfault in SaveInConfig caused by writing over char[] sizes
+ * apt-pkg/pkgcache.cc:
+ - get the best matching arch package from a group with FindPreferredPkg
+ * cmdline/apt-cache.cc:
+ - make the search multiarch compatible by using GrpIterator instead
+ - use pkgCacheFile and the new CacheSets all over the place
+ - add --target-release option (Closes: #115520)
+ - accept pkg/release and pkg=version in show and co. (Closes: #236270)
+ - accept package versions in the unmet command
+ * cmdline/apt-get.cc:
+ - use unsigned long long instead of double to store values it gets
+ * apt-pkg/cachefile.{cc,h}:
+ - split Open() into submethods to be able to build only parts
+ - make the OpProgress optional in the Cache buildprocess
+ - store also the SourceList we use internally for export
+ * doc/apt.conf.5.xml:
+ - document the new Valid-Until related options
+ * apt-pkg/contrib/strutl.cc:
+ - split StrToTime() into HTTP1.1 and FTP date parser methods and
+ use strptime() instead of some self-made scanf mangling
+ - use the portable timegm shown in his manpage instead of a strange
+ looking code copycat from wget
+ * ftparchive/writer.cc:
+ - add ValidTime option to generate a Valid-Until header in Release file
+ * apt-pkg/policy.cc:
+ - get the candidate right for a not-installed pseudo package if
+ his non-pseudo friend is installed
+ * apt-pkg/indexcopy.cc:
+ - move the gpg codecopy to a new method and use it also in methods/gpgv.cc
+
+ -- Michael Vogt <mvo@debian.org> Thu, 10 Jun 2010 14:02:22 +0200
+
+apt (0.7.26~exp5) experimental; urgency=low
+
+ [ David Kalnischkies ]
+ * cmdline/apt-get.cc:
+ - rerun dpkg-source in source if --fix-broken is given (Closes: #576752)
+ - don't suggest held packages as they are installed (Closes: #578135)
+ - handle multiple --{tar,diff,dsc}-only options correctly
+ - show at the end of the install process a list of disappeared packages
+ * cmdline/apt-cache.cc:
+ - use GroupCount for package names in stats and add a package struct line
+ * methods/rred.cc:
+ - use the patchfile modification time instead of the one from the
+ "old" file - thanks to Philipp Weis for noticing! (Closes: #571541)
+ * debian/rules:
+ - remove targets referring to CVS or arch as they are useless
+ - use $(CURDIR) instead of $(pwd)
+ - use dpkg-buildflags if available for CXXFLAGS
+ * README.arch:
+ - remove the file completely as it has no use nowadays
+ * apt-pkg/depcache.cc:
+ - be doublesure that the killer query is empty before starting reinstall
+ * methods/gpgv.cc:
+ - remove the keyrings count limit by using vector magic
+ * contrib/mmap.cc:
+ - clarify "MMap reached size limit" error message, thanks Ivan Masár!
+ * doc/apt.ent
+ - add entities for the current oldstable/stable/testing codenames
+ * doc/sources.list.5.xml:
+ - use stable-codename instead of stable in the examples (Closes: #531492)
+ * doc/apt_preferences.5.xml:
+ - adapt some examples here to use current codenames as well
+ - add "NotAutomatic: yes" handling, thanks Osamu Aoki (Closes: #490347)
+ * debian/libapt-pkg-doc.doc-base.cache:
+ - remove yet another reference to the removed cache.sgml
+ * doc/apt-get.8.xml:
+ - do not say explicit target_release_{name,version,codename}, it should
+ be clear by itself and 'man' can break lines again (Closes: #566166)
+ - remove the gnome-apt reference as it is removed from unstable
+ * apt-pkg/deb/dpkgpm.cc:
+ - add 'disappear' to the known processing states, thanks Jonathan Nieder
+ * apt-pkg/packagemanager.h:
+ - export info about disappeared packages with GetDisappearedPackages()
+
+ [ Michael Vogt ]
+ * methods/http.{cc,h}:
+ - code cleanup, use enums instead of magic ints
+
+ [ Jari Aalto ]
+ * debian/rules:
+ - spell out some less known options to reduce manpage consultation-rate
+ - Use POSIX command substitution: $(<command sequence>)
+ - Remove EOL whitespace (Closes: #577804)
+
+ [ Julian Andres Klode ]
+ * apt-pkg/acquire-item.cc:
+ - Fix pkgAcqFile::Custom600Headers() to always return something.
+
+
+ [ Christian Perrier ]
+ * Slovak translation update. Closes: #581159
+ * Italian translation update. Closes: #581742
+
+ -- Michael Vogt <mvo@debian.org> Tue, 25 May 2010 16:01:42 +0200
+
+apt (0.7.26~exp4) experimental; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/depcache.cc:
+ - rewrite the pseudo package reinstaller to be more intelligent
+ in his package choices
+ * apt-pkg/packagemanager.cc:
+ - don't try to "unpack" pseudo packages twice
+ * apt-pkg/contrib/fileutl.cc:
+ - add a parent-guarded "mkdir -p" as CreateDirectory()
+ * apt-pkg/acquire.{cc,h}:
+ - add a delayed constructor with Setup() for success reporting
+ - check for and create directories in Setup if needed instead of
+ error out unfriendly in the Constructor (Closes: #523920, #525783)
+ - optional handle a lock file in Setup()
+ * apt-pkg/acquire-item.cc:
+ - Acquire::ForceHash to force method for expected hash
+ * cmdline/apt-get.cc:
+ - remove the lock file handling and let Acquire take care of it instead
+ - display MD5Sum in --print-uris if not forced to use another method
+ instead of displaying the strongest available (Closes: #576420)
+ - regex for package names executed on Grp- not PkgIterator
+ - show non-candidates as fallback for virtual packages (Closes: #578385)
+ - set also "all" to this version for pseudo packages in TryToChangeVer
+ * apt-pkg/deb/dpkgpm.cc:
+ - remove Chroot-Directory from files passed to install commands.
+ Thanks to Kel Modderman for report & patch! (Closes: #577226)
+ * ftparchive/writer.cc:
+ - remove 999 chars Files and Checksums rewrite limit (Closes: #577759)
+ * cmdline/apt-cache.cc:
+ - align Installed and Candidate Version in policy so they can be compared
+ easier, thanks Ralf Gesellensetter for the pointer! (Closes: #578657)
+ * doc/apt.ent:
+ - Add a note about APT_CONFIG in the -c description (Closes: #578267)
+ * doc/po/de.po:
+ - correct typos in german apt_preferences manpage, thanks Chris Leick!
+ * apt-pkg/sourcelist.cc:
+ - be less strict and accept [option=value] as well
+ * apt-pkg/contrib/configuration.cc:
+ - error out if #clear directive has no argument
+ * doc/files.sgml:
+ - sync documentation with status quo, regarding files/directories in
+ use, extended_states and uri schemes.
+ * doc/cache.sgml:
+ - drop the file in favor of inplace documentation with doxygen
+ * apt-pkg/pkgcache.h:
+ - enhance the Groups ABI by providing a ID as the other structs does
+ - check also the size of the Group struct then checking for the others
+
+ [ Jari Aalto ]
+ * cmdline/apt-get.cc:
+ - replace backticks with single quotes around fix-broken command
+ in the broken packages message. (Closes: #577168)
+ * dselect/install:
+ - modernize if-statements not to use 'x' (Closes: #577117)
+ - replace backticks with POSIX $() (Closes: #577116)
+
+ [ Michael Vogt ]
* [ Abi break ] apt-pkg/acquire-item.{cc,h}:
- add "IsIndexFile" to constructor of pkgAcqFile so that it sends
the right cache control headers
+ * cmdline/apt-get.cc:
+ - fix crash when pkg.VersionList() is empty
* apt-pkg/depcache.cc:
- fix incorrect std::cout usage for debug output
* test/libapt/getlanguages_test.cc:
@@ -58,11 +350,26 @@ apt (0.7.26~exp4) unstable; urgency=low
* apt-pkg/deb/debrecords.cc:
- fix max tag buffer size (LP: #545336, closes: #578959)
* debian/rules:
- - install html doxygen in libapt-pkg-doc as well
+ - install html doxygen in libapt-pkg-doc
+ * debian/control:
+ - build-depend on doxygen
+
+ [ Julian Andres Klode ]
+ * apt-pkg/contrib/weakptr.h:
+ - add a class WeakPointable which allows one to register weak pointers to
+ an object which will be set to NULL when the object is deallocated.
+ * [ABI break] apt-pkg/acquire{-worker,-item,}.h:
+ - subclass pkgAcquire::{Worker,Item,ItemDesc} from WeakPointable.
+ * apt-pkg/pkgcache.cc:
+ - Merge fix from David to correct handling in single-arch environments.
+ * cmdline/apt-cache.cc:
+ - Add a showauto command to apt-cache.
+ * cmdline/apt-get.cc:
+ - Add apt-get markauto and unmarkauto commands.
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 04 May 2010 09:55:08 +0200
+ -- Michael Vogt <mvo@debian.org> Thu, 06 May 2010 09:32:54 +0200
-apt (0.7.26~exp3) UNRELEASED; urgency=low
+apt (0.7.26~exp3) experimental; urgency=low
[ Christian Perrier ]
* German translation update. Closes: #571037
@@ -72,6 +379,68 @@ apt (0.7.26~exp3) UNRELEASED; urgency=low
* Add "manpages-pl (<< 20060617-3~)" to avoid file conflicts with
that package that was providing some manpages for APT utilities.
+ [ David Kalnischkies ]
+ * [BREAK] merge MultiArch-ABI. We don't support MultiArch,
+ but we support the usage of the new ABI so libapt users
+ can start to prepare for MultiArch (Closes: #536029)
+ * Ignore :qualifiers after package name in build dependencies
+ in the library by default, but try to honour them in apt-get
+ as we have some sort of MultiArch support ready (Closes: #558103)
+ * add translation of the manpages to PT (portuguese)
+ Thanks to Américo Monteiro!
+ * Switch to dpkg-source 3.0 (native) format
+ * apt-pkg/depcache.cc:
+ - remove Auto-Installed information from extended_states
+ together with the package itself (Closes: #572364)
+ * cmdline/apt-mark:
+ - don't crash if no arguments are given (Closes: #570962)
+ * debian/control:
+ - remove some years old and obsolete Replaces
+ - add automake/conf build-depends/conflicts as recommend by
+ the autotools-dev README (Closes: #572615)
+ * apt-pkg/contrib/mmap.{h,cc}:
+ - add char[] fallback for filesystems without shared writable
+ mmap() like JFFS2. Thanks to Marius Vollmer for writing
+ and to Loïc Minier for pointing to the patch! (Closes: #314334)
+ * doc/apt_preferences.5.xml:
+ - fix two typos and be more verbose in the novice warning.
+ Thanks to Osamu Aoki for pointing it out! (Closes: #567669)
+ - fix a=sid vs. n=sid typo, thanks Ansgar Burchardt!
+ - origin can be used to match a hostname (Closes: #352667)
+ - remove wrong pin-priority is optional remark (Closes: #574944)
+ * apt-pkg/deb/dpkgpm.cc:
+ - fix error message construction in OpenLog()
+ - if available store the Commandline in the history
+ * cmdline/apt-get.cc:
+ - add a --only-upgrade flag to install command (Closes: #572259)
+ - fix memory leaks in error conditions in DoSource()
+ - try version match in FindSrc first exact than fuzzy (LP: #551178)
+ * apt-pkg/contrib/cmndline.cc:
+ - save Commandline in Commandline::AsString for logging
+ * apt-pkg/deb/debversion.cc:
+ - consider absent of debian revision equivalent to 0 (Closes: #573592)
+ * doc/makefile, doc/*:
+ - generate subdirectories for building the manpages in on the fly
+ depending on the po files we have.
+ * apt-pkg/pkgcachegen.cc:
+ - merge versions correctly even if multiple different versions
+ with the same version number are available.
+ Thanks to Magnus Holmgren for the patch! (Closes: #351056)
+ * ftparchive/writer.cc:
+ - write LongDescriptions if they shouldn't be included in Packages
+ file into i18n/Translation-en by default.
+ * doc/po/de.po:
+ - correct a few typos in the german manpage translation.
+ Thanks to Chris Leick and Georg Koppen! (Closes: #574962)
+ * apt-pkg/contrib/strutl.cc:
+ - convert all toupper calls to tolower_ascii for a little speedup
+
+ [ Jean-Baptiste Lallement ]
+ * apt-pkg/contrib/strutl.cc:
+ - always escape '%' (LP: #130289) (Closes: #500560)
+ - unescape '%' sequence only if followed by 2 hex digit
+ - username/password are urlencoded in proxy string (RFC 3986)
+
[ Julian Andres Klode ]
* cmdline/apt-cache.cc:
- Change behavior of showsrc to match the one of show (Closes: #512046).
@@ -104,7 +473,7 @@ apt (0.7.26~exp3) UNRELEASED; urgency=low
* doc/examples/configure-index:
- add missing Debug::pkgPackageManager option
- -- Christian Perrier <bubulle@debian.org> Wed, 24 Feb 2010 22:13:50 +0100
+ -- Michael Vogt <mvo@debian.org> Thu, 01 Apr 2010 17:30:43 +0200
apt (0.7.26~exp2) experimental; urgency=low
@@ -1504,13 +1873,6 @@ apt (0.7.6) unstable; urgency=low
-- Otavio Salvador <otavio@debian.org> Wed, 01 Aug 2007 19:49:51 -0300
-apt (0.7.6) unstable; urgency=low
-
- * Applied patch from Aurelien Jarno <aurel32@debian.org> to fix wrong
- directory downloading on non-linux architectures (closes: #435597)
-
- -- Otavio Salvador <otavio@debian.org> Wed, 01 Aug 2007 19:49:51 -0300
-
apt (0.7.5) unstable; urgency=low
[ Otavio Salvador ]
diff --git a/debian/control b/debian/control
index 58916a2b9..757b761e5 100644
--- a/debian/control
+++ b/debian/control
@@ -5,14 +5,15 @@ Maintainer: APT Development Team <deity@lists.debian.org>
Uploaders: Michael Vogt <mvo@debian.org>, Otavio Salvador <otavio@debian.org>,
Christian Perrier <bubulle@debian.org>, Daniel Burrows <dburrows@debian.org>,
Luca Bruno <lethalman88@gmail.com>, Julian Andres Klode <jak@debian.org>
-Standards-Version: 3.8.4
-Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5), zlib1g-dev | libz-dev, debiandoc-sgml, xsltproc, docbook-xsl, po4a (>= 0.34-2), autotools-dev
+Standards-Version: 3.9.0
+Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5), zlib1g-dev | libz-dev, debiandoc-sgml, xsltproc, docbook-xsl, po4a (>= 0.34-2), autotools-dev, autoconf, automake, doxygen
+Build-Conflicts: autoconf2.13, automake1.4
Vcs-Bzr: http://bzr.debian.org/apt/debian-sid/
Package: apt
Architecture: any
Depends: ${shlibs:Depends}, debian-archive-keyring, ${misc:Depends}
-Replaces: libapt-pkg-doc (<< 0.3.7), libapt-pkg-dev (<< 0.3.7), manpages-pl (<< 20060617-3~)
+Replaces: manpages-pl (<< 20060617-3~)
Provides: ${libapt-pkg:provides}
Conflicts: python-apt (<< 0.7.93.2~)
Suggests: aptitude | synaptic | wajig, dpkg-dev, apt-doc, bzip2, lzma, python-apt
@@ -28,7 +29,6 @@ Package: apt-doc
Architecture: all
Priority: optional
Depends: ${misc:Depends}
-Replaces: apt (<< 0.5.4.9)
Section: doc
Description: Documentation for APT
This package contains the user guide and offline guide, for APT, an
@@ -60,7 +60,6 @@ Package: apt-utils
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
Provides: ${libapt-inst:provides}
-Replaces: apt (<< 0.5.9)
Description: APT utility programs
This package contains some APT utility programs such as apt-ftparchive,
apt-sortpkgs and apt-extracttemplates.
diff --git a/debian/libapt-pkg-doc.doc-base.cache b/debian/libapt-pkg-doc.doc-base.cache
deleted file mode 100644
index 4b47db810..000000000
--- a/debian/libapt-pkg-doc.doc-base.cache
+++ /dev/null
@@ -1,18 +0,0 @@
-Document: libapt-pkg-doc-cache
-Title: APT Cache Specification
-Author: Jason Gunthorpe
-Abstract: The APT Cache Specification describes the complete implementation
- and format of the APT Cache file. The APT Cache file is a way for APT to
- parse and store a large number of package files for display in the UI.
- It's primary design goal is to make display of a single package in the
- tree very fast by pre-linking important things like dependencies and
- provides. The specification doubles as documentation for one of the
- in-memory structures used by the package library and the APT GUI.
-Section: Debian
-
-Format: html
-Index: /usr/share/doc/libapt-pkg-doc/cache.html/index.html
-Files: /usr/share/doc/libapt-pkg-doc/cache.html/*.html
-
-Format: text
-Files: /usr/share/doc/libapt-pkg-doc/cache.text.gz
diff --git a/debian/rules b/debian/rules
index 450f3e0f6..8bfcaf385 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,10 +27,14 @@ endif
# See below
-include build/environment.mak
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- export CXXFLAGS = -O0 -g -Wall
+ifneq (,$(shell which dpkg-buildflags))
+ export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
else
- export CXXFLAGS = -O2 -g -Wall
+ ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ export CXXFLAGS = -O0 -g -Wall
+ else
+ export CXXFLAGS = -O2 -g -Wall
+ endif
endif
# Default rule
@@ -47,7 +51,7 @@ BASE=.
ifdef BUILD
BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
else
-BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
+BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
endif
BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
@@ -82,9 +86,9 @@ LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
debian/shlibs.local: apt-pkg/makefile
- # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
+ # We have 3 shlibs.local files: One for 'apt', one for 'apt-utils' and
# one for the rest of the packages. This ensures that each package gets
- # the right overrides..
+ # the right overrides…
rm -rf $@ $@.apt $@.apt-utils
echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
@@ -94,8 +98,8 @@ debian/shlibs.local: apt-pkg/makefile
echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
echo "libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
-build: build/build-stamp
-build-doc: build/build-doc-stamp
+build: build/build-stamp
+build-doc: build/build-doc-stamp
# Note that this is unconditionally done first as part of loading environment.mak
# The true is needed to force make to reload environment.mak after running
@@ -123,10 +127,8 @@ build/build-doc-stamp: build/configure-stamp
clean:
dh_testdir
-# dh_testroot
- [ -f Makefile ] && $(MAKE) clean
- [ -f Makefile ] && $(MAKE) distclean
+ [ ! -f Makefile ] || $(MAKE) clean distclean
rm -rf build
# Add here commands to clean up after the build process.
@@ -141,23 +143,20 @@ libapt-pkg-doc: build-doc debian/shlibs.local
dh_installdirs -p$@
#
# libapt-pkg-doc install
-#
- dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
- $(BLD)/docs/files* $(BLD)/docs/method* \
- doc/libapt-pkg2_to_3.txt doc/style.txt \
- $(BLD)/doc/doxygen/html/*
+#
+ dh_installdocs -p$@ $(BLD)/docs/design* \
+ $(BLD)/docs/dpkg-tech* \
+ $(BLD)/docs/files* \
+ $(BLD)/docs/method* \
+ doc/libapt-pkg2_to_3.txt \
+ doc/style.txt \
+ $(BLD)/doc/doxygen/html
dh_installexamples -p$@
-# dh_installmenu -p$@
-# dh_installinit -p$@
-# dh_installcron -p$@
-# dh_installman -p$@
-# dh_undocumented -p$@
dh_installchangelogs -p$@
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
-# dh_suidregister -p$@
dh_installdeb -p$@
dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
dh_md5sums -p$@
@@ -171,8 +170,10 @@ apt-doc: build-doc
# apt-doc install
#
# Copy the guides
- dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
- $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
+ dh_installdocs -p$@ $(BLD)/docs/guide*.text \
+ $(BLD)/docs/guide*.html \
+ $(BLD)/docs/offline*.text \
+ $(BLD)/docs/offline*.html
dh_installchangelogs -p$@
dh_compress -p$@
dh_fixperms -p$@
@@ -215,7 +216,6 @@ apt: build build-doc debian/shlibs.local
cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
-# head -n 500 ChangeLog > debian/ChangeLog
# copy lintian override
cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
@@ -225,6 +225,10 @@ apt: build build-doc debian/shlibs.local
rm -f build/po/*.pot
rm -f po/*.pot
+ # move the mirror failure script in place
+ #mv debian/$@/usr/bin/apt-report-mirror-failure \
+ # debian/$@/usr/lib/apt/apt-report-mirror-failure \
+
dh_installexamples -p$@ $(BLD)/docs/examples/*
dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
dh_installcron -p$@
@@ -233,9 +237,9 @@ apt: build build-doc debian/shlibs.local
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
- dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
+ dh_makeshlibs -p$@ --major=$(LIBAPTPKG_MAJOR) --version-info='$(LIBAPTPKG_PROVIDE)'
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
+ dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@
@@ -254,16 +258,11 @@ libapt-pkg-dev: build debian/shlibs.local
cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
dh_installdocs -p$@
-# dh_installmenu -p$@
-# dh_installinit -p$@
-# dh_installcron -p$@
-# dh_installman -p$@
dh_installchangelogs -p$@
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
-# dh_suidregister -p$@
dh_installdeb -p$@
dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
dh_md5sums -p$@
@@ -291,9 +290,9 @@ apt-utils: build debian/shlibs.local
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
- dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
+ dh_makeshlibs -p$@ --major=$(LIBAPTINST_MAJOR) --version-info='$(LIBAPTINST_PROVIDE)'
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
+ dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@
@@ -305,7 +304,7 @@ apt-transport-https: build debian/shlibs.local libapt-pkg-dev
dh_installdirs -p$@
# install the method
- mkdir -p debian/$@/usr/lib/apt/methods
+ mkdir --parents debian/$@/usr/lib/apt/methods
cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
dh_installdocs -p$@ debian/apt-transport-https.README
@@ -319,61 +318,18 @@ apt-transport-https: build debian/shlibs.local libapt-pkg-dev
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib
+ dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
dh_gencontrol -p$@
dh_md5sums -p$@
dh_builddeb -p$@
-source diff:
- @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-# Update from CVS
-l33ch: really-clean
- cvs update
- buildlib/mkChangeLog
-
-# Update from CVS and then configure for build
-super-l33ch: l33ch Makefile.in
-
configure:
$(MAKE) configure
-l33ch-stamp: super-l33ch
- touch $@
-
really-clean: clean
- -find -name Makefile.in -print0 | xargs -0r rm -f
+ -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
find -name ChangeLog | xargs rm -f
rm -f l33ch-stamp
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
-
-
-# Done by the uploader.
-#cvs update..
-#edit debian/changelog
-# configure.in has the version automatically updated now.
-# edit configure.in
-# debian/rules cvs-build
-
-CVS_BUILDDIR=apt-$(APT_DEBVER)
-CVS_ROOT=$(shell cat CVS/Root)
-CVS_MODULE=$(shell cat CVS/Repository)
-cvs-build:
- rm -rf debian/cvs-build
- mkdir -p debian/cvs-build
- (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
- $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
- (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
-
-cvs-mkul:
- -mkdir -p ../upload-$(APT_DEBVER)
- cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
-
-arch-build:
- rm -rf debian/arch-build
- mkdir -p debian/arch-build/apt-$(APT_DEBVER)
- tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
- $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
- (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)