summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily11
-rw-r--r--debian/changelog21
-rw-r--r--debian/control2
3 files changed, 31 insertions, 3 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index bb6c0151e..17fe8fb78 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -38,8 +38,9 @@ update_stamp()
UpdateInterval=0
DownloadUpgradeableInterval=0
-RES=`apt-config shell UpdateInterval APT::Periodic::Update-Package-Lists DownloadUpgradeableInterval APT::Periodic::Download-Upgradeable-Packages`
-eval $RES
+eval $(apt-config shell UpdateInterval APT::Periodic::Update-Package-Lists DownloadUpgradeableInterval APT::Periodic::Download-Upgradeable-Packages)
+AutocleanInterval=$DownloadUpgradeableInterval
+eval $(apt-config shell AutocleanInterval APT::Periodic::Autoclean)
# laptop check, on_ac_power returns:
# 0 (true) System is on mains power
@@ -68,3 +69,9 @@ if check_stamp $DOWNLOAD_UPGRADEABLE_STAMP $DownloadUpgradeableInterval; then
apt-get -qq -d dist-upgrade 2>/dev/null
update_stamp $DOWNLOAD_UPGRADEABLE_STAMP
fi
+
+AUTOCLEAN_STAMP=/var/lib/apt/periodic/autoclean-stamp
+if check_stamp $AUTOCLEAN_STAMP $AutocleanInterval; then
+ apt-get -qq autoclean
+ update_stamp $AUTOCLEAN_STAMP
+fi
diff --git a/debian/changelog b/debian/changelog
index a971e30b1..28279ebf4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,24 @@
+apt (0.5.32) unstable; urgency=low
+
+ * Call setlocale and bindtextdomain in the http method, so that the
+ messages are properly localised (Closes: #282700)
+
+ --
+
+apt (0.5.31) unstable; urgency=low
+
+ * New Romanian translation from Sorin Batariuc <sorin@bonbon.net>
+ (Closes: #281458)
+ * Merge changes from Hoary (0.5.30,0.5.30ubuntu2]
+ * Fix the example in apt_preferences(5) to match the text
+ (Closes: #222267)
+ * Add APT::Periodic::Autoclean setting, to allow "apt-get autoclean" to
+ be run periodically. This is useful with
+ APT::Periodic::Download-Upgradeable-Packages, and defaults to the same
+ value, so that the cache size is bounded
+
+ -- Matt Zimmerman <mdz@debian.org> Tue, 23 Nov 2004 12:53:04 -0800
+
apt (0.5.30ubuntu2) hoary; urgency=low
* bzip2 is now "Suggested" and it will detect if bzip2 is installed
diff --git a/debian/control b/debian/control
index 3ac709906..a1e376b9d 100644
--- a/debian/control
+++ b/debian/control
@@ -52,7 +52,7 @@ Description: Documentation for APT development
Package: apt-utils
Architecture: any
-Depends: bzip2, ${shlibs:Depends}
+Depends: ${shlibs:Depends}
Priority: optional
Provides: ${libapt-inst:provides}
Replaces: apt (<< 0.5.9)