summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily6
-rw-r--r--debian/changelog7
2 files changed, 13 insertions, 0 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 48714ec15..4f7eff47b 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -170,6 +170,12 @@ if which on_ac_power >/dev/null; then
fi
fi
+# check if we can lock the cache and if the cache is clean
+if ! apt-get check -q -q 2>/dev/null; then
+ exit 1
+fi
+
+
UPDATE_STAMP=/var/lib/apt/periodic/update-stamp
if check_stamp $UPDATE_STAMP $UpdateInterval; then
if apt-get -qq update 2>/dev/null; then
diff --git a/debian/changelog b/debian/changelog
index 7213c6773..79efaf1a6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+apt (0.7.6ubuntu14) gutsy; urgency=low
+
+ * debian/apt.cron.daily:
+ - only run the cron job if apt-get check succeeds (LP: #131719)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 12 Oct 2007 17:56:22 +0200
+
apt (0.7.6ubuntu13) gutsy; urgency=low
* apt-pkg/deb/dpkgpm.cc: