summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog64
-rw-r--r--debian/control8
-rw-r--r--debian/libapt-inst1.4.install2
-rw-r--r--debian/libapt-inst1.4.install.in2
-rw-r--r--debian/libapt-pkg-dev.dirs2
-rw-r--r--debian/libapt-pkg-dev.install3
-rw-r--r--debian/libapt-pkg-dev.install.in3
-rw-r--r--debian/libapt-pkg4.12.install2
-rw-r--r--debian/libapt-pkg4.12.install.in2
-rwxr-xr-xdebian/rules12
10 files changed, 82 insertions, 18 deletions
diff --git a/debian/changelog b/debian/changelog
index e6389dd06..06c84f31c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,51 @@
+apt (0.8.16~exp9) UNRELEASED; urgency=low
+
+ [ Julian Andres Klode ]
+ * apt-pkg/cdrom.cc:
+ - Accept .bz2, .xz files in addition to .gz files (Closes: #649451)
+
+ [ Michael Vogt ]
+ * apt-pkg/cdrom.cc:
+ - use aptconfiguration to get the supported compression types
+ * debian/control:
+ - bump debhelper build-dep to debhelper (>= 8.1.3~)
+ - set libapt-pkg-dev to multi-arch: same too
+
+ [ Colin Watson ]
+ * Convert libapt-pkg4.12 and libapt-inst1.4 to Multi-Arch: same.
+
+ [ David Kalnischkies ]
+ * apt-pkg/cacheset.cc:
+ - make the cachesets real containers which can embedding any container
+ to be able to use the same interface regardless of set or list usage
+ - provide a {Package,Version}List similar to {Package,Version}Set
+ * cmdline/apt-{get,cache,mark}.cc:
+ - use Lists instead of Sets if input order should be preserved for
+ commands accepting lists of packages, e.g. policy (Closes: #625960)
+ * apt-pkg/depcache.cc:
+ - prefer native providers over foreigns even if the chain is foreign
+ * cmdline/apt-get.cc:
+ - ignore foreign architectures if we check if a provides has only one
+ resolver as it's basically the same for the user, so no need to choose
+ * cmdline/apt-config.cc:
+ - dump the APT::Compressor settings correctly and completely
+ * apt-pkg/contrib/fileutl.{h,cc}:
+ - implement a ModificationTime method for FileFd
+ - add a ReadLine method
+ - drop the explicit export of gz-compression handling
+ * apt-pkg/cdrom.cc:
+ - support InRelease files on cdrom
+
+ [ Michael Vogt ]
+ * g++ 4.7 fixes
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Sun, 11 Dec 2011 19:34:58 +0100
+
apt (0.8.16~exp8) experimental; urgency=low
[ David Kalnischkies ]
+ * algorithms.cc:
+ - show a debug why a package was kept by ResolveByKeep()
* apt-pkg/packagemanager.cc:
- do not fail on unpacked packages in SmartUnPack, just don't
shedule them for unpack, but do all checks and configure them
@@ -9,9 +54,6 @@ apt (0.8.16~exp8) experimental; urgency=low
- use a pointer-union to peace gcc strict-aliasing warning
* apt-pkg/deb/deblistparser.cc:
- M-A: foreign packages provide for other archs, too
-
- [ Michael Vogt ]
- * g++ 4.7 fixes
-- David Kalnischkies <kalnischkies@gmail.com> Thu, 03 Nov 2011 09:40:29 -0500
@@ -199,13 +241,25 @@ apt (0.8.16~exp1) experimental; urgency=low
-- Michael Vogt <mvo@debian.org> Wed, 29 Jun 2011 12:40:31 +0200
-apt (1.8.15.9+nmu1) unstable; urgency=low
+apt (0.8.15.10) UNRELEASEDunstable; urgency=low
[ David Kalnischkies ]
* algorithms.cc:
- show a debug why a package was kept by ResolveByKeep()
+ * doc/manpage-style.xml:
+ - put <brackets> around email addresses
+ * doc/po/de.po:
+ - apply typo-fix from Michael Basse, thanks! (LP: #900770)
+
+ [ Chris Leick ]
+ * German manpage translation update
+ * doc/*.xml:
+ - find and fix a bunch of misspellings
+
+ [ Program translation updatex ]
+ * Dutch (Jeroen Schot). Closes: #652230
- -- David Kalnischkies <kalnischkies@gmail.com> Mon, 17 Oct 2011 16:36:22 +0200
+ -- David Kalnischkies <kalnischkies@gmail.com> Tue, 06 Dec 2011 16:35:39 +0100
apt (0.8.15.9) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 7efb6ca8a..03d74c51f 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Uploaders: Michael Vogt <mvo@debian.org>, Otavio Salvador <otavio@debian.org>,
Christian Perrier <bubulle@debian.org>, Daniel Burrows <dburrows@debian.org>,
Julian Andres Klode <jak@debian.org>
Standards-Version: 3.9.2
-Build-Depends: dpkg-dev (>= 1.15.8), debhelper (>= 7.2.3~), libdb-dev,
+Build-Depends: dpkg-dev (>= 1.15.8), debhelper (>= 8.1.3~), libdb-dev,
gettext (>= 0.12), libcurl4-gnutls-dev (>= 7.19.0),
zlib1g-dev | libz-dev, debiandoc-sgml, xsltproc, docbook-xsl, docbook-xml,
po4a (>= 0.34-2), autotools-dev, autoconf, automake, doxygen
@@ -37,6 +37,8 @@ Description: APT's commandline package manager
Package: libapt-pkg4.12
Architecture: any
+Multi-Arch: same
+Pre-Depends: ${misc:Pre-Depends}
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: APT's package managment runtime library
This library provides the common functionality for searching and
@@ -56,6 +58,8 @@ Description: APT's package managment runtime library
Package: libapt-inst1.4
Architecture: any
+Multi-Arch: same
+Pre-Depends: ${misc:Pre-Depends}
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: APT's deb package format runtime library
This library provides methods to query and extract information
@@ -73,7 +77,9 @@ Description: Documentation for APT
Package: libapt-pkg-dev
Architecture: any
+Multi-Arch: same
Priority: optional
+Pre-Depends: ${misc:Pre-Depends}
Depends: ${libapt-pkg-name} (= ${binary:Version}), ${libapt-inst-name} (= ${binary:Version}), ${misc:Depends}, zlib1g-dev | zlib-dev
Section: libdevel
Description: Development files for APT's libapt-pkg and libapt-inst
diff --git a/debian/libapt-inst1.4.install b/debian/libapt-inst1.4.install
deleted file mode 100644
index b7b63be81..000000000
--- a/debian/libapt-inst1.4.install
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/libapt-inst*.so.* usr/lib/
-usr/share/locale/*/*/libapt-inst*.mo
diff --git a/debian/libapt-inst1.4.install.in b/debian/libapt-inst1.4.install.in
new file mode 100644
index 000000000..8bcce2c28
--- /dev/null
+++ b/debian/libapt-inst1.4.install.in
@@ -0,0 +1,2 @@
+bin/libapt-inst*.so.* usr/lib/@DEB_HOST_MULTIARCH@/
+usr/share/locale/*/*/libapt-inst*.mo
diff --git a/debian/libapt-pkg-dev.dirs b/debian/libapt-pkg-dev.dirs
deleted file mode 100644
index 844642ab0..000000000
--- a/debian/libapt-pkg-dev.dirs
+++ /dev/null
@@ -1,2 +0,0 @@
-usr/lib
-usr/include/apt-pkg
diff --git a/debian/libapt-pkg-dev.install b/debian/libapt-pkg-dev.install
deleted file mode 100644
index bd1a6c174..000000000
--- a/debian/libapt-pkg-dev.install
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/libapt-pkg*.so usr/lib/
-bin/libapt-inst*.so usr/lib/
-include/apt-pkg/*.h usr/include/apt-pkg/
diff --git a/debian/libapt-pkg-dev.install.in b/debian/libapt-pkg-dev.install.in
new file mode 100644
index 000000000..be8022107
--- /dev/null
+++ b/debian/libapt-pkg-dev.install.in
@@ -0,0 +1,3 @@
+bin/libapt-pkg*.so usr/lib/@DEB_HOST_MULTIARCH@/
+bin/libapt-inst*.so usr/lib/@DEB_HOST_MULTIARCH@/
+include/apt-pkg/*.h usr/include/apt-pkg/
diff --git a/debian/libapt-pkg4.12.install b/debian/libapt-pkg4.12.install
deleted file mode 100644
index 91b39a31b..000000000
--- a/debian/libapt-pkg4.12.install
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/libapt-pkg*.so.* usr/lib/
-usr/share/locale/*/*/libapt-pkg*.mo
diff --git a/debian/libapt-pkg4.12.install.in b/debian/libapt-pkg4.12.install.in
new file mode 100644
index 000000000..56bed39d3
--- /dev/null
+++ b/debian/libapt-pkg4.12.install.in
@@ -0,0 +1,2 @@
+bin/libapt-pkg*.so.* usr/lib/@DEB_HOST_MULTIARCH@/
+usr/share/locale/*/*/libapt-pkg*.mo
diff --git a/debian/rules b/debian/rules
index 30474c06b..4ef5bb47a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,7 @@
export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
# FOR AUTOCONF 2.52 AND NEWER ONLY
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
@@ -118,6 +119,11 @@ clean:
[ ! -f Makefile ] || $(MAKE) clean distclean
rm -rf build
+ rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
+ debian/libapt-pkg-dev.install
+
+debian/%.install: debian/%.install.in
+ sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
binary-indep: apt-doc libapt-pkg-doc
# Build architecture-independent files here.
@@ -217,7 +223,7 @@ apt: build build-doc
dh_md5sums -p$@
dh_builddeb -p$@
-libapt-pkg-dev: build
+libapt-pkg-dev: build debian/libapt-pkg-dev.install
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -265,7 +271,7 @@ apt-utils: build
dh_md5sums -p$@
dh_builddeb -p$@
-$(LIBAPT_PKG): build
+$(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -284,7 +290,7 @@ $(LIBAPT_PKG): build
dh_md5sums -p$@
dh_builddeb -p$@
-$(LIBAPT_INST): build
+$(LIBAPT_INST): build debian/$(LIBAPT_INST).install
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@