summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog33
-rw-r--r--debian/tests/control2
-rw-r--r--debian/tests/run-tests4
3 files changed, 37 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 52e4e7a3a..5b885ad6c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -68,6 +68,39 @@ apt (1.1~exp1) experimental; urgency=low
-- Michael Vogt <mvo@debian.org> Thu, 19 Jun 2014 12:01:48 +0200
+apt (1.0.7) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * add REAMDE.md
+ * StringToBool: only act if the entire string is consumed by strtol()
+ * Use @builddeps@ in the debian/tests/control file
+ * apt-pkg/acquire-item.cc: make pkgAcqDiffIndex more uniform
+ * Fix SmartConfigure to ignore ordering of packages that are already valid
+ * doc/apt.8.xml: fix typo, thanks to Jakub Wilk (Closes: #756056)
+ * doc/po/pt.po: updated, thanks to Américo Monteir (Closes: #756200)
+
+ [ victory ]
+ * Update Japanese documentation translation (Closes: #754817)
+
+ [ Trần Ngọc Quân ]
+ * l10n: vi.po (636t): Update one new string
+
+ [ Julian Andres Klode ]
+ * Fix debListParser to accept "no" as a value for the Multi-Arch field
+ (Closes: #759099)
+
+ [ Mert Dirik ]
+ * Turkish program translation update (Closes: 756710)
+
+ [ Miroslav Kure ]
+ * Czech program translation update (Closes: 758208)
+
+ [ David Kalnischkies ]
+ * add dpkg::source-options for dpkg-source invocation (Closes: 757534)
+ * support versioned provides as implemented by dpkg (Closes: 758153)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 27 Aug 2014 17:11:42 -0700
+
apt (1.0.6) unstable; urgency=medium
[ Chris Leick ]
diff --git a/debian/tests/control b/debian/tests/control
index ecaa089d8..f7e47c5f3 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,3 +1,3 @@
Tests: run-tests
Restrictions: allow-stderr
-Depends: @, build-essential, fakeroot, wget, dpkg-dev, debhelper, libdb-dev, gettext, libcurl4-gnutls-dev, zlib1g-dev, libbz2-dev, xsltproc, docbook-xsl, docbook-xml, po4a, autotools-dev, autoconf, automake, doxygen, stunnel4, libdb-dev, db-util
+Depends: @, @builddeps@, fakeroot, wget, stunnel4, db-util
diff --git a/debian/tests/run-tests b/debian/tests/run-tests
index 308031e9d..9d7c484fc 100644
--- a/debian/tests/run-tests
+++ b/debian/tests/run-tests
@@ -8,7 +8,9 @@ if [ ! -e environment.mak ]; then
fi
make -C test/interactive-helper/
-# run against the installed apt
+# run tests against the installed apt, use "env -i" to ensure
+# the host env does not pollute our environment
+env -i \
APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
APT_INTEGRATION_TESTS_LIBEXEC_DIR=/usr/lib/apt/ \