summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily43
-rw-r--r--debian/changelog117
-rw-r--r--debian/control2
3 files changed, 133 insertions, 29 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index a699f0583..8c69a389a 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -11,7 +11,7 @@
# Dir::Cache "var/apt/cache/";
# - Set apt package cache directory
#
-# Dir::Cache::Archive "archives/";
+# Dir::Cache::Archives "archives/";
# - Set package archive directory
#
# APT::Periodic::Enable "1";
@@ -147,21 +147,14 @@ check_size_constraints()
eval $(apt-config shell MaxSize APT::Archives::MaxSize)
eval $(apt-config shell MaxSize APT::Periodic::MaxSize)
- CacheDir="var/cache/apt/"
- eval $(apt-config shell CacheDir Dir::Cache)
- CacheDir=${CacheDir%/}
-
- CacheArchive="archives/"
- eval $(apt-config shell CacheArchive Dir::Cache::archives)
- CacheArchive=${CacheArchive%/}
+ Cache="/var/cache/apt/archives/"
+ eval $(apt-config shell Cache Dir::Cache::archives/d)
# sanity check
- if [ -z "$CacheDir" -o -z "$CacheArchive" ]; then
- echo "empty Dir::Cache or Dir::Cache::archives, exiting"
+ if [ -z "$Cache" ]; then
+ echo "empty Dir::Cache::archives, exiting"
exit
fi
-
- Cache="${Dir%/}/${CacheDir%/}/${CacheArchive%/}/"
# check age
if [ ! $MaxAge -eq 0 ] && [ ! $MinAge -eq 0 ]; then
@@ -225,22 +218,17 @@ do_cache_backup()
fi
# Set default values and normalize
- Dir="/"
- eval $(apt-config shell Dir Dir)
- Dir=${Dir%/}
-
- CacheDir="var/cache/apt/"
- eval $(apt-config shell CacheDir Dir::Cache)
+ CacheDir="/var/cache/apt"
+ eval $(apt-config shell CacheDir Dir::Cache/d)
CacheDir=${CacheDir%/}
if [ -z "$CacheDir" ]; then
debug_echo "practically empty Dir::Cache, exiting"
return 0
fi
- CacheArchive="archives/"
- eval $(apt-config shell CacheArchive Dir::Cache::Archives)
- CacheArchive=${CacheArchive%/}
- if [ -z "$CacheArchive" ]; then
+ Cache="${CacheDir}/archives/"
+ eval $(apt-config shell Cache Dir::Cache::Archives/d)
+ if [ -z "$Cache" ]; then
debug_echo "practically empty Dir::Cache::archives, exiting"
return 0
fi
@@ -251,16 +239,15 @@ do_cache_backup()
BackupLevel=2 ;
fi
- CacheBackup="backup/"
- eval $(apt-config shell CacheBackup Dir::Cache::Backup)
- CacheBackup=${CacheBackup%/}
- if [ -z "$CacheBackup" ]; then
+ Back="${CacheDir}/backup/"
+ eval $(apt-config shell Back Dir::Cache::Backup/d)
+ if [ -z "$Back" ]; then
echo "practically empty Dir::Cache::Backup, exiting" 1>&2
return
fi
- Cache="${Dir}/${CacheDir}/${CacheArchive}/"
- Back="${Dir}/${CacheDir}/${CacheBackup}/"
+ CacheArchive="$(basename "${Cache}")"
+ test -n "${CacheArchive}" || CacheArchive="archives"
BackX="${Back}${CacheArchive}/"
for x in $(seq 0 1 $((${BackupLevel}-1))); do
eval "Back${x}=${Back}${x}/"
diff --git a/debian/changelog b/debian/changelog
index 8b737cc5c..ea2ef3510 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,120 @@
+apt (0.8.7ubuntu1) UNRELEASED; urgency=low
+
+ * merged from debian-unstable, remainging changes:
+ - use ubuntu keyring and ubuntu archive keyring in apt-key
+ - run update-apt-xapian-index in apt.cron
+ - support apt-key net-update and verify keys against master-keyring
+ - run apt-key net-update in cron.daily
+ - different example sources.list
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Wed, 13 Oct 2010 16:16:01 +0200
+
+apt (0.8.7) UNRELEASED; urgency=low
+
+ [ Manpages translations ]
+ * Typo fixed in French (extra "Z"). Thanks to Florentin Duneau.
+ * Another typo fixed in French ("Anfin"). Thanks to bubulle
+ * Wrong translation for "showauto" fixed. Thanks to Raphaƫl Hertzog
+ Closes: #599265
+
+ [ Michael Vogt ]
+ * debian/apt.cron.daily:
+ - source /etc/default/locale (if available) so that the
+ apt-get update cron job fetches the right translated package
+ descriptions
+ * fix test failure on amd64
+ * apt-pkg/deb/debsystem.cc:
+ - fix issues with dir::state::status and dir::state::extended_states
+ when alternative rootdirs are used
+
+ [ Martin Pitt ]
+ * apt-pkg/deb/debindexfile.cc:
+ - Use FileFd::Size() instead of stat()ing the sources/binary/translations
+ indexes directly, so that we have transparent handling of gzipped
+ indexes.
+ * apt-pkg/contrib/fileutl.cc:
+ - Fix FileFd::Size() for gzipped files to give the size of the
+ uncompressed data. This fixes cache building progress going way
+ over 100%.
+
+ -- Christian Perrier <bubulle@debian.org> Tue, 05 Oct 2010 05:35:58 +0200
+
+apt (0.8.6) unstable; urgency=low
+
+ [ Programs translations ]
+ * Vietnamese update by Clytie Siddall (Closes: #598489)
+ * Asturian update by Maacub (Closes: #599057)
+
+ [ David Kalnischkies ]
+ * cmdline/apt-cache.cc:
+ - use the TranslatedDescription for searching and not the first
+ available one as it is maybe not an expected language (Closes: #597925)
+ * apt-pkg/contrib/strutl.cc:
+ - add a space between number and unit as required by SI (Closes: #598352)
+ * apt-pkg/depcache.cc:
+ - do not check endpointer packages instead of only those which prevented
+ NeverAutoRemove settings from having an effect (Closes: #598452)
+ - do not remove packages which the user requested for installation
+ explicitly while satisfying other install requests (Closes: #598669)
+ * apt-pkg/packagemanager.cc:
+ - Add a space between period and 'Please' and unfuzzy all translations
+ * doc/po/de.po:
+ - remove the duplicated "angefertigt" in translation-holder string
+
+ -- Michael Vogt <mvo@debian.org> Mon, 04 Oct 2010 11:52:19 +0200
+
+apt (0.8.5) unstable; urgency=low
+
+ [ Manpages translations ]
+ * German (Chris Leick). Closes: #597163
+
+ [ Michael Vogt ]
+ * merged lp:~mvo/apt/conflicts-on-virtuals to better deal with
+ conflicts/breaks against virtual packages (LP: #614993)
+
+ [ David Kalnischkies ]
+ * apt-pkg/policy.cc:
+ - support 100-pinning in Release file with ButAutomaticUpgrades
+ as requested by the backports crew (Closes: #596097)
+ * apt-pkg/deb/deblistparser.cc:
+ - overrule NotAutomatic in case of ButAutomaticUpgrades
+ * debian/apt.cron.daily:
+ - handle absolut directory paths correctly by loading directories
+ directly instead of building the paths on our own (Closes: #596421)
+ * debian/control:
+ - build-depend on docbook-xml to ensure that the xml DTDs are always
+ available on the buildds (Closes: #597145)
+ * buildlib/debiandoc.mak, buildlib/po4a_manpage.mak:
+ - ensure that the build fails if documentation building fails
+ * doc/po/fr.po:
+ - correct two syntax issues to ensure we can build fine
+
+ -- Michael Vogt <mvo@debian.org> Fri, 17 Sep 2010 22:05:06 +0200
+
+apt (0.8.4) unstable; urgency=low
+
+ [ Michael vogt ]
+ * ftparchive/writer.cc:
+ - write out {Files,Checksum-Sha1,Checksum-Sha256} only if
+ available LP: #633967. Thanks to Colin Watson
+ * apt-pkg/contrib/cdromutl.cc:
+ - if apt-cdrom is used on writable media (like usb-sticks), do
+ not use the root directory to identify the medium (as all
+ changes there change the ident id). Use the .disk directory
+ instead
+
+ [ David Kalnischkies ]
+ * ftparchive/writer.cc:
+ - null the valid string instead of the date if Valid-Until is not set
+ * apt-pkg/acquire-item.cc:
+ - use also unsigned Release files again (Closes: #596189)
+
+ [ Christian Perrier ]
+ * Fix missing space after dot in a message from apt-pkg
+ Translations unfuzzied. Thanks to Holger Wansing.
+
+ -- Michael Vogt <mvo@debian.org> Fri, 10 Sep 2010 20:45:15 +0200
+
apt (0.8.3ubuntu7) maverick; urgency=low
[ David Kalnischkies ]
diff --git a/debian/control b/debian/control
index c1283f7d2..88cc2b4d8 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Uploaders: Michael Vogt <mvo@debian.org>, Otavio Salvador <otavio@debian.org>,
Christian Perrier <bubulle@debian.org>, Daniel Burrows <dburrows@debian.org>,
Luca Bruno <lethalman88@gmail.com>, Julian Andres Klode <jak@debian.org>
Standards-Version: 3.9.0
-Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev (>= 7.19.0), zlib1g-dev | libz-dev, debiandoc-sgml, xsltproc, docbook-xsl, po4a (>= 0.34-2), autotools-dev, autoconf, automake, doxygen
+Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev (>= 7.19.0), zlib1g-dev | libz-dev, debiandoc-sgml, xsltproc, docbook-xsl, docbook-xml, po4a (>= 0.34-2), autotools-dev, autoconf, automake, doxygen
Build-Conflicts: autoconf2.13, automake1.4
Vcs-Bzr: http://bzr.debian.org/apt/debian-sid/