summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily46
-rw-r--r--debian/changelog10
2 files changed, 47 insertions, 9 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 7ee7e46db..0128e0194 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -74,6 +74,51 @@ check_size_constraints()
{
# min-age in days
MaxAge=0
+ MaxSize=0
+ CacheDir="var/cache/apt"
+ CacheArchive="archives/"
+ eval $(apt-config shell MaxAge APT::Archives::MaxAge)
+ eval $(apt-config shell MaxSize APT::Archives::MaxSize)
+ eval $(apt-config shell CacheDir Dir::Cache)
+ eval $(apt-config shell CacheArchive Dir::Cache::archives)
+
+ # sanity check
+ if [ -z "$CacheDir" -o -z "$CacheArchive" ]; then
+ echo "empty Dir::Cache or Dir::Cache::archives, exiting"
+ exit
+ fi
+ Cache="/"$CacheDir$CacheArchive
+
+ # check age
+ if [ ! $MaxAge -eq 0 ]; then
+ find $Cache -name "*.deb" -mtime +$MaxAge -print0 | xargs -r -0 rm -f
+ fi
+
+ # check size
+ if [ ! $MaxSize -eq 0 ]; then
+ # reverse-sort by mtime
+ for file in $(ls -rt $Cache/*.deb); do
+ du=$(du -s $Cache)
+ size=${du%%/*}
+ # check if the cache is small enough
+ if [ $size -lt $MaxSize ]; then
+ break
+ fi
+ # delete oldest file
+ rm -f $file
+ done
+ fi
+}
+
+check_size_constraints
+
+
+
+# we check here if autoclean was enough sizewise
+check_size_constraints()
+{
+ # min-age in days
+ MaxAge=0
MinAge=1
MaxSize=0
CacheDir="var/cache/apt"
@@ -173,6 +218,7 @@ fi
AUTOCLEAN_STAMP=/var/lib/apt/periodic/autoclean-stamp
if check_stamp $AUTOCLEAN_STAMP $AutocleanInterval; then
apt-get -qq autoclean
+ check_size_contrains
update_stamp $AUTOCLEAN_STAMP
fi
diff --git a/debian/changelog b/debian/changelog
index 1820b2cbf..2b093b0dc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,16 +1,8 @@
apt (0.6.35) hoary; urgency=low
- * Merge apt--mvo--0 (incorporates 0.6.34ubuntu1):
+ * Merge apt--mvo--0:
- Implement MaxSize and MaxAge in apt.cron.daily, to prevent the cache
from growing too large (Ubuntu #6761)
- - some comments about the pkgAcqMetaSig::Custom600Headers() added
- - use gpg --with-colons
- - commented the ftp no_proxy unseting in methods/ftp.cc
- - added support for "Acquire::gpgv::options" in methods/gpgv.cc
- * Merge bubulle@debian.org--2005/apt--main--0
- - Make capitalization more consistent
- - Un-fuzzy translations resulting from capitalization changes
- - Italian translation update
-- Matt Zimmerman <mdz@ubuntu.com> Mon, 7 Mar 2005 20:08:33 -0800