summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog24
-rw-r--r--debian/compat2
-rw-r--r--debian/control4
-rw-r--r--debian/libapt-pkg-doc.doc-base.cache2
-rwxr-xr-xdebian/rules3
5 files changed, 30 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 64c743a7f..b104e9666 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,27 @@
+apt (0.6.44) unstable; urgency=low
+
+ * apt-pkg/acquire.cc: don't show ETA if it is 0 or absurdely large
+ * apt-pkg/deb/dpkgpm.cc:
+ - wording fixes (thanks to Matt Zimmerman)
+ - fix error in dpkg interaction (closes: #364513,
+ thanks to Martin Dickopp)
+ * apt-pkg/tagfile.{cc,h}:
+ - use MMap to read the entries (thanks to Zephaniah E. Hull for the
+ patch) Closes: #350025
+ * Merge from http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
+ * bg.po: Added, complete to 512t. Closes: #360262
+ * doc/apt-ftparchive.1.xml:
+ - fix documentation for "SrcPackages" -> "Sources"
+ (thanks to Bart Martens for the patch, closes: #307756)
+ * debian/libapt-pkg-doc.doc-base.cache:
+ - remove broken charackter from description (closes: #361129)
+ * apt-inst/deb/dpkgdb.cc, methods/gpgv.cc:
+ - i18n fixes (closes: #349298)
+ * debian/postinst: dont fail on not available
+ /usr/share/doc/apt/examples/sources.list (closes: #361130)
+
+ --
+
apt (0.6.43.3) unstable; urgency=low
* Merge bubulle@debian.org--2005/apt--main--0 up to patch-186:
diff --git a/debian/compat b/debian/compat
index 00750edc0..7ed6ff82d 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-3
+5
diff --git a/debian/control b/debian/control
index 3b8883f88..53ce851f6 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,8 @@ Section: admin
Priority: important
Maintainer: APT Development Team <deity@lists.debian.org>
Uploaders: Jason Gunthorpe <jgg@debian.org>, Adam Heath <doogie@debian.org>, Matt Zimmerman <mdz@debian.org>, Michael Vogt <mvo@debian.org>
-Standards-Version: 3.6.1
-Build-Depends: debhelper (>= 4.1.62), libdb4.3-dev, gettext (>= 0.12)
+Standards-Version: 3.6.2.2
+Build-Depends: debhelper (>= 5.0), libdb4.3-dev, gettext (>= 0.12)
Build-Depends-Indep: debiandoc-sgml, docbook-utils (>= 0.6.12-1)
Package: apt
diff --git a/debian/libapt-pkg-doc.doc-base.cache b/debian/libapt-pkg-doc.doc-base.cache
index b58b79bd1..59558dee8 100644
--- a/debian/libapt-pkg-doc.doc-base.cache
+++ b/debian/libapt-pkg-doc.doc-base.cache
@@ -4,7 +4,7 @@ Author: Jason Gunthorpe
Abstract: The APT Cache Specification describes the complete implementation
and format of the APT Cache file. The APT Cache file is a way for APT to
parse and store a large number of package files for display in the UI.
- It's primaryć design goal is to make display of a single package in the
+ It's primary design goal is to make display of a single package in the
tree very fast by pre-linking important things like dependencies and
provides. The specification doubles as documentation for one of the
in-memory structures used by the package library and the APT GUI.
diff --git a/debian/rules b/debian/rules
index cd026b4a4..a8bf88762 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,6 +36,7 @@ endif
# Default rule
build:
+PKG=apt
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
@@ -335,6 +336,6 @@ cvs-mkul:
arch-build:
rm -rf debian/arch-build
mkdir -p debian/arch-build/apt-$(APT_DEBVER)
- baz inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
+ tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
$(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
(cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))