summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt-doc.docs1
-rw-r--r--debian/apt.conf.autoremove2
-rw-r--r--debian/apt.dirs1
-rw-r--r--debian/apt.install.in2
-rw-r--r--debian/apt.maintscript3
-rw-r--r--debian/changelog52
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules4
8 files changed, 64 insertions, 3 deletions
diff --git a/debian/apt-doc.docs b/debian/apt-doc.docs
index 4ec23f55d..df9701123 100644
--- a/debian/apt-doc.docs
+++ b/debian/apt-doc.docs
@@ -1,3 +1,2 @@
README.progress-reporting
-README.MultiArch
doc/external-dependency-solver-protocol.txt
diff --git a/debian/apt.conf.autoremove b/debian/apt.conf.autoremove
index cf69d56c3..fc02350ae 100644
--- a/debian/apt.conf.autoremove
+++ b/debian/apt.conf.autoremove
@@ -22,6 +22,8 @@ APT
".*-modules";
".*-kernel";
"linux-backports-modules-.*";
+ # tools
+ "linux-tools";
};
Never-MarkAuto-Sections
diff --git a/debian/apt.dirs b/debian/apt.dirs
index 6d492a30f..e4bb2c824 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -15,3 +15,4 @@ var/lib/apt/mirrors/partial
var/lib/apt/periodic
var/log/apt
usr/share/bug/apt
+usr/share/bash-completion/completions/ \ No newline at end of file
diff --git a/debian/apt.install.in b/debian/apt.install.in
index 4ffe43e3b..9c9489572 100644
--- a/debian/apt.install.in
+++ b/debian/apt.install.in
@@ -3,4 +3,4 @@ bin/apt-* usr/bin/
bin/methods/* usr/lib/apt/methods/
scripts/dselect/* usr/lib/dpkg/methods/apt/
usr/share/locale/*/*/apt.mo
-bin/libapt-private.so.* usr/lib/@DEB_HOST_MULTIARCH@/ \ No newline at end of file
+bin/libapt-private.so.* usr/lib/@DEB_HOST_MULTIARCH@/
diff --git a/debian/apt.maintscript b/debian/apt.maintscript
new file mode 100644
index 000000000..939769355
--- /dev/null
+++ b/debian/apt.maintscript
@@ -0,0 +1,3 @@
+rm_conffile /etc/apt/apt.conf.d/20changelog 1.0.3 -- "@"
+
+
diff --git a/debian/changelog b/debian/changelog
index d3beac0ef..1a27dd07e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,55 @@
+apt (1.0.2) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * fix apt list output for pkgs in dpkg ^rc state
+ * Notice the user about "apt list -a" when only a single hit if found
+ * fix test-failure in adt
+ * apt-private/acqprogress.cc: fix output when ctrl-c is hit during
+ apt update (LP: #1310548, closes: #744297)
+ * Fix option name DPkg::Progress-Fancy in apt.8 manpage
+ (LP: #1310506)
+
+ [ David Kalnischkies ]
+ * don't double-count seeks in FileFd::Skip for bzip/xz
+ * deal with umask only if we really need to for mkstemp
+ * consider priorities only for downloadable pkgs in resolver
+ * force fancy progressbar redraw on window size change
+ * clear HitEof flag in FileFd::Seek
+ * use Google C++ Testing Framework for libapt tests
+ * support dist-upgrade options in full-upgrade
+
+ [ Trần Ngọc Quân ]
+ * l10n: vi.po (624t): Update translation
+
+ [ Theppitak Karoonboonyanan ]
+ * Updated Thai program translation (closes: #745120)
+
+ [ James McCoy ]
+ * Consistently use Dpkg::Progress* in documentation (Closes: 745452)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 25 Apr 2014 13:15:03 +0200
+
+apt (1.0.1) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * Fix crash in "apt list" when a sources.list file is unreable
+ (Closes: 743413)
+ * make apt search case-insensitive by default
+ * Fix possible race when stunnel/aptwebserver create their PID files
+ in the tests
+ * Fix insecure file permissions when using FileFd with OpenMode::Atomic
+ (LP: #1304657)
+
+ [ Julian Andres Klode ]
+ * Version the Breaks/Replaces for sun-java{5,6}-jdk (LP: #1302736)
+ (Closes: #743616)
+ * Add versioned openjdk-6-jdk breaks
+
+ [ Josef Vitu ]
+ * apt: Minor typo in 'apt' man page (closes: #743657)
+
+ -- Michael Vogt <mvo@debian.org> Thu, 10 Apr 2014 09:48:56 +0200
+
apt (1.0) unstable; urgency=low
The "Happy birthday and 10000b years in the making" release
diff --git a/debian/control b/debian/control
index c0526d30c..ff984db75 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Build-Depends: dpkg-dev (>= 1.15.8), debhelper (>= 8.1.3~), libdb-dev,
gettext (>= 0.12), libcurl4-gnutls-dev (>= 7.19.4~),
zlib1g-dev, libbz2-dev, liblzma-dev,
xsltproc, docbook-xsl, docbook-xml, po4a (>= 0.34-2),
- autotools-dev, autoconf, automake
+ autotools-dev, autoconf, automake, libgtest-dev
Build-Depends-Indep: doxygen, debiandoc-sgml, graphviz
Build-Conflicts: autoconf2.13, automake1.4
Vcs-Git: git://anonscm.debian.org/apt/apt.git
diff --git a/debian/rules b/debian/rules
index eec016607..fc0e9e8f6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -189,6 +189,10 @@ apt: build-binary build-manpages debian/apt.install
cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
+ # install bash completion
+ cp share/bash-completions/* debian/$@/usr/share/bash-completion/completions/
+ # install vendor specific apt confs
+ find -L vendor/current -name 'apt.conf-*' | while read conf; do cp "$${conf}" "debian/$@/etc/apt/apt.conf.d/$${conf#*-}"; done
# make rosetta happy and remove pot files in po/ (but leave stuff
# in po/domains/* untouched) and cp *.po into each domain dir