summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.dirs2
-rw-r--r--debian/apt.logrotate8
-rw-r--r--debian/changelog38
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules1
5 files changed, 48 insertions, 3 deletions
diff --git a/debian/apt.dirs b/debian/apt.dirs
index 1543e8bb1..8ce9b175a 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -4,7 +4,9 @@ usr/lib/dpkg/methods/apt
etc/apt
etc/apt/apt.conf.d
etc/apt/sources.list.d
+etc/logrotate.d
var/cache/apt/archives/partial
var/lib/apt/lists/partial
var/lib/apt/periodic
+var/log/apt
usr/share/bug/apt
diff --git a/debian/apt.logrotate b/debian/apt.logrotate
new file mode 100644
index 000000000..3e924d383
--- /dev/null
+++ b/debian/apt.logrotate
@@ -0,0 +1,8 @@
+/var/log/apt/term.log {
+ rotate 6
+ monthly
+ compress
+ missingok
+ notifempty
+}
+
diff --git a/debian/changelog b/debian/changelog
index 8961a0257..c730f85b0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,14 +1,48 @@
-apt (0.7.5) UNRELEASED; urgency=low
+apt (0.7.7) UNRELEASED; urgency=low
+
+ * apt-inst/contrib/extracttar.cc:
+ - fix fd leak for zero size files (thanks to Bill Broadley for
+ reporting this bug)
+ * apt-pkg/acquire-item.cc:
+ - remove zero size files on I-M-S hit
+ * methods/https.cc:
+ - only send LastModified if we actually have one
+ - send range request with if-range
+ - delete failed downloads
+ * apt-pkg/deb/dpkgpm.{cc,h}:
+ - merged dpkg-log branch, this lets you specify a
+ Dir::Log::Terminal file to log dpkg output to
+ (ABI break)
+ * merged apt--sha256 branch to fully support the new
+ sha256 checksums in the Packages and Release files
+ (ABI break)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 02 Aug 2007 11:55:54 +0200
+
+apt (0.7.6) unstable; urgency=low
+
+ * Applied patch from Aurelien Jarno <aurel32@debian.org> to fix wrong
+ directory downloading on non-linux architectures (closes: #435597)
+
+ -- Otavio Salvador <otavio@debian.org> Wed, 01 Aug 2007 19:49:51 -0300
+
+apt (0.7.5) unstable; urgency=low
[ Otavio Salvador ]
- * Applied patch from Guillem Jover <guillem.jover@nokia.com> to use
+ * Applied patch from Guillem Jover <guillem@debian.org> to use
dpkg-architecture to get the host architecture (closes: #407187)
+ * Applied patch from Guillem Jover <guillem@debian.org> to add
+ support to add lzma support (closes: #408201)
[ Michael Vogt ]
* apt-pkg/depcache.cc:
- support a list of sections for:
APT::Install-Recommends-Sections
APT::Never-MarkAuto-Sections
+ * methods/makefile:
+ - install lzma symlink method (for full lzma support)
+ * debian/control:
+ - suggest "lzma"
-- Otavio Salvador <otavio@ossystems.com.br> Wed, 25 Jul 2007 20:16:46 -0300
diff --git a/debian/control b/debian/control
index 76e5b1a19..742e8ca5c 100644
--- a/debian/control
+++ b/debian/control
@@ -14,7 +14,7 @@ Depends: ${shlibs:Depends}, debian-archive-keyring
Priority: important
Replaces: libapt-pkg-doc (<< 0.3.7), libapt-pkg-dev (<< 0.3.7)
Provides: ${libapt-pkg:provides}
-Suggests: aptitude | synaptic | gnome-apt | wajig, dpkg-dev, apt-doc, bzip2
+Suggests: aptitude | synaptic | gnome-apt | wajig, dpkg-dev, apt-doc, bzip2, lzma
Section: admin
Description: Advanced front-end for dpkg
This is Debian's next generation front-end for the dpkg package manager.
diff --git a/debian/rules b/debian/rules
index 473821f16..b3222f3b4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -209,6 +209,7 @@ apt: build debian/shlibs.local
cp -r $(BLD)/locale debian/$@/usr/share/
cp debian/bugscript debian/$@/usr/share/bug/apt/script
+ cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
cp share/debian-archive.gpg debian/$@/usr/share/$@
cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove