summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt-utils.examples1
-rw-r--r--debian/apt.cron.daily14
-rw-r--r--debian/apt.manpages1
-rw-r--r--debian/changelog44
-rwxr-xr-xdebian/rules1
5 files changed, 54 insertions, 7 deletions
diff --git a/debian/apt-utils.examples b/debian/apt-utils.examples
new file mode 100644
index 000000000..25aadf996
--- /dev/null
+++ b/debian/apt-utils.examples
@@ -0,0 +1 @@
+doc/examples/apt-ftparchive.conf \ No newline at end of file
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 2d93a5ba4..26dfa2530 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -95,9 +95,9 @@ check_size_constraints()
# check age
if [ ! $MaxAge -eq 0 ] && [ ! $MinAge -eq 0 ]; then
- find $Cache -name "*.deb" -mtime +$MaxAge -and -not -mtime -$MinAge -print0 | xargs -r -0 rm -f
+ find $Cache -name "*.deb" \( -mtime +$MaxAge -and -ctime +$MaxAge \) -and -not \( -mtime -$MinAge -or -ctime -$MinAge \) -print0 | xargs -r -0 rm -f
elif [ ! $MaxAge -eq 0 ]; then
- find $Cache -name "*.deb" -mtime +$MaxAge -print0 | xargs -r -0 rm -f
+ find $Cache -name "*.deb" -ctime +$MaxAge -and -mtime +$MaxAge -print0 | xargs -r -0 rm -f
fi
# check size
@@ -120,8 +120,14 @@ check_size_constraints()
# check for MinAge of the file
if [ ! $MinAge -eq 0 ]; then
- mtime=$(date --date=$(date -r $file --iso-8601) +%s)
- delta=$(($now-$mtime))
+ # check both ctime and mtime
+ mtime=$(stat -c %Y $file)
+ ctime=$(stat -c %Z $file)
+ if [ $mtime -gt $ctime ]; then
+ delta=$(($now-$mtime))
+ else
+ delta=$(($now-$ctime))
+ fi
#echo "$file ($delta), $MinAge"
if [ $delta -le $MinAge ]; then
#echo "Skiping $file (delta=$delta)"
diff --git a/debian/apt.manpages b/debian/apt.manpages
index e621e1c49..b52ea3d3d 100644
--- a/debian/apt.manpages
+++ b/debian/apt.manpages
@@ -3,6 +3,7 @@ doc/apt-cdrom.8
doc/apt-config.8
doc/apt-get.8
doc/apt-key.8
+doc/apt-secure.8
doc/apt.8
doc/apt.conf.5
doc/apt_preferences.5
diff --git a/debian/changelog b/debian/changelog
index a0092d366..acf74d166 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,48 @@
-apt (0.6.40.2) unstable; urgency=low
+apt (0.6.41.1) unstable; urgency=low
+
+ * apt-pkg/cdrom.cc:
+ - unmount the cdrom when apt failed to locate any package files
+ * allow cdrom failures and fallback to other sources in that case
+ (closes: #44135)
+ * better error text when dpkg-source fails
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-104:
+ - patch-99: Added Galician translation
+ - patch-100: Completed Danish translation (Closes: #325686)
+ - patch-104: French translation completed
+ * applied frensh man-page update (thanks to Philippe Batailler)
+
+ --
+
+apt (0.6.41) unstable; urgency=low
* improved the support for "error" and "conffile" reporting from
dpkg, added the format to README.progress-reporting
* added README.progress-reporting to the apt-doc package
-
- --
+ * improved the network timeout handling, if a index file from a
+ sources.list times out or EAI_AGAIN is returned from getaddrinfo,
+ don't try to get the other files from that entry
+ * Support architecture-specific extra overrides
+ (closes: #225947). Thanks to Anthony Towns for idea and
+ the patch, thanks to Colin Watson for testing it.
+ * Javier Fernandez-Sanguino Pen~a:
+ - Added a first version of an apt-secure.8 manpage, and modified
+ apt-key and apt.end accordingly. Also added the 'update'
+ argument to apt-key which was previously not documented
+ (Closes: #322120)
+ * Andreas Pakulat:
+ - added example apt-ftparchive.conf file to doc/examples
+ (closes: #322483)
+ * Fix a incorrect example in the man-page (closes: #282918)
+ * Fix a bug for very long lines in the apt-cdrom code (closes: #280356)
+ * Fix a manual page bug (closes: #316314)
+ * Do md5sum checking for file and cdrom method (closes: #319142)
+ * Change pkgPolicy::Pin from private to protected to let subclasses
+ access it too (closes: #321799)
+ * add default constructor for PrvIterator (closes: #322267)
+ * Reread status configuration on debSystem::Initialize()
+ (needed for apt-proxy, thanks to Otavio for this patch)
+
+ -- Michael Vogt <mvo@debian.org> Mon, 5 Sep 2005 22:59:03 +0200
apt (0.6.40.1) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index b3f72bb7f..cd026b4a4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -269,6 +269,7 @@ apt-utils: build debian/shlibs.local
cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
dh_installdocs -p$@
+ dh_installexamples -p$@
# Install the man pages..
dh_installman -p$@