summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.conf.changelog6
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules1
3 files changed, 13 insertions, 0 deletions
diff --git a/debian/apt.conf.changelog b/debian/apt.conf.changelog
new file mode 100644
index 000000000..3466bb6e0
--- /dev/null
+++ b/debian/apt.conf.changelog
@@ -0,0 +1,6 @@
+// Server information for apt-changelog
+APT {
+ Changelog {
+ Server "http://changelogs.ubuntu.com/changelogs";
+ }
+}
diff --git a/debian/changelog b/debian/changelog
index b7f290713..2f95d2e00 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,12 @@ apt (0.8.8ubuntu3) UNRELEASED; urgency=low
* cmdline/apt-changelog: Filter out multiple results for a source package,
just take the latest one.
+ * cmdline/apt-changelog: Read server name from configuration
+ APT::Changelog::Server instead of hardcoding it. This allows local users
+ to point to a local changelog mirror, or make this script work for Debian.
+ * Add debian/apt.conf.changelog: Configuration for apt-changelog with the
+ server for Ubuntu (changelogs.ubuntu.com). Install it in debian/rules.
+ * doc/apt-changelog.1.xml: Document the new option.
-- Martin Pitt <martin.pitt@ubuntu.com> Fri, 12 Nov 2010 16:53:31 +0100
diff --git a/debian/rules b/debian/rules
index 9f3dca627..ea0fec443 100755
--- a/debian/rules
+++ b/debian/rules
@@ -216,6 +216,7 @@ apt: build build-doc debian/shlibs.local
cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
+ cp debian/apt.conf.changelog debian/$@/etc/apt/apt.conf.d/20changelog
# copy lintian override
cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt