summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.install.in (renamed from debian/apt.install)1
-rw-r--r--debian/apt.lintian-overrides2
-rw-r--r--debian/apt.postinst14
-rw-r--r--debian/changelog89
-rwxr-xr-xdebian/rules4
5 files changed, 101 insertions, 9 deletions
diff --git a/debian/apt.install b/debian/apt.install.in
index 9d4008fab..ac12060ce 100644
--- a/debian/apt.install
+++ b/debian/apt.install.in
@@ -2,3 +2,4 @@ bin/apt-* usr/bin/
bin/methods/* usr/lib/apt/methods/
scripts/dselect/* usr/lib/dpkg/methods/apt/
usr/share/locale/*/*/apt.mo
+bin/libapt-private.so.* usr/lib/@DEB_HOST_MULTIARCH@/ \ No newline at end of file
diff --git a/debian/apt.lintian-overrides b/debian/apt.lintian-overrides
new file mode 100644
index 000000000..2867c74d9
--- /dev/null
+++ b/debian/apt.lintian-overrides
@@ -0,0 +1,2 @@
+apt: no-shlibs-control-file
+apt: package-name-doesnt-match-sonames
diff --git a/debian/apt.postinst b/debian/apt.postinst
index 9ff1e031c..70de237d0 100644
--- a/debian/apt.postinst
+++ b/debian/apt.postinst
@@ -15,12 +15,16 @@ set -e
case "$1" in
configure)
- SECRING='/etc/apt/secring.gpg'
- # test if secring is an empty normal file
- if test -f $SECRING -a ! -s $SECRING; then
- rm -f $SECRING
+ if dpkg --compare-versions "$2" lt-nl 0.9.9.5; then
+ # we are using tmpfiles for both
+ rm -f /etc/apt/trustdb.gpg
+ # this removal was done unconditional since 0.8.15.3
+ SECRING='/etc/apt/secring.gpg'
+ # test if secring is an empty normal file
+ if test -f $SECRING -a ! -s $SECRING; then
+ rm -f $SECRING
+ fi
fi
- apt-key update
# ensure tighter permissons on the logs, see LP: #975199
if dpkg --compare-versions "$2" lt-nl 0.9.7.7; then
diff --git a/debian/changelog b/debian/changelog
index e2bb9c471..5d3758850 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,93 @@
-apt (0.9.9.5) UNRELEASED; urgency=low
+apt (0.9.11~exp3) UNRELEASEDexperimental; urgency=low
+ * fix incorrect bugnumber for the Pre-Install-Pkgs hook
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Mon, 19 Aug 2013 15:53:47 +0200
+
+apt (0.9.11~exp2) experimental; urgency=low
+
+ * add lintian override for no-shlibs-control-file so that
+ the internal libapt-private.so.0.0.0 can be shipped
+ * adjust apt.install.in to only install libapt-private.so.*
+
+ -- Michael Vogt <mvo@debian.org> Mon, 19 Aug 2013 14:54:58 +0200
+
+apt (0.9.11~exp1) experimental; urgency=low
+
+ [ Daniel Hartwig ]
+ * Clarify units of Acquire::http::Dl-Limit (closes: #705445)
+ * Show a error message if {,dist-}upgrade is used with additional
+ arguments (closes: #705510)
+
+ [ Michael Vogt ]
+ * lp:~mvo/apt/config-clear:
+ - support Configuration.Clear() for a clear of the entire
+ configuration
+ * lp:~mvo/apt/add-glob-function:
+ - add Glob() to fileutl.{cc,h}
+ * feature/apt-binary2
+ - refactor large chunks of cmdline/*.cc into a new libapt-private
+ library that is shared between the internal apt cmdline tools
+ - install libapt-private* into the apt binary
+ - add PACKAGE_MATCHER_ABI_COMPAT define so that this branch can be
+ merged without breaking ABI
+
+ [ David Kalnischkies ]
+ * ensure that pkgTagFile isn't writing past Buffer length (Closes: 719629)
+ * allow Pre-Install-Pkgs hooks to get info over an FD != stdin
+ (Closes: #671726)
+
+ [ Christian PERRIER ]
+ * French translation update.
+
+ -- Michael Vogt <mvo@debian.org> Mon, 19 Aug 2013 13:25:45 +0200
+
+apt (0.9.10) unstable; urgency=low
+
+ The "Hello to Debconf" upload
+
+ [ Christian Perrier ]
* Vietnamese translation update. Closes: #718615
+ * Japanese translation update. Closes: #719279
+ * French translation update.
+
+ [ Michael Vogt ]
+ * work on fixing coverity scan results:
+ - fix some off-by-one errors
+ - fix some resource leaks
+ - fixes in chroot() handling
+ - fix some missing va_end()
+ * make the code -Wall clean again
+ * remove duplicated #include<list>
+ * add .travis.yml
+ * use the 'abi-complicance-checker' package and remove the buildin
+ copy for the abi checks
+
+ [ David Kalnischkies ]
+ * ensure that FileFd::Size returns 0 in error cases
+ * add missing Turkish (tr) to po/LINGUAS
+ * correct management-typo in description found by lintian
+ * implement debian/rules build-{arch,indep} as required by policy 3.9.4
+ * reenable automatic parallel build of APT
+ * exclude config.{sub,guess} from source package
+ * update the symbol files to reflect current state
+ * unset LANGUAGE for showing [Y/n] answer hints
+ * fix some unitialized data members
+ * specific pins below 1000 cause downgrades (Closes: 543966)
+ * use pkgTagFile to parse "header" of Release files
+ * fix: --print-uris removes authentication (Closes: 719263)
+ * always use our own trustdb.gpg in apt-key
+ * use a tmpfile for trustdb.gpg in apt-key.
+ Thanks to Andreas Beckmann for the initial patch! (Closes: #687611)
+ * do not double-slash paths in apt-key (Closes: 665411)
+ * make the keyring locations in apt-key configurable
+ * let apt-key del work better with softlink and single key keyrings
+ * do not call 'apt-key update' in apt.postinst
+
+ [ Colin Watson ]
+ * prefer native arch over higher priority for providers (Closes: #718482)
- -- Christian Perrier <bubulle@debian.org> Sat, 03 Aug 2013 16:06:55 +0200
+ -- Michael Vogt <mvo@debian.org> Mon, 12 Aug 2013 21:45:07 +0200
apt (0.9.9.4) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index fc44d5a68..06ccdac31 100755
--- a/debian/rules
+++ b/debian/rules
@@ -115,7 +115,7 @@ clean:
[ ! -f Makefile ] || $(MAKE) clean distclean
rm -rf build
rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
- debian/libapt-pkg-dev.install
+ debian/libapt-pkg-dev.install debian/apt.install
test ! -L buildlib/config.guess || rm -f buildlib/config.guess
test ! -L buildlib/config.sub || rm -f buildlib/config.sub
@@ -174,7 +174,7 @@ apt-doc: build-debiandoc
# Build architecture-dependent files here.
apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
-apt: build-binary build-manpages
+apt: build-binary build-manpages debian/apt.install
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@