summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.dirs1
-rw-r--r--debian/changelog12
-rwxr-xr-xdebian/rules4
3 files changed, 17 insertions, 0 deletions
diff --git a/debian/apt.dirs b/debian/apt.dirs
index 1543e8bb1..025898e84 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -6,5 +6,6 @@ etc/apt/apt.conf.d
etc/apt/sources.list.d
var/cache/apt/archives/partial
var/lib/apt/lists/partial
+var/lib/apt/mirrors/partial
var/lib/apt/periodic
usr/share/bug/apt
diff --git a/debian/changelog b/debian/changelog
index 838567183..6fdf646f0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+apt (0.6.46.4ubuntu7) feisty; urgency=low
+
+ * Merged the apt--mirror branch. This means that a new 'mirror'
+ method is available that will allow dynamic mirror updates.
+ The sources.list entry looks something like this:
+ "deb mirror://mirrors.lp.net/get_mirror feisty main restricted"
+
+ It also supports error reporting to a configurable url for mirror
+ problems/failures.
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 6 Feb 2007 11:38:06 +0100
+
apt (0.6.46.4ubuntu6) feisty; urgency=low
* methods/http.cc:
diff --git a/debian/rules b/debian/rules
index b22b09fd1..3defd3c29 100755
--- a/debian/rules
+++ b/debian/rules
@@ -219,6 +219,10 @@ apt: build debian/shlibs.local
rm -f build/po/*.pot
rm -f po/*.pot
+ # move the mirror failure script in place
+ mv debian/$@/usr/bin/apt-report-mirror-failure \
+ debian/$@/usr/lib/apt/apt-report-mirror-failure \
+
dh_installexamples -p$@ $(BLD)/docs/examples/*
dh_installman -p$@
dh_installcron -p$@