summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/NEWS2
-rw-r--r--debian/apt.conf.autoremove1
-rw-r--r--debian/apt.dirs1
-rw-r--r--debian/apt.postinst6
-rw-r--r--debian/changelog241
-rw-r--r--debian/control10
-rwxr-xr-xdebian/rules15
7 files changed, 221 insertions, 55 deletions
diff --git a/debian/NEWS b/debian/NEWS
index 7612adb9c..a12f1a4f8 100644
--- a/debian/NEWS
+++ b/debian/NEWS
@@ -2,7 +2,7 @@ apt (0.7.24) unstable; urgency=low
* Already included in the last version but now with better documentation
is the possibility to add/prefer different compression types while
- downloading archive informations, which can decrease the time needed for
+ downloading archive information, which can decrease the time needed for
update on slow machines. See apt.conf (5) manpage for details.
* APT manages his manpage translations now with po4a, thanks to Nicolas
François and Kurasawa Nozomu, who also provide the ja translation.
diff --git a/debian/apt.conf.autoremove b/debian/apt.conf.autoremove
index 98143ce9a..b41be8397 100644
--- a/debian/apt.conf.autoremove
+++ b/debian/apt.conf.autoremove
@@ -4,5 +4,6 @@ APT
{
"^linux-image.*";
"^linux-restricted-modules.*";
+ "^kfreebsd-image.*";
};
};
diff --git a/debian/apt.dirs b/debian/apt.dirs
index fb6716c35..66556e453 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -5,6 +5,7 @@ etc/apt
etc/apt/apt.conf.d
etc/apt/preferences.d
etc/apt/sources.list.d
+etc/apt/trusted.gpg.d
etc/logrotate.d
var/cache/apt/archives/partial
var/lib/apt/lists/partial
diff --git a/debian/apt.postinst b/debian/apt.postinst
index 88fb932df..cc0d8b1fe 100644
--- a/debian/apt.postinst
+++ b/debian/apt.postinst
@@ -15,13 +15,7 @@ set -e
case "$1" in
configure)
-
- if ! test -f /etc/apt/trusted.gpg; then
- cp /usr/share/apt/debian-archive.gpg /etc/apt/trusted.gpg
- fi
-
apt-key update
-
;;
abort-upgrade|abort-remove|abort-deconfigure)
diff --git a/debian/changelog b/debian/changelog
index 26b3e8c1e..a81a2abd0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,153 @@
-apt (0.7.25) UNRELEASED; urgency=low
+apt (0.7.26) UNRELEASED; urgency=low
+
+ [ David Kalnischkies ]
+ * [BREAK] add possibility to download and use multiply
+ Translation files, configurable with Acquire::Translation
+ (Closes: #444222, #448216, #550564)
+ * [BREAK] merge MultiArch-ABI. We don't support MultiArch,
+ but we support the usage of the new ABI so libapt users
+ can start to prepare for MultiArch (Closes: #536029)
+ * Ignore :qualifiers after package name in build dependencies
+ for now as long we don't understand them (Closes: #558103)
+ * apt-pkg/contrib/mmap.{cc,h}:
+ - extend it to have a growable flag - unused now but maybe...
+ * apt-pkg/pkgcache.h:
+ - use long instead of short for {Ver,Desc}File size,
+ patch from Víctor Manuel Jáquez Leal, thanks! (Closes: #538917)
+ * apt-pkg/acquire-item.cc:
+ - allow also to skip the last patch if target is reached,
+ thanks Bernhard R. Link! (Closes: #545699)
+ * ftparchive/writer.{cc,h}:
+ - add APT::FTPArchive::AlwaysStat to disable the too aggressive
+ caching if versions are build multiply times (not recommend)
+ Patch by Christoph Goehre, thanks! (Closes: #463260)
+
+ [ Ivan Masár ]
+ * Slovak translation update. Closes: #568294
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Sat, 13 Feb 2010 01:42:50 +0100
+
+apt (0.7.25.3) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * Italian translation update. Closes: #567532
+
+ [ David Kalnischkies ]
+ * apt-pkg/contrib/macros.h:
+ - install the header system.h with a new name to be able to use
+ it in other headers (Closes: #567662)
+ * cmdline/acqprogress.cc:
+ - Set Mode to Medium so that the correct prefix is used.
+ Thanks Stefan Haller for the patch! (Closes: #567304 LP: #275243)
+ * ftparchive/writer.cc:
+ - generate sha1 and sha256 checksums for dsc (Closes: #567343)
+ * cmdline/apt-get.cc:
+ - don't mark as manually if in download only (Closes: #468180)
+
+ -- Michael Vogt <mvo@debian.org> Mon, 01 Feb 2010 18:41:15 +0100
+
+apt (0.7.25.2) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * apt-pkg/contrib/cdromutl.cc:
+ - fix UnmountCdrom() fails, give it a bit more time and try
+ the umount again
+ * apt-pkg/cdrom.cc:
+ - fix crash in pkgUdevCdromDevices
+ * methods/cdrom.cc:
+ - fixes in multi cdrom setup code (closes: #549312)
+ - add new "Acquire::cdrom::AutoDetect" config that enables/disables
+ the dlopen of libudev for automatic cdrom detection. Off by default
+ currently, feedback/testing welcome
+ * cmdline/apt-cdrom.cc:
+ - add new --auto-detect option that uses libudev to figure out
+ the cdrom/mount-point
+ * cmdline/apt-mark:
+ - merge fix from Gene Cash that supports markauto for
+ packages that are not in the extended_states file yet
+ (closes: #534920)
+ * ftparchive/writer.{cc,h}:
+ - merge crash fix for apt-ftparchive on hurd, thanks to
+ Samuel Thibault for the patch (closes: #566664)
+
+ [ David Kalnischkies ]
+ * apt-pkg/contrib/fileutl.cc:
+ - Fix the newly introduced method GetListOfFilesInDir to not
+ accept every file if no extension is enforced
+ (= restore old behaviour). (Closes: #565213)
+ * apt-pkg/policy.cc:
+ - accept also partfiles with "pref" file extension as valid
+ * apt-pkg/contrib/configuration.cc:
+ - accept also partfiles with "conf" file extension as valid
+ * doc/apt.conf.5.xml:
+ - reorder description and split out syntax
+ - add partfile name convention (Closes: #558348)
+ * doc/apt_preferences.conf.5.xml:
+ - describe partfile name convention also here
+ * apt-pkg/deb/dpkgpm.cc:
+ - don't segfault if term.log file can't be opened.
+ Thanks Sam Brightman for the patch! (Closes: #475770)
+ * doc/*:
+ - replace the per language addendum with a global addendum
+ - add a explanation why translations include (maybe) english
+ parts to the new global addendum (Closes: #561636)
+ * apt-pkg/contrib/strutl.cc:
+ - fix malloc asseration fail with ja_JP.eucJP locale in
+ apt-cache search. Thanks Kusanagi Kouichi! (Closes: #548884)
+
+ [ Christian Perrier ]
+ * French translation update
+
+ -- Michael Vogt <mvo@debian.org> Wed, 27 Jan 2010 16:16:10 +0100
+
+apt (0.7.25.1) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * French manpage translation update
+ * Russian translation update by Yuri Kozlov
+ Closes: #564171
+
+ [Chris Leick]
+ * spot & fix various typos in all manpages
+ * German manpage translation update
+
+ [ David Kalnischkies ]
+ * cmdline/apt-cache.cc:
+ - remove translatable marker from the "%4i %s\n" string
+ * buildlib/po4a_manpage.mak:
+ - instruct debiandoc to build files with utf-8 encoding
+ * buildlib/tools.m4:
+ - fix some warning from the buildtools
+ * apt-pkg/acquire-item.cc:
+ - add configuration PDiffs::Limit-options to not download
+ too many or too big patches (Closes: #554349)
+ * debian/control:
+ - let all packages depend on ${misc:Depends}
+ * share/*-archive.gpg:
+ - remove the horrible outdated files. We already depend on
+ the keyring so we don't need to ship our own version
+ * cmdline/apt-key:
+ - errors out if wget is not installed (Closes: #545754)
+ - add --keyring option as we have now possibly many
+ * methods/gpgv.cc:
+ - pass all keyrings (TrustedParts) to gpgv instead of
+ using only one trusted.gpg keyring (Closes: #304846)
+ * methods/https.cc:
+ - finally merge the rest of the patchset from Arnaud Ebalard
+ with the CRL and Issuers options, thanks! (Closes: #485963)
+ * apt-pkg/deb/debindexfile.cc, apt-pkg/pkgcachegen.cc:
+ - add debug option Debug::pkgCacheGen
+
+ [ Michael Vogt ]
+ * cmdline/apt-get.cc:
+ - merge fix for apt-get source pkg=version regression
+ (closes: #561971)
+ * po/ru.po:
+ - merged updated ru.po, thanks to Yuri Kozlov (closes: #564171)
+
+ -- Michael Vogt <mvo@debian.org> Sat, 09 Jan 2010 21:52:36 +0100
+
+apt (0.7.25) unstable; urgency=low
[ Christian Perrier ]
* Fix apt-ftparchive(1) wrt description of the "-o" option.
@@ -13,17 +162,42 @@ apt (0.7.25) UNRELEASED; urgency=low
Closes: #548571
* German translation update by Holger Wansing
Closes: #551534
- * German translation of manpages by Chris Leick
- Closes: #552606
* Italian translation update by Milo Casagrande
Closes: #555797
+ * Simplified Chinese translation update by Aron Xu
+ Closes: #558737
+ * Slovak translation update by Ivan Masár
+ Closes: #559277
+
+ [ Michael Vogt ]
+ * apt-pkg/packagemanager.cc:
+ - add output about pre-depends configuring when debug::pkgPackageManager
+ is used
+ * methods/https.cc:
+ - fix incorrect use of CURLOPT_TIMEOUT, closes: #497983, LP: #354972
+ thanks to Brian Thomason for the patch
+ * merge lp:~mvo/apt/netrc branch, this adds support for a
+ /etc/apt/auth.conf that can be used to store username/passwords
+ in a "netrc" style file (with the extension that it supports "/"
+ in a machine definition). Based on the maemo git branch (Closes: #518473)
+ (thanks also to Jussi Hakala and Julian Andres Klode)
+ * apt-pkg/deb/dpkgpm.cc:
+ - add "purge" to list of known actions
+ * apt-pkg/init.h:
+ - add compatibility with old ABI name until the next ABI break
+ * merge segfault fix from Mario Sanchez Prada, many thanks
+ (closes: #561109)
+
+ [ Brian Murray ]
+ * apt-pkg/depcache.cc, apt-pkg/indexcopy.cc:
+ - typo fix (LP: #462328)
+
+ [ Loïc Minier ]
+ * cmdline/apt-key:
+ - Emit a warning if removed keys keyring is missing and skip associated
+ checks (LP: #218971)
[ David Kalnischkies ]
- * [BREAK] add possibility to download and use multiply
- Translation files, configurable with Acquire::Translation
- (Closes: #444222, #448216, #550564)
- * Ignore :qualifiers after package name in build dependencies
- for now as long we don't understand them (Closes: #558103)
* apt-pkg/packagemanager.cc:
- better debug output for ImmediateAdd with depth and why
- improve the message shown for failing immediate configuration
@@ -37,7 +211,7 @@ apt (0.7.25) UNRELEASED; urgency=low
* doc/apt-mark.8.xml:
- correct showauto synopsis, thanks Andrew Schulman (Closes: #551440)
* cmdline/apt-get.cc:
- - source should displays his final pkg pick (Closes: #249383, #550952)
+ - source should display his final pkg pick (Closes: #249383, #550952)
- source doesn't need the complete version for match (Closes: #245250)
- source ignores versions/releases if not available (Closes: #377424)
- only warn if (free) space overflows (Closes: #522238)
@@ -59,46 +233,42 @@ apt (0.7.25) UNRELEASED; urgency=low
- bump policy to 3.8.3 as we have no outdated manpages anymore
* debian/NEWS:
- fix a typo in 0.7.24: Allready -> Already (Closes: #557674)
+ * ftparchive/writer.{cc,h}:
+ - add APT::FTPArchive::LongDescription to be able to disable them
+ * apt-pkg/deb/debsrcrecords.cc:
+ - use "diff" filetype for .debian.tar.* files (Closes: #554898)
* methods/rred.cc:
- rewrite to be able to handle even big patch files
- adopt optional mmap+iovec patch from Morten Hustveit
(Closes: #463354) which should speed up a bit. Thanks!
- * apt-pkg/contrib/mmap.{cc,h}:
- - extend it to have a growable flag - unused now but maybe...
- * apt-pkg/pkgcache.h:
- - use long instead of short for {Ver,Desc}File size,
- patch from Víctor Manuel Jáquez Leal, thanks! (Closes: #538917)
- * apt-pkg/acquire-item.cc:
- - allow also to skip the last patch if target is reached,
- thanks Bernhard R. Link! (Closes: #545699)
- * cmdline/apt-mark:
- - print an error if a new state file can't be created,
- thanks Carl Chenet! (Closes: #521289)
- - print an error and exit if python-apt is not installed,
- thanks Carl Chenet! (Closes: #521284)
* methods/http{,s}.cc
- add config setting for User-Agent to the Acquire group,
thanks Timothy J. Miller! (Closes: #355782)
- add https options which default to http ones (Closes: #557085)
- * ftparchive/writer.{cc,h}:
- - add APT::FTPArchive::LongDescription to be able to disable them
- - add APT::FTPArchive::AlwaysStat to disable the too aggressive
- caching if versions are build multiply times (not recommend)
- Patch by Christoph Goehre, thanks! (Closes: #463260)
- * ftparchive/*:
- - fix a few typos in strings, comments and manpage,
- thanks Karl Goetz! (Closes: #558757)
- * apt-pkg/deb/debsrcrecords.cc:
- - use "diff" filetype for .debian.tar.* files (Closes: #554898)
* debian/apt.cron.daily:
- check cache size even if we do nothing else otherwise, thanks
Francesco Poli for patch(s) and patience! (Closes: #459344)
+ * ftparchive/*:
+ - fix a few typos in strings, comments and manpage,
+ thanks Karl Goetz! (Closes: #558757)
+
+ [ Carl Chenet ]
+ * cmdline/apt-mark:
+ - print an error if a new state file can't be created
+ (Closes: #521289) and
+ - exit nicely if python-apt is not installed (Closes: #521284)
[ Chris Leick ]
+ * doc/de: German translation of manpages (Closes: #552606)
* doc/ various manpages:
- correct various errors, typos and oddities (Closes: #552535)
* doc/apt-secure.8.xml:
- replace literal with emphasis tags in Archive configuration
+ * doc/apt-ftparchive.1.xml:
+ - remove informalexample tag which hides the programlisting
+ * doc/apt-get.8.xml:
+ - change equivalent "for" to "to the" (purge command)
+ - clarify --fix-broken sentence about specifying packages
[ Eugene V. Lyubimkin ]
* apt-pkg/contib/strutl.h
@@ -113,13 +283,12 @@ apt (0.7.25) UNRELEASED; urgency=low
- Restrict option names to alphanumerical characters and "/-:._+".
- Deprecate #include, we have apt.conf.d nowadays which should be
sufficient.
- * methods/https.cc:
- - Add support for authentication using netrc (Closes: #518473), patch
- by Jussi Hakala <jussi.hakala@hut.fi>.
* ftparchive/apt-ftparchive.cc:
- Call setlocale() so translations are actually used.
+ * debian/apt.conf.autoremove:
+ - Add kfreebsd-image-* to the list (Closes: #558803)
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 29 Sep 2009 15:51:34 +0200
+ -- Michael Vogt <mvo@debian.org> Tue, 15 Dec 2009 09:21:55 +0100
apt (0.7.24) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 357fb3f5f..d756871d1 100644
--- a/debian/control
+++ b/debian/control
@@ -11,7 +11,7 @@ Vcs-Bzr: http://bzr.debian.org/apt/debian-sid/
Package: apt
Architecture: any
-Depends: ${shlibs:Depends}, debian-archive-keyring
+Depends: ${shlibs:Depends}, debian-archive-keyring, ${misc:Depends}
Replaces: libapt-pkg-doc (<< 0.3.7), libapt-pkg-dev (<< 0.3.7)
Provides: ${libapt-pkg:provides}
Suggests: aptitude | synaptic | wajig, dpkg-dev, apt-doc, bzip2, lzma, python-apt
@@ -26,6 +26,7 @@ Description: Advanced front-end for dpkg
Package: apt-doc
Architecture: all
Priority: optional
+Depends: ${misc:Depends}
Replaces: apt (<< 0.5.4.9)
Section: doc
Description: Documentation for APT
@@ -35,7 +36,7 @@ Description: Documentation for APT
Package: libapt-pkg-dev
Architecture: any
Priority: optional
-Depends: apt (= ${binary:Version}), apt-utils (= ${binary:Version}), ${libapt-pkg:provides}, ${libapt-inst:provides}
+Depends: apt (= ${binary:Version}), apt-utils (= ${binary:Version}), ${libapt-pkg:provides}, ${libapt-inst:provides}, ${misc:Depends}
Section: libdevel
Description: Development files for APT's libapt-pkg and libapt-inst
This package contains the header files and libraries for
@@ -45,6 +46,7 @@ Description: Development files for APT's libapt-pkg and libapt-inst
Package: libapt-pkg-doc
Architecture: all
Priority: optional
+Depends: ${misc:Depends}
Section: doc
Description: Documentation for APT development
This package contains documentation for development of the APT
@@ -52,7 +54,7 @@ Description: Documentation for APT development
Package: apt-utils
Architecture: any
-Depends: ${shlibs:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
Provides: ${libapt-inst:provides}
Replaces: apt (<< 0.5.9)
Description: APT utility programs
@@ -65,7 +67,7 @@ Description: APT utility programs
Package: apt-transport-https
Architecture: any
-Depends: ${shlibs:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
Priority: optional
Description: APT https transport
This package contains a APT https transport. It makes it possible to
diff --git a/debian/rules b/debian/rules
index f69c0cffb..37c96ef20 100755
--- a/debian/rules
+++ b/debian/rules
@@ -78,21 +78,21 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
include buildlib/libversion.mak
# Determine which package we should provide in the control files
-LIBAPTPKG_PROVIDE=libapt-pkg-$(LIBAPTPKG_MAJOR)
-LIBAPTINST_PROVIDE=libapt-inst-$(LIBAPTINST_MAJOR)
+LIBAPTPKG_PROVIDE=libapt-pkg$(LIBEXT)-$(LIBAPTPKG_MAJOR)
+LIBAPTINST_PROVIDE=libapt-inst$(LIBEXT)-$(LIBAPTINST_MAJOR)
debian/shlibs.local: apt-pkg/makefile
# We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
# one for the rest of the packages. This ensures that each package gets
# the right overrides..
rm -rf $@ $@.apt $@.apt-utils
- echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
+ echo "libapt-pkg$(LIBEXT) $(LIBAPTPKG_MAJOR)" > $@.apt
- echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
- echo "libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
+ echo "libapt-pkg$(LIBEXT) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
+ echo "libapt-inst$(LIBEXT) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
- echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
- echo "libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
+ echo "libapt-pkg$(LIBEXT) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
+ echo "libapt-inst$(LIBEXT) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
build: build/build-stamp
build-doc: build/build-doc-stamp
@@ -213,7 +213,6 @@ apt: build build-doc debian/shlibs.local
cp debian/bugscript debian/$@/usr/share/bug/apt/script
cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
- cp share/debian-archive.gpg debian/$@/usr/share/$@
cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
# head -n 500 ChangeLog > debian/ChangeLog