summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily5
-rw-r--r--debian/changelog23
2 files changed, 27 insertions, 1 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 1dfaa04a3..efc61362c 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -457,7 +457,10 @@ if check_stamp $UPDATE_STAMP $UpdateInterval; then
# now run apt-xapian-index if it is installed to ensure the index
# is up-to-date
if [ -x /usr/sbin/update-apt-xapian-index ]; then
- nice ionice -c3 update-apt-xapian-index -q
+ if [ "$(dpkg --print-architecture)" = "armel" ]; then
+ xapian_extra_args='-u'
+ fi
+ nice ionice -c3 update-apt-xapian-index -q $xapian_extra_args
fi
else
debug_echo "download updated metadata (error)"
diff --git a/debian/changelog b/debian/changelog
index 88b614ca1..a0f59e019 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,26 @@
+apt (0.8.16~exp5ubuntu13) UNRELEASEDoneiric; urgency=low
+
+ [ Adam Conrad ]
+ * On armel, call update-apt-xapian-index with '-u' to keep the CPU
+ and I/O usage low. We would do this on all arches, but there's a
+ regression risk here, but that's better than killing slow systems.
+
+ [ Michael Vogt ]
+ * cmdline/apt-key:
+ - fix apt-key net-update, thanks to Marc Deslauriers and
+ Adam Conrad for the code review (LP: #857472)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 06 Oct 2011 16:13:00 +0200
+
+apt (0.8.16~exp5ubuntu12) oneiric; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/deb/deblistparser.cc:
+ - fix crash when the dynamic mmap needs to be remapped during
+ LoadReleaseInfo (LP: #854090)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Mon, 26 Sep 2011 13:31:11 +0200
+
apt (0.8.16~exp5ubuntu11) oneiric; urgency=low
[ Colin Watson ]