summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog13
1 files changed, 9 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 7f14502e7..786b8a86f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -30,16 +30,21 @@ apt (0.7.22) UNRELEASED; urgency=low
* add Debug::pkgProblemResolver::ShowScores and make the scores
adjustable
* do not write state file in simulate mode (closes: #433007)
- * add hook for auto-install (closes: #470035)
- * support IsAutoInstallOk in the resolver too
+ * add hook for MarkInstall and MarkDelete (closes: #470035)
* fix typo in apt-pkg/acquire.cc which prevents Dl-Limit to work
correctly when downloading from multiple sites (Closes: #534752)
+ * add the various foldmarkers in apt-pkg & cmdline (no code change)
+ * versions with a pin of -1 shouldn't be a candidate (Closes: #355237)
+ * prefer mmap as memory allocator in MMap instead of a static char
+ array which can (at least in theory) grow dynamic
+ * add a segfault handler to MMap to show the Cache-Limit message, which
+ can be deactivated with MMap::SegfaultHandler=false (Closes: 535218)
[ Michael Vogt ]
- * honor the dpkg hold state in AutoInstOk (closes: #64141)
+ * honor the dpkg hold state in new Marker hooks (closes: #64141)
* debian/apt.cron.daily:
- if the timestamp is too far in the future, delete it
-
+
[ Julian Andres Klode ]
* apt-pkg/contrib/configuration.cc: Fix a small memory leak in
ReadConfigFile.