summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog64
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules10
3 files changed, 73 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index f50bac52d..2f6dbbd28 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,67 @@
+apt (0.9.7.1ubuntu1) quantal; urgency=low
+
+ * merged from the debian-sid branch
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 29 Jun 2012 15:33:42 +0200
+
+apt (0.9.7.1) unstable; urgency=low
+
+ [ Program translation updates ]
+ * Bulgarian (Damyan Ivanov) (Closes: #678983)
+ * Hungarian (Gabor Kelemen)
+ * Italian (Milo Casagrande)
+ * Slovenian (Andrej Znidarsic)
+ * German (Holger Wansing) (Closes: #679314)
+ * Slovak (Ivan Masár) (Closes: #679448)
+
+ [ David Kalnischkies ]
+ * cmdline/apt-internal-solver.cc, cmdline/apt-mark.cc:
+ - typo fixes and unfuzzy translations
+ * debian/control:
+ - libapt-{pkg,inst} packages should be in section 'libs' instead
+ of 'admin' as by ftp-master override request in #677596
+ - demote debiandoc-sgml to Build-Depends-Indep
+ * doc/makefile:
+ - separate translation building of debiandoc from manpages
+ so that we don't need to build debiandoc for binary packages
+
+ -- Michael Vogt <mvo@debian.org> Fri, 29 Jun 2012 14:26:32 +0200
+
+apt (0.9.7) unstable; urgency=low
+
+ [ Julian Andres Klode ]
+ * apt-pkg/contrib/mmap.cc:
+ - Fix the Fallback option to work correctly, by not calling
+ realloc() on a map mapped by mmap(), and by using malloc
+ and friends instead of new[].
+ - Zero out the new memory allocated with realloc().
+
+ [ Daniel Hartwig ]
+ * apt-pkg/pkgcachegen.cc:
+ - always reset _error->StackCount in MakeStatusCache (Closes: #677175)
+
+ [ David Kalnischkies ]
+ * apt-pkg/deb/deblistparser.cc:
+ - ensure that mixed positive/negative architecture wildcards
+ are handled in the same way as dpkg handles them
+ - use PackageArchitectureMatchesSpecification filter
+ * apt-pkg/cachefilter.cc:
+ - add PackageArchitectureMatchesSpecification (Closes: #672603)
+ * apt-pkg/cacheset.cc:
+ - add PackageContainerInterface::FromGroup to support
+ architecture specifications with wildcards on the commandline
+ * apt-pkg/pkgcache.cc:
+ - do a string comparision for architecture checking in IsMultiArchImplicit
+ as 'unique' strings in the pkgcache aren't unique (Closes: #677454)
+ * buildlib/configure.mak:
+ - print a message detailing how to get config.guess and config.sub
+ in case they are not in /usr/share/misc (Closes: #677312)
+ * cmdline/apt-get.cc:
+ - print a friendly message in 'download' if a package can't be
+ downloaded (Closes: #677887)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 19 Jun 2012 16:42:43 +0200
+
apt (0.9.6ubuntu3) quantal; urgency=low
* SECURITY UPDATE: Disable apt-key net-update for now, as validation
diff --git a/debian/control b/debian/control
index 4bdd3ce70..b793d3f04 100644
--- a/debian/control
+++ b/debian/control
@@ -10,8 +10,8 @@ Standards-Version: 3.9.3
Build-Depends: dpkg-dev (>= 1.15.8), debhelper (>= 8.1.3~), libdb-dev,
gettext:any (>= 0.12), libcurl4-gnutls-dev (>= 7.19.0),
zlib1g-dev, libbz2-dev, xsltproc, docbook-xsl, docbook-xml,
- po4a (>= 0.34-2), autotools-dev, autoconf, automake, debiandoc-sgml
-Build-Depends-Indep: doxygen
+ po4a (>= 0.34-2), autotools-dev, autoconf, automake
+Build-Depends-Indep: doxygen, debiandoc-sgml
Build-Conflicts: autoconf2.13, automake1.4
Vcs-Bzr: lp:~ubuntu-core-dev/apt/ubuntu
Vcs-Browser: http://code.launchpad.net/apt/ubuntu
@@ -42,6 +42,7 @@ Architecture: any
Multi-Arch: same
Pre-Depends: ${misc:Pre-Depends}
Depends: ${shlibs:Depends}, ${misc:Depends}
+Section: libs
Description: package managment runtime library
This library provides the common functionality for searching and
managing packages as well as information about packages.
@@ -63,6 +64,7 @@ Architecture: any
Multi-Arch: same
Pre-Depends: ${misc:Pre-Depends}
Depends: ${shlibs:Depends}, ${misc:Depends}
+Section: libs
Description: deb package format runtime library
This library provides methods to query and extract information
from deb packages. This includes the control data and the package
diff --git a/debian/rules b/debian/rules
index 27effcfb0..8da5ae790 100755
--- a/debian/rules
+++ b/debian/rules
@@ -70,7 +70,7 @@ LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
export DPKG_GENSYMBOLS_CHECK_LEVEL=0
build: build/build-stamp
-build-doc: build-manpages build/build-doc-stamp
+build-debiandoc: build/build-debiandoc-stamp
build-manpages: build/build-manpages-stamp
# Note that this is unconditionally done first as part of loading environment.mak
@@ -101,9 +101,9 @@ else
endif
touch $@
-build/build-doc-stamp: build/build-manpages-stamp build/configure-stamp
+build/build-debiandoc-stamp: build/configure-stamp
# Add here commands to compile the package.
- $(MAKE) doc
+ $(MAKE) debiandoc
touch $@
build/build-manpages-stamp: build/configure-stamp
@@ -124,7 +124,7 @@ debian/%.install: debian/%.install.in
binary-indep: apt-doc libapt-pkg-doc
# Build architecture-independent files here.
-libapt-pkg-doc: build-doc
+libapt-pkg-doc: build-debiandoc
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -150,7 +150,7 @@ libapt-pkg-doc: build-doc
dh_md5sums -p$@
dh_builddeb -p$@
-apt-doc: build-doc
+apt-doc: build-debiandoc
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@