summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.conf.autoremove8
-rw-r--r--debian/apt.dirs1
-rw-r--r--debian/changelog15
-rwxr-xr-xdebian/rules2
4 files changed, 19 insertions, 7 deletions
diff --git a/debian/apt.conf.autoremove b/debian/apt.conf.autoremove
new file mode 100644
index 000000000..98143ce9a
--- /dev/null
+++ b/debian/apt.conf.autoremove
@@ -0,0 +1,8 @@
+APT
+{
+ NeverAutoRemove
+ {
+ "^linux-image.*";
+ "^linux-restricted-modules.*";
+ };
+};
diff --git a/debian/apt.dirs b/debian/apt.dirs
index e1cb738fa..1543e8bb1 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -2,6 +2,7 @@ usr/bin
usr/lib/apt/methods
usr/lib/dpkg/methods/apt
etc/apt
+etc/apt/apt.conf.d
etc/apt/sources.list.d
var/cache/apt/archives/partial
var/lib/apt/lists/partial
diff --git a/debian/changelog b/debian/changelog
index 6dc69ba12..d8f90ba40 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,20 +1,23 @@
apt (0.6.45ubuntu6) edgy; urgency=low
+ [Michael Vogt]
+ * cmdline/apt-get.cc:
+ - always show auto-removable packages and give a hint how to remove
+ them
+ * debian/apt.conf.autoremove:
+ - exlucde linux-image and linux-restricted-modules from ever being
+ auto-removed
+ [Ian Jackson]
* Tests pass without code changes! Except that we need this:
* Bump cache file major version to force rebuild so that Breaks
dependencies are included.
* Don't depend on or suggest any particular dpkg or dpkg-dev versions;
--auto-deconfigure is very very old and dpkg-dev's Breaks support
is more or less orthogonal.
-
- -- Ian Jackson <iwj@ubuntu.com> Tue, 5 Sep 2006 19:50:02 +0100
-
-apt (0.6.45ubuntu6~iwj) unstable; urgency=low
-
* Initial draft of `Breaks' implementation. Appears to compile,
but as yet *completely untested*.
- -- Ian Jackson <ian@davenant.greenend.org.uk> Fri, 25 Aug 2006 15:39:07 +0100
+ --
apt (0.6.45ubuntu5) edgy; urgency=low
diff --git a/debian/rules b/debian/rules
index 333d4ad5b..ffc23402e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -211,7 +211,7 @@ apt: build debian/shlibs.local
cp debian/bugscript debian/$@/usr/share/bug/apt/script
cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
-
+ cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
# head -n 500 ChangeLog > debian/ChangeLog
# make rosetta happy and remove pot files in po/ (but leave stuff