summaryrefslogtreecommitdiff
path: root/test/interactive-helper/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/interactive-helper/CMakeLists.txt')
-rw-r--r--test/interactive-helper/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/interactive-helper/CMakeLists.txt b/test/interactive-helper/CMakeLists.txt
new file mode 100644
index 000000000..fc08d6a8f
--- /dev/null
+++ b/test/interactive-helper/CMakeLists.txt
@@ -0,0 +1,10 @@
+add_executable(mthdcat mthdcat.cc)
+target_link_libraries(mthdcat apt-pkg)
+add_executable(testdeb testdeb.cc)
+target_link_libraries(testdeb apt-pkg apt-inst)
+add_executable(extract-control extract-control.cc)
+target_link_libraries(extract-control apt-pkg apt-inst)
+add_executable(aptwebserver aptwebserver.cc)
+target_link_libraries(aptwebserver apt-pkg ${CMAKE_THREAD_LIBS_INIT})
+add_executable(test_fileutl test_fileutl.cc)
+target_link_libraries(test_fileutl apt-pkg)