summaryrefslogtreecommitdiff
path: root/test/libapt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/libapt/CMakeLists.txt')
-rw-r--r--test/libapt/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/libapt/CMakeLists.txt b/test/libapt/CMakeLists.txt
index f7cd5b2f6..86c0b28b5 100644
--- a/test/libapt/CMakeLists.txt
+++ b/test/libapt/CMakeLists.txt
@@ -22,6 +22,9 @@ if(NOT GTEST_FOUND AND EXISTS ${GTEST_ROOT})
endif()
if(GTEST_FOUND)
+ # Definition of the C++ files used to build the test binary - note that this
+ # is expanded at CMake time, so you have to rerun cmake if you add or remove
+ # a file (you can just run cmake . in the build directory)
file(GLOB files gtest_runner.cc *-helpers.cc *_test.cc)
add_executable(libapt_test ${files})
target_include_directories(libapt_test PRIVATE ${GTEST_INCLUDE_DIRS})