summaryrefslogtreecommitdiff
path: root/data/lighttpd/lighttpd-1.4.53/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'data/lighttpd/lighttpd-1.4.53/CMakeLists.txt')
-rw-r--r--data/lighttpd/lighttpd-1.4.53/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/data/lighttpd/lighttpd-1.4.53/CMakeLists.txt b/data/lighttpd/lighttpd-1.4.53/CMakeLists.txt
new file mode 100644
index 000000000..caaca1bd1
--- /dev/null
+++ b/data/lighttpd/lighttpd-1.4.53/CMakeLists.txt
@@ -0,0 +1,27 @@
+project(lighttpd C)
+
+cmake_minimum_required(VERSION 2.8.2 FATAL_ERROR)
+
+set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/scripts/cmake)
+
+include(CTest)
+
+enable_testing()
+
+set(CPACK_PACKAGE_VERSION_MAJOR 1)
+set(CPACK_PACKAGE_VERSION_MINOR 4)
+set(CPACK_PACKAGE_VERSION_PATCH 53)
+set(CPACK_PACKAGE_VERSION "${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH}")
+
+set(CPACK_RESOURCE_FILE_LICENSE "${CMAKE_SOURCE_DIR}/COPYING")
+set(CPACK_RESOURCE_FILE_README "${CMAKE_SOURCE_DIR}/README")
+set(CPACK_PACKAGE_VENDOR "jan@kneschke.de")
+
+set(CPACK_SOURCE_GENERATOR "TGZ")
+set(CPACK_SOURCE_IGNORE_FILES "/\\\\.;~$;/_;build/;CMakeFiles/;CMakeCache;gz$;Makefile\\\\.;trace;Testing/;foo;autom4te;cmake_install;CPack;\\\\.pem;ltmain.sh;configure;libtool;/config\\\\.;missing;autogen.sh;install-sh;Dart;aclocal;log$;Makefile$")
+
+set(CPACK_SOURCE_PACKAGE_FILE_NAME "${CMAKE_PROJECT_NAME}-${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}.${CPACK_PACKAGE_VERSION_PATCH}")
+
+add_subdirectory(src build)
+#add_subdirectory(doc)
+add_subdirectory(tests)