summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2017-06-28 10:55:57 +0200
committerJulian Andres Klode <jak@debian.org>2017-06-28 15:52:38 +0200
commit2851ec6cf037d552118b885be0dd7796d74730c6 (patch)
tree31fddfa989f328b28806149435857c753dfcfd5f /CMakeLists.txt
parent5666084ecfe140aaa3f89388de557c2f875b4244 (diff)
methods: Add HTTPS support to http method, using GnuTLS
The http method will eventually replace the curl-based https method, but for now, this is an opt-in experiment that can be enabled by setting Dir::Bin::Methods::https to "http". Known issues: - We do not support HTTPS proxies yet - We do not support proxying HTTPS connections yet (CONNECT) - IssuerCert and SslForceVersion are unsupported Gbp-Dch: Full
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83af9bd5a..8f8ffb898 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -81,6 +81,10 @@ find_package(CURL REQUIRED)
if (CURL_FOUND)
set(HAVE_CURL 1)
endif()
+find_package(GnuTLS REQUIRED)
+if (GNUTLS_FOUND)
+ set(HAVE_GNUTLS 1)
+endif()
# (De)Compressor libraries
find_package(ZLIB REQUIRED)