summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <julian.klode@canonical.com>2019-04-15 11:32:50 +0200
committerJulian Andres Klode <julian.klode@canonical.com>2019-05-03 16:37:50 +0200
commit60cc44d160af02c49614653c97bfa3e4e5c9601d (patch)
treebcb3a3031af6f0ead0156932453869822567f913 /CMakeLists.txt
parente547a738922b434ae0bad32ead26a1a3c2095d1e (diff)
Prevent shutdown while running dpkg
As long as we are running dpkg, keep an inhibitor that blocks us from shutting down. LP: #1820886
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29cd30bc6..02bad9377 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -117,6 +117,11 @@ if (UDEV_FOUND)
set(HAVE_UDEV 1)
endif()
+find_package(Systemd)
+if (SYSTEMD_FOUND)
+ set(HAVE_SYSTEMD 1)
+endif()
+
find_package(Seccomp)
if (SECCOMP_FOUND)
set(HAVE_SECCOMP 1)