summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <julian.klode@canonical.com>2019-02-04 16:10:44 +0100
committerJulian Andres Klode <julian.klode@canonical.com>2019-02-05 11:20:46 +0100
commit62b5a521ff61bd01a605ff95ad2b18d87006f6ff (patch)
treea0b053c84a69b17bb12bce5ae76a4e555e9c54b4 /CMakeLists.txt
parent7775e430c0b17e285a612c115b4d138759761e65 (diff)
CMakeLists.txt: Bump C++ standard version to C++14
Not a lot of fancy new stuff there, but some good stuff. Would like to use C++17, but might not be stable yet.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f1f80e0d3..9b053bfb5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,7 +50,7 @@ add_definitions(${LFS_DEFINITIONS})
link_libraries(${LFS_LIBRARIES})
# Set compiler flags
-set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD 14)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)