summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-08-06 21:11:06 +0200
committerJulian Andres Klode <jak@debian.org>2016-08-06 22:36:02 +0200
commit7def24826c298df77e34fd17bb72c570a22b04bd (patch)
tree7b97d2acd914e4543c3388f061eb3ed0ee294b42 /CMakeLists.txt
parentf3de2dbaf657f9040a4da448c57267de0fef7d33 (diff)
CMake: Add support for building and installing .mo files
Introduce support for building translation domain-specific templates, merging them with the translations, and building a language-specific .mo file. The invocation of xgettext is done in the project source directory, not in the current source directory, and all paths are made relative to the project root, in order to have clean templates. This only supports the C++ source code for now, it unfortunately does not handle the shell scripts of deselect yet.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90e5272c9..cba893227 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,7 @@ endif()
# Include stuff
include(Misc)
+include(Translations)
include(CheckIncludeFiles)
include(CheckFunctionExists)
include(CheckStructHasMember)
@@ -130,3 +131,4 @@ add_subdirectory(cmdline)
add_subdirectory(dselect)
add_subdirectory(ftparchive)
add_subdirectory(methods)
+add_subdirectory(po)