summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <julian.klode@canonical.com>2019-04-15 11:32:50 +0200
committerJulian Andres Klode <julian.klode@canonical.com>2019-05-03 16:48:56 +0200
commit96aef11a5cf400377a52f7e93e70944b17e249d1 (patch)
tree6ba3f312a3c3bec2a527f804f3dd28e29dbae758 /CMakeLists.txt
parent61159a9be93f930066ad39e4f8eb658e18853b8e (diff)
Prevent shutdown while running dpkg
As long as we are running dpkg, keep an inhibitor that blocks us from shutting down. LP: #1820886
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 60f329078..500186105 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -115,6 +115,11 @@ if (UDEV_FOUND)
set(HAVE_UDEV 1)
endif()
+find_package(Systemd)
+if (SYSTEMD_FOUND)
+ set(HAVE_SYSTEMD 1)
+endif()
+
find_package(Seccomp)
if (SECCOMP_FOUND)
set(HAVE_SECCOMP 1)