summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <julian.klode@canonical.com>2019-04-15 11:32:50 +0200
committerJulian Andres Klode <julian.klode@canonical.com>2019-05-07 11:17:52 +0200
commitc5b8a857f2535fe284426cefda2fbd1bbb3d5808 (patch)
tree03e99b4fc41c6c84d17053ae2016118eb97caa75 /CMakeLists.txt
parenta76f9705ab4dfa439fa2c8788ee67d0766700d07 (diff)
Prevent shutdown while running dpkg
As long as we are running dpkg, keep an inhibitor that blocks us from shutting down. LP: #1820886 (cherry picked from commit 96aef11a5cf400377a52f7e93e70944b17e249d1) (cherry picked from commit 8ea79afcadead5a5b7d94bf8623cb833859f6d80)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0481f4ee8..b45692517 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,6 +114,11 @@ if (UDEV_FOUND)
set(HAVE_UDEV 1)
endif()
+find_package(Systemd)
+if (SYSTEMD_FOUND)
+ set(HAVE_SYSTEMD 1)
+endif()
+
find_package(Seccomp)
if (SECCOMP_FOUND)
set(HAVE_SECCOMP 1)