summaryrefslogtreecommitdiff
path: root/apt-pkg/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-08-23 13:42:54 +0200
committerJulian Andres Klode <jak@debian.org>2016-08-26 15:49:14 +0200
commitad5282bb0c97fd0254b20fb71a59d0f755c3ed65 (patch)
tree55af94cc08cc0e0ab1e8d3e2c9c1ff8d6d52e618 /apt-pkg/CMakeLists.txt
parent374ab017c262108c0f12bcdc8d15ff242c7adc56 (diff)
CMake: Do not use -lresolv if res_init exists in libc
Gbp-Dch: ignore
Diffstat (limited to 'apt-pkg/CMakeLists.txt')
-rw-r--r--apt-pkg/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/apt-pkg/CMakeLists.txt b/apt-pkg/CMakeLists.txt
index 9bbc6bd98..3f85bc143 100644
--- a/apt-pkg/CMakeLists.txt
+++ b/apt-pkg/CMakeLists.txt
@@ -30,7 +30,7 @@ target_include_directories(apt-pkg
${LZMA_INCLUDE_DIRS}
${LZ4_INCLUDE_DIRS})
target_link_libraries(apt-pkg
- PRIVATE -lutil ${CMAKE_DL_LIBS} -lresolv
+ PRIVATE -lutil ${CMAKE_DL_LIBS} ${RESOLV_LIBRARIES}
${CMAKE_THREAD_LIBS_INIT}
${ZLIB_LIBRARIES}
${BZIP2_LIBRARIES}