summaryrefslogtreecommitdiff
path: root/apt-pkg/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-09-11 13:58:40 +0200
committerJulian Andres Klode <jak@debian.org>2016-09-11 17:44:17 +0200
commitbccb344412a0e97afdf0aaaf41a31124c84f6eaa (patch)
treec57341872a3d83bc5a01ea5b45d9b25d631afacc /apt-pkg/CMakeLists.txt
parent422a2eba84361a8dfd84b549c13037512779c572 (diff)
Coverage: Do not print messages from gcov
We need to ignore messages from gcov. All those messages start with profiling: and are printed using vfprintf(), so the only thing we can do is add a library overriding those functions and linking apt-pkg to it.
Diffstat (limited to 'apt-pkg/CMakeLists.txt')
-rw-r--r--apt-pkg/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/apt-pkg/CMakeLists.txt b/apt-pkg/CMakeLists.txt
index bdaa93d67..1b493c819 100644
--- a/apt-pkg/CMakeLists.txt
+++ b/apt-pkg/CMakeLists.txt
@@ -49,3 +49,7 @@ add_version_script(apt-pkg)
install(TARGETS apt-pkg LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
install(FILES ${headers} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/apt-pkg)
flatify(${PROJECT_BINARY_DIR}/include/apt-pkg/ "${headers}")
+
+if(CMAKE_BUILD_TYPE STREQUAL "Coverage")
+ target_link_libraries(apt-pkg PUBLIC noprofile)
+endif()