summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2014-09-24 22:18:16 +0200
committerJulian Andres Klode <jak@debian.org>2015-08-13 15:19:30 +0200
commit5a3264396f9b167fa99fb6e375ae8b978d829a39 (patch)
tree6c9055a3b03959df3ee6fb1a045eee6256fcba90 /configure.ac
parent98cc7fd2c1d397623960baf69ae3cec04a87a23e (diff)
Use setresuid() and setresgid() where available
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2221833a1..feba7be61 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,9 +174,11 @@ AC_EGREP_HEADER(h_errno, netdb.h, [AC_MSG_RESULT(normal)],
dnl check for setuid checking function
-AC_CHECK_FUNCS(getresuid getresgid)
+AC_CHECK_FUNCS(getresuid getresgid setresuid setresgid)
AC_SUBST(HAVE_GETRESUID)
AC_SUBST(HAVE_GETRESGID)
+AC_SUBST(HAVE_SETRESUID)
+AC_SUBST(HAVE_SETRESGID)
dnl Check for doxygen
AC_PATH_PROG(DOXYGEN, doxygen)