summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2015-12-28 00:07:03 +0100
committerJulian Andres Klode <jak@debian.org>2016-01-07 14:28:27 +0100
commite3fbd54cee3fffecbf4f7c384e0aad715fc68218 (patch)
treef6376dd48b8f6917c2bd36dca183f1d6eeb5c07f /configure.ac
parentd4cfc24887851fa55f93a1a3c09f662b80f97729 (diff)
FileFd: (native) LZ4 support
Implement native support for LZ4 compression, using the official lz4 library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 60c634047..5c49a1094 100644
--- a/configure.ac
+++ b/configure.ac
@@ -108,6 +108,13 @@ if test "x$HAVE_ZLIB" = "xyes"; then
AC_DEFINE(HAVE_ZLIB)
fi
+HAVE_LZ4=no
+AC_CHECK_LIB(lz4, LZ4F_createCompressionContext,[AC_CHECK_HEADER(lz4frame.h, [HAVE_LZ4=yes], [])], [])
+AC_SUBST(HAVE_LZ4)
+if test "x$HAVE_LZ4" = "xyes"; then
+ AC_DEFINE(HAVE_LZ4)
+fi
+
HAVE_BZ2=no
AC_CHECK_LIB(bz2, BZ2_bzopen,[AC_CHECK_HEADER(bzlib.h, [HAVE_BZ2=yes], [])], [])
AC_SUBST(HAVE_BZ2)