summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2007-08-01 19:51:20 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2007-08-01 19:51:20 -0300
commit5b28c8040795b53a4df54f33e57976720558ed32 (patch)
tree1e689cda085cf6252926cf2a28de453e10ac6acd /configure.in
parent64a3bcac6e4ea6c166f254a1c0f15b23b5dd92dc (diff)
* Applied patch from Aurelien Jarno <aurel32@debian.org> to fix wrong
directory downloading on non-linux architectures (closes: #435597)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 2 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index c33451390..0294b9ae7 100644
--- a/configure.in
+++ b/configure.in
@@ -80,20 +80,13 @@ dnl Converts the ARCH to be something singular for this general CPU family
dnl This is often the dpkg architecture string.
dnl First check against the full canonical canoncial-system-type in $target
dnl and if that fails, just look for the cpu
-AC_MSG_CHECKING(system architecture)
+AC_MSG_CHECKING(debian architecture)
archset="`dpkg-architecture -qDEB_HOST_ARCH`"
if test "x$archset" = "x"; then
AC_MSG_ERROR([failed: use --host= or output from dpkg-architecture])
fi
AC_MSG_RESULT($archset)
-AC_DEFINE_UNQUOTED(COMMON_CPU,"$archset")
-
-dnl Get a common name for the host OS - this is primarily only for HURD and is
-dnl non fatal if it fails
-AC_MSG_CHECKING(system OS)
-osset="`dpkg-architecture -qDEB_HOST_ARCH_OS`"
-AC_MSG_RESULT($osset)
-AC_DEFINE_UNQUOTED(COMMON_OS,"$osset")
+AC_DEFINE_UNQUOTED(COMMON_ARCH,"$archset")
dnl We use C99 types if at all possible
AC_CACHE_CHECK([for C99 integer types],c9x_ints,[