summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2012-05-21 16:50:52 +0200
committerDavid Kalnischkies <kalnischkies@gmail.com>2012-05-21 16:50:52 +0200
commit65bf851838611139239805bee63a7cea4cb0a309 (patch)
tree89865869c0b4ca26bc0f0a2774c43d3b122aa3a1 /configure.in
parent5c1715d8f847a5a3d8b8128d2dcc8a7622a9df1b (diff)
* buildlib/inttypes.h.in:
- remove inttypes.h compatibility as providing such a c99 types compatibility conflicts with the usage of c99 type long long
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in45
1 files changed, 1 insertions, 44 deletions
diff --git a/configure.in b/configure.in
index f98f288b1..d574c18e5 100644
--- a/configure.in
+++ b/configure.in
@@ -119,12 +119,6 @@ fi
AC_MSG_RESULT($archset)
AC_DEFINE_UNQUOTED(COMMON_ARCH,"$archset")
-dnl We use C99 types if at all possible
-AC_CACHE_CHECK([for C99 integer types],apt_cv_c9x_ints,[
- AC_TRY_COMPILE([#include <inttypes.h>],
- [uint8_t Foo1;uint16_t Foo2;uint32_t Foo3;],
- apt_cv_c9x_ints=yes,apt_cv_c9x_ints=no)])
-
dnl Single Unix Spec statvfs
AC_CHECK_FUNC(statvfs,[HAVE_STATVFS=yes])
AC_SUBST(HAVE_STATVFS)
@@ -144,46 +138,9 @@ dnl We should use the real timegm function if we have it.
AC_CHECK_FUNC(timegm,AC_DEFINE(HAVE_TIMEGM))
AC_SUBST(HAVE_TIMEGM)
-dnl Check the sizes etc. of the architecture
-dnl This is stupid, it should just use the AC macros like it does below
-dnl Cross compilers can either get a real C library or preload the cache
-dnl with their size values.
-changequote(,)
-archline="`awk \" ! /^#|^\\\$/ {if (match(\\\"$archset\\\",\\\$1)) {print; exit}}\" $srcdir/buildlib/sizetable | cut -f 2- -d ' '`"
-if test "x$archline" != "x"; then
- changequote([,])
- set $archline
- if test "$1" = "little"; then
- ac_cv_c_bigendian=no
- else
- ac_cv_c_bigendian=yes
- fi
- size_char=$2
- size_int=$3
- size_short=$4
- size_long=$5
-fi
-
-dnl I wonder what AC_C_BIGENDIAN does if you cross compile...
-dnl This is probably bogus, as above we only care if we have to build our own
-dnl C9x types.
-if test "$cross_compiling" = "yes" -a "x$archline" = "x"; then
- AC_MSG_ERROR(When cross compiling, architecture must be present in sizetable)
-fi
+dnl Check the architecture
AC_C_BIGENDIAN
-dnl We do not need this if we have inttypes!
-HAVE_C9X=yes
-if test x"$apt_cv_c9x_ints" = x"no"; then
- AC_CHECK_SIZEOF(char,$size_char)
- AC_CHECK_SIZEOF(int,$size_int)
- AC_CHECK_SIZEOF(short,$size_short)
- AC_CHECK_SIZEOF(long,$size_long)
-
- HAVE_C9X=
- AC_SUBST(HAVE_C9X)
-fi
-
dnl HP-UX sux..
AC_MSG_CHECKING(for missing socklen_t)
AC_EGREP_HEADER(socklen_t, sys/socket.h,[AC_MSG_RESULT(no)],[