summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 16:55:32 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 16:55:32 +0000
commitb819effdc984e492bbce459faa7432931ccfeb58 (patch)
tree3e99081e2974d317068086a40a8549f4e6c995c0 /configure.in
parent1ae93c94429de697fb17f7067367fbf32fd3b6fc (diff)
OpenBSD fixes
Author: jgg Date: 1999-12-11 02:11:10 GMT OpenBSD fixes
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c0ecdaa05..366d70375 100644
--- a/configure.in
+++ b/configure.in
@@ -31,7 +31,9 @@ AC_CHECK_TOOL_PREFIX dnl recheck, in case the initial guess was wrong
dnl Check for other programs
AC_PROG_CXX
-#AC_LANG_CPLUSPLUS
+AC_PROG_CPP
+AC_PROG_RANLIB
+AC_CHECK_TOOL(AR,ar,"ar")
dnl Checks for sockets
SAVE_LIBS="$LIBS"
@@ -98,6 +100,13 @@ dnl Single Unix Spec statvfs
AC_CHECK_FUNC(statvfs,[HAVE_STATVFS=yes])
AC_SUBST(HAVE_STATVFS)
+dnl Arg, linux and bsd put their statfs function in different places
+if test x"$HAVE_STATVFS" != x"yes"; then
+ AC_EGREP_HEADER(statfs,sys/vfs.h,[AC_DEFINE(HAVE_VFS_H)],[
+ AC_EGREP_HEADER(statfs,sys/mount.h,[AC_DEFINE(HAVE_MOUNT_H)],[AC_MSG_ERROR(failed: Need statvfs)])
+ ])
+fi
+
dnl Check the sizes etc. of the architecture
changequote(,)
if archline="`grep \"^$archset\" $srcdir/buildlib/sizetable | cut -f 2- -d ' '`";then