summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormartin@piware.de <>2010-06-11 11:16:22 +0200
committermartin@piware.de <>2010-06-11 11:16:22 +0200
commitbcc27ad808016b27bba7d7d137098df6abf766c3 (patch)
treef6dd0f0e6e68fedef83eb8df988624764b69b2a2 /configure.in
parentde2c243cd22b3bad3c27a5f3f7a35f0698cf07f1 (diff)
* configure.in:
- Check for zlib library and headers.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 82785a9dd..015b142ea 100644
--- a/configure.in
+++ b/configure.in
@@ -83,6 +83,10 @@ AC_CHECK_LIB(curl, curl_easy_init,
AC_SUBST(BDBLIB)
+AC_CHECK_LIB(z, gzopen,
+ [AC_CHECK_HEADER(zlib.h, [], AC_MSG_ERROR([failed: zlib.h not found]))],
+ AC_MSG_ERROR([failed: Need libz]))
+
dnl Converts the ARCH to be something singular for this general CPU family
dnl This is often the dpkg architecture string.
dnl First check against the full canonical canoncial-system-type in $target