summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 16:55:23 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 16:55:23 +0000
commitf43579d10c48a2a21c8f418a2a1a7de118b52429 (patch)
treec216058162ad69f36957a47c1f8996ec1fe54476 /configure.in
parentc0f453871317ecccff95b132a093e30288555036 (diff)
Removed the tl_* macros, as dpkg doesn't use them, so w...
Author: doogie Date: 1999-12-10 03:20:21 GMT Removed the tl_* macros, as dpkg doesn't use them, so why should we? Added smp configure support detection, so on cpu >= 2, we compile in parallel. The default multiplier is 2(2 processes per cpu) on machines with more than one cpu. Non-smp boxen compile 1 process at a time.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 93a9e3f6a..609c1643e 100644
--- a/configure.in
+++ b/configure.in
@@ -21,18 +21,18 @@ AC_DEFINE_UNQUOTED(VERSION,"0.3.15")
AC_DEFINE_UNQUOTED(PACKAGE,"apt")
dnl Tom's host stuff
-tl_CHECK_TOOL_PREFIX dnl Initial guess
+AC_CHECK_TOOL_PREFIX dnl Initial guess
dnl Check our C compiler
-tl_PROG_CC
+AC_PROG_CC
AC_ISC_POSIX
dnl Check the host arch (build+target not needed... yet)
-tl_CANONICAL_HOST
-tl_CHECK_TOOL_PREFIX dnl recheck, in case the initial guess was wrong
+AC_CANONICAL_HOST
+AC_CHECK_TOOL_PREFIX dnl recheck, in case the initial guess was wrong
dnl Check for other programs
-tl_PROG_CXX
+AC_PROG_CXX
AC_LANG_CPLUSPLUS
dnl Checks for X11
AC_PATH_X
@@ -123,4 +123,6 @@ AC_CHECK_PROG(DEBIANDOC_TEXT,debiandoc2text,"yes","")
dnl Check for YODL
AC_CHECK_PROG(YODL_MAN,yodl2man,"yes","")
+ah_NUM_PROCS
+
AC_OUTPUT(environment.mak:buildlib/environment.mak.in makefile:buildlib/makefile.in,make dirs)