summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Vogt <egon@bottom>2007-06-06 23:07:06 +0200
committerMichael Vogt <egon@bottom>2007-06-06 23:07:06 +0200
commitfaa6596e09eec9535189c5baa7a6d2d4531f9239 (patch)
tree9846a3966c0cd46a3098909e38eba579c114f5ee /configure.in
parent90485a0039fcf308b0d7fc056d39ee4b91b76c58 (diff)
parent0fa17428d9905865fe2d586f3787ebc590ca5a24 (diff)
* vi.po: Updated to 515t. Closes: #426976
* eu.po: Updated to 515t. Closes: #423766 * pt.po: 515t. Closes: #423111 * fr.po: Updated by Christian Perrier * Update all PO and the POT. Gives 513t2f for formerly complete translations * buildlib/archtable: - added support for sh3/sh4 (closes: #424870) - added support for m32r (closes: #394096) * buildlib/systemtable: - added support for lpia * configure.in: - check systemtable for architecture mapping too
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d6755769e..4aa56e117 100644
--- a/configure.in
+++ b/configure.in
@@ -78,10 +78,15 @@ AC_SUBST(BDBLIB)
dnl Converts the ARCH to be something singular for this general CPU family
dnl This is often the dpkg architecture string.
+dnl First check against the full canonical canoncial-system-type in $target
+dnl and if that fails, just look for the cpu
AC_MSG_CHECKING(system architecture)
-archset="`awk \" ! /^#|^\\\$/ { if(match(\\\"$target_cpu\\\",\\\"^\\\"\\\$1\\\"\\\$\\\")) {print \\\$2; exit}}\" $srcdir/buildlib/archtable`"
+archset="`awk \" ! /^#|^\\\$/ { if(match(\\\"$target\\\",\\\"^\\\"\\\$1\\\"\\\$\\\")) {print \\\$2; exit}}\" $srcdir/buildlib/systemtable`"
if test "x$archset" = "x"; then
+ archset="`awk \" ! /^#|^\\\$/ { if(match(\\\"$target_cpu\\\",\\\"^\\\"\\\$1\\\"\\\$\\\")) {print \\\$2; exit}}\" $srcdir/buildlib/archtable`"
+ if test "x$archset" = "x"; then
AC_MSG_ERROR(failed: use --host= or check buildlib/archtable)
+ fi
fi
AC_MSG_RESULT($archset)
AC_DEFINE_UNQUOTED(COMMON_CPU,"$archset")